Skip to content

Commit

Permalink
games-engines/love: fix compilation error in 0.7 and 0.8
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/672558
Signed-off-by: Marek Szuba <[email protected]>
  • Loading branch information
Marek Szuba committed Oct 13, 2020
1 parent 1b04c6c commit a8dce7e
Show file tree
Hide file tree
Showing 4 changed files with 83 additions and 4 deletions.
19 changes: 19 additions & 0 deletions games-engines/love/files/love-0.7.2-opengl_glext_prototypes.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
diff -ur love-HEAD.orig/src/modules/graphics/opengl/Framebuffer.cpp love-HEAD/src/modules/graphics/opengl/Framebuffer.cpp
--- love-HEAD.orig/src/modules/graphics/opengl/Framebuffer.cpp 2019-06-03 01:15:56.600016765 +0200
+++ love-HEAD/src/modules/graphics/opengl/Framebuffer.cpp 2019-06-03 01:16:16.737916762 +0200
@@ -1,3 +1,4 @@
+#define GL_GLEXT_PROTOTYPES
#include "Framebuffer.h"
#include <common/Matrix.h>

diff -ur love-HEAD.orig/src/modules/graphics/opengl/SpriteBatch.cpp love-HEAD/src/modules/graphics/opengl/SpriteBatch.cpp
--- love-HEAD.orig/src/modules/graphics/opengl/SpriteBatch.cpp 2019-06-03 01:15:56.601016760 +0200
+++ love-HEAD/src/modules/graphics/opengl/SpriteBatch.cpp 2019-06-03 01:16:31.007845896 +0200
@@ -18,6 +18,7 @@
* 3. This notice may not be removed or altered from any source distribution.
**/

+#define GL_GLEXT_PROTOTYPES
#include "SpriteBatch.h"

// STD
54 changes: 54 additions & 0 deletions games-engines/love/files/love-0.8.0-opengl_glext_prototypes.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
diff -ur love-HEAD.orig/src/modules/graphics/opengl/SpriteBatch.cpp love-HEAD/src/modules/graphics/opengl/SpriteBatch.cpp
--- love-HEAD.orig/src/modules/graphics/opengl/SpriteBatch.cpp
+++ love-HEAD/src/modules/graphics/opengl/SpriteBatch.cpp
@@ -18,6 +18,7 @@
* 3. This notice may not be removed or altered from any source distribution.
**/

+#define GL_GLEXT_PROTOTYPES
#include "SpriteBatch.h"

// STD
--- a/src/modules/graphics/opengl/VertexBuffer.cpp
+++ b/src/modules/graphics/opengl/VertexBuffer.cpp
@@ -18,6 +18,9 @@
* 3. This notice may not be removed or altered from any source distribution.
**/

+#define GL_GLEXT_PROTOTYPES
+#include "SpriteBatch.h"
+
#include "VertexBuffer.h"

#include "common/Exception.h"
--- a/src/modules/graphics/opengl/Graphics.cpp
+++ b/src/modules/graphics/opengl/Graphics.cpp
@@ -18,6 +18,7 @@
* 3. This notice may not be removed or altered from any source distribution.
**/

+#define GL_GLEXT_PROTOTYPES
#include <common/config.h>
#include <common/math.h>
#include <common/Vector.h>
--- a/src/modules/graphics/opengl/PixelEffect.cpp
+++ b/src/modules/graphics/opengl/PixelEffect.cpp
@@ -18,6 +18,7 @@
* 3. This notice may not be removed or altered from any source distribution.
**/

+#define GL_GLEXT_PROTOTYPES
#include "PixelEffect.h"
#include "GLee.h"


--- a/src/modules/graphics/opengl/Canvas.cpp
+++ b/src/modules/graphics/opengl/Canvas.cpp
@@ -18,6 +18,7 @@
* 3. This notice may not be removed or altered from any source distribution.
**/

+#define GL_GLEXT_PROTOTYPES
#include "Canvas.h"
#include "Graphics.h"
#include <common/Matrix.h>
7 changes: 5 additions & 2 deletions games-engines/love/love-0.7.2-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -31,7 +31,10 @@ DEPEND="${RDEPEND}

S="${WORKDIR}/${PN}-HEAD"

PATCHES=( "${FILESDIR}"/${PN}-0.8.0-freetype2.patch )
PATCHES=(
"${FILESDIR}"/${PN}-0.7.2-opengl_glext_prototypes.patch
"${FILESDIR}"/${PN}-0.8.0-freetype2.patch
)

src_install() {
DOCS="readme.txt changes.txt" \
Expand Down
7 changes: 5 additions & 2 deletions games-engines/love/love-0.8.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -29,7 +29,10 @@ DEPEND="${RDEPEND}
media-libs/tiff:0
"

PATCHES=( "${FILESDIR}"/${P}-freetype2.patch )
PATCHES=(
"${FILESDIR}"/${PN}-0.8.0-freetype2.patch
"${FILESDIR}"/${PN}-0.8.0-opengl_glext_prototypes.patch
)

src_install() {
DOCS="readme.md changes.txt" \
Expand Down

0 comments on commit a8dce7e

Please sign in to comment.