Skip to content

Commit

Permalink
games-engines/love: sync the live ebuild with 11.3
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/737904
Signed-off-by: Marek Szuba <[email protected]>
  • Loading branch information
Marek Szuba committed Oct 13, 2020
1 parent db33583 commit bc11115
Showing 1 changed file with 14 additions and 15 deletions.
29 changes: 14 additions & 15 deletions games-engines/love/love-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,16 +1,15 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit gnome2-utils xdg-utils
EAPI=7

inherit xdg-utils

if [[ ${PV} == 9999* ]]; then
inherit mercurial
EHG_REPO_URI="https://bitbucket.org/rude/${PN}"
SRC_URI=""
KEYWORDS=""
inherit git-r3
EGIT_REPO_URI="https://github.com/love2d/${PN}.git"
else
SRC_URI="https://www.bitbucket.org/rude/${PN}/downloads/${P}-linux-src.tar.gz"
SRC_URI="https://github.com/love2d/${PN}/releases/download/${PV}/${P}-linux-src.tar.gz"
KEYWORDS="~amd64 ~arm ~x86"
fi

Expand All @@ -22,7 +21,7 @@ SLOT="0"
IUSE="+luajit"

RDEPEND="sys-libs/zlib
!luajit? ( dev-lang/lua:0[deprecated] )
!luajit? ( dev-lang/lua:0 )
luajit? ( dev-lang/luajit:2 )
media-libs/freetype
media-libs/libmodplug
Expand Down Expand Up @@ -52,23 +51,23 @@ src_install() {
default

find "${D}" -name '*.la' -delete || die
if [ "$SLOT" != "0" ]
then

if [[ ${SLOT} != 0 ]]; then
mv "${ED}/usr/bin/${PN}" "${ED}/usr/bin/${PN}-${SLOT}" || die
mv "${ED}"/usr/share/applications/love{,"-$SLOT"}.desktop || die
sed -i "s|/usr/bin/love|/usr/bin/love-$SLOT|" "${ED}/usr/share/applications/love-$SLOT.desktop" || die
rm "${ED}"/usr/{lib64/liblove.so,share/{mime/packages/love.xml,pixmaps/love.svg,icons/hicolor/scalable/mimetypes/application-x-love-game.svg,man/man1/love.1}} || die
sed -i -e "/^Name=/s/$/ ($SLOT)/" -e "s|/usr/bin/love|/usr/bin/love-$SLOT|" "${ED}/usr/share/applications/love-$SLOT.desktop" || die
rm -r "${ED}"/usr/{lib64/liblove.so,share/{mime/,pixmaps/,icons/,man/}} || die
fi
}

pkg_postinst() {
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
}

0 comments on commit bc11115

Please sign in to comment.