forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-lang/R: bump to 3.3.2, thanks to Neil Shephard (bug #598834)
Package-Manager: portage-2.3.3
- Loading branch information
Denis Dupeyron
committed
Dec 8, 2016
1 parent
14c8b74
commit bda3e8c
Showing
2 changed files
with
202 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST R-20130129.bash_completion.bz2 4209 SHA256 487e969b94563fec98ec58de7e6142e9361d4219088add0fca282b482a9e01b1 SHA512 910b26e16cfebe677f438abfa5f2652e582db143d91dbf0e7d4b1ea33462c7e5c89c3a3619c63ae98bba26b11a5adb16eda9d344f8cdbe4f0feabc546993c1a5 WHIRLPOOL 2368efaed37fcb6e010f6a234864631f68549bd8e3f733561170cc5b28f5557e546d8561246fb265a481a47991a262fec3acf6abc1dc3929a9357405e0d3c6fc | ||
DIST R-3.2.2.tar.gz 29772864 SHA256 9c9152e74134b68b0f3a1c7083764adc1cb56fd8336bec003fd0ca550cd2461d SHA512 71ba470875262b9f00fb6970f209788df4dad30e0a28373b824b60d8bc6401afb7786e65387663c6490c7ddcd2bfd7f808a270a3e63238f3d7565d5f93607138 WHIRLPOOL fea59929ada1d67dafc6ad89409d18ad173af7990384033f490a00e0f794d9919aecf7cd37089d105fe03b9cf64d079e5d148622571cec3eb924c1c5bd00081e | ||
DIST R-3.3.1.tar.gz 29848329 SHA256 3dc59ae5831f5380f83c169bac2103ad052efe0ecec4ffa74bde4d85a0fda9e2 SHA512 d0ff85e99b9ec9cac672aa30d7d1a854778c6a610bcc5336e8c60c8c74f20856f2bfeae085af793fad646ff45cb4677d9d6dcbaa18212591f72f00a02339f4cd WHIRLPOOL 6e2edb60173a54c8b25d16201c24176b3ea837287e6d306c9d2e2c4578764b0d469d9c17228b6be67dda646a4272f30b331dbbc6238a6e851eb5320f04c7f151 | ||
DIST R-3.3.2.tar.gz 29440670 SHA256 d294ad21e9f574fb4828ebb3a94b8cb34f4f304a41687a994be00dd41a4e514c SHA512 06a98687c0b180cb0bfd57440ea26088212d9f48948d503136475bf54b42d72cfec5bea7e333c0cedd60733bd614dd0f8c2eced7e24478b6c89f48e8d0c43482 WHIRLPOOL a68112df87552cc6ca8cd6b78b99dda2a22b8f4cfcd87a4512d541d25ef21358ede1ba71b4d7e9f274bf4e4340de18355a777d9af2ed41c0a498fa11d91cf0d8 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,201 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit bash-completion-r1 autotools eutils flag-o-matic fortran-2 multilib versionator toolchain-funcs | ||
|
||
BCP=${PN}-20130129.bash_completion | ||
DESCRIPTION="Language and environment for statistical computing and graphics" | ||
HOMEPAGE="http://www.r-project.org/" | ||
SRC_URI=" | ||
mirror://cran/src/base/R-3/${P}.tar.gz | ||
https://dev.gentoo.org/~bicatali/distfiles/${BCP}.bz2" | ||
|
||
LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos" | ||
IUSE="cairo doc icu java jpeg lapack minimal nls openmp perl png prefix profile readline static-libs tiff tk X" | ||
REQUIRED_USE="png? ( || ( cairo X ) ) jpeg? ( || ( cairo X ) ) tiff? ( || ( cairo X ) )" | ||
|
||
CDEPEND=" | ||
app-arch/bzip2:0= | ||
app-arch/xz-utils:0= | ||
app-text/ghostscript-gpl | ||
>=dev-libs/libpcre-8.35:3= | ||
virtual/blas:0 | ||
|| ( >=sys-apps/coreutils-8.15 sys-freebsd/freebsd-bin app-misc/realpath ) | ||
cairo? ( x11-libs/cairo:0=[X] x11-libs/pango:0= ) | ||
icu? ( dev-libs/icu:= ) | ||
jpeg? ( virtual/jpeg:0 ) | ||
lapack? ( virtual/lapack:0 ) | ||
perl? ( dev-lang/perl ) | ||
png? ( media-libs/libpng:0= ) | ||
readline? ( sys-libs/readline:0= ) | ||
tiff? ( media-libs/tiff:0= ) | ||
tk? ( dev-lang/tk:0= ) | ||
X? ( x11-libs/libXmu:0= x11-misc/xdg-utils )" | ||
|
||
DEPEND="${CDEPEND} | ||
virtual/pkgconfig | ||
doc? ( | ||
virtual/latex-base | ||
dev-texlive/texlive-fontsrecommended | ||
)" | ||
|
||
RDEPEND="${CDEPEND} | ||
>=sys-libs/zlib-1.2.5.1-r2:0[minizip] | ||
java? ( >=virtual/jre-1.5 )" | ||
|
||
RESTRICT="minimal? ( test )" | ||
|
||
pkg_setup() { | ||
if use openmp; then | ||
if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then | ||
ewarn "OpenMP is not available in your current selected gcc" | ||
die "need openmp capable gcc" | ||
fi | ||
FORTRAN_NEED_OPENMP=1 | ||
fi | ||
fortran-2_pkg_setup | ||
filter-ldflags -Wl,-Bdirect -Bdirect | ||
# avoid using existing R installation | ||
unset R_HOME | ||
# Temporary fix for bug #419761 | ||
if [[ ($(tc-getCC) == *gcc) && ($(gcc-version) == 4.7) ]]; then | ||
append-flags -fno-ipa-cp-clone | ||
fi | ||
} | ||
|
||
src_prepare() { | ||
epatch \ | ||
"${FILESDIR}"/${PN}-2.11.1-parallel.patch \ | ||
"${FILESDIR}"/${PN}-2.13.1-zlib_header_fix.patch \ | ||
"${FILESDIR}"/${PN}-3.0.0-rmath-shared.patch | ||
|
||
# fix packages.html for doc (gentoo bug #205103) | ||
sed -i \ | ||
-e "s:../../../library:../../../../$(get_libdir)/R/library:g" \ | ||
src/library/tools/R/Rd.R || die | ||
|
||
# fix Rscript path when installed (gentoo bug #221061) | ||
sed -i \ | ||
-e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${EROOT%/}/usr/$(get_libdir)/${PN}\"':" \ | ||
src/unix/Makefile.in || die "sed unix Makefile failed" | ||
|
||
# fix HTML links to manual (gentoo bug #273957) | ||
sed -i \ | ||
-e 's:\.\./manual/:manual/:g' \ | ||
$(grep -Flr ../manual/ doc) || die "sed for HTML links failed" | ||
|
||
use lapack && \ | ||
export LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)" | ||
|
||
if use X; then | ||
export R_BROWSER="$(type -p xdg-open)" | ||
export R_PDFVIEWER="$(type -p xdg-open)" | ||
fi | ||
use perl && \ | ||
export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}" | ||
|
||
# don't search /usr/local | ||
sed -i -e '/FLAGS=.*\/local\//c\: # removed by ebuild' configure.ac || die | ||
# Fix for Darwin (OS X) | ||
if use prefix; then | ||
if [[ ${CHOST} == *-darwin* ]] ; then | ||
sed -i \ | ||
-e 's:-install_name libR.dylib:-install_name ${libdir}/R/lib/libR.dylib:' \ | ||
-e 's:-install_name libRlapack.dylib:-install_name ${libdir}/R/lib/libRlapack.dylib:' \ | ||
-e 's:-install_name libRblas.dylib:-install_name ${libdir}/R/lib/libRblas.dylib:' \ | ||
-e "/SHLIB_EXT/s/\.so/.dylib/" \ | ||
configure.ac || die | ||
# sort of "undo" 2.14.1-rmath-shared.patch | ||
sed -i \ | ||
-e "s:-Wl,-soname=libRmath.so:-install_name ${EROOT%/}/usr/$(get_libdir)/libRmath.dylib:" \ | ||
src/nmath/standalone/Makefile.in || die | ||
else | ||
append-ldflags -Wl,-rpath="${EROOT%/}/usr/$(get_libdir)/R/lib" | ||
fi | ||
fi | ||
AT_M4DIR=m4 eaclocal | ||
eautoconf | ||
} | ||
|
||
src_configure() { | ||
# --with-system-tre \ | ||
# tre is patched from upstream | ||
econf \ | ||
--enable-byte-compiled-packages \ | ||
--enable-R-shlib \ | ||
--disable-R-framework \ | ||
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \ | ||
--docdir="${EPREFIX}/usr/share/doc/${PF}" \ | ||
rdocdir="${EPREFIX}/usr/share/doc/${PF}" \ | ||
$(use_enable java) \ | ||
$(use_enable nls) \ | ||
$(use_enable openmp) \ | ||
$(use_enable profile R-profiling) \ | ||
$(use_enable profile memory-profiling) \ | ||
$(use_enable static-libs static) \ | ||
$(use_enable static-libs R-static-lib) \ | ||
$(use_with cairo) \ | ||
$(use_with icu ICU) \ | ||
$(use_with jpeg jpeglib) \ | ||
$(use_with lapack) \ | ||
$(use_with !minimal recommended-packages) \ | ||
$(use_with png libpng) \ | ||
$(use_with readline) \ | ||
$(use_with tiff libtiff) \ | ||
$(use_with tk tcltk) \ | ||
$(use_with tk tk-config "${EPREFIX}"/usr/lib/tkConfig.sh) \ | ||
$(use_with tk tcl-config "${EPREFIX}"/usr/lib/tclConfig.sh) \ | ||
$(use_with X x) | ||
} | ||
|
||
src_compile() { | ||
export VARTEXFONTS="${T}/fonts" | ||
emake AR="$(tc-getAR)" | ||
emake -C src/nmath/standalone \ | ||
shared $(use static-libs && echo static) AR="$(tc-getAR)" | ||
use doc && emake info pdf | ||
} | ||
|
||
src_install() { | ||
default | ||
emake -j1 -C src/nmath/standalone DESTDIR="${D}" install | ||
|
||
if use doc; then | ||
emake DESTDIR="${D}" install-info install-pdf | ||
dosym ../manual /usr/share/doc/${PF}/html/manual | ||
fi | ||
|
||
cat > 99R <<-EOF | ||
LDPATH=${EROOT%/}/usr/$(get_libdir)/${PN}/lib | ||
R_HOME=${EROOT%/}/usr/$(get_libdir)/${PN} | ||
EOF | ||
doenvd 99R | ||
newbashcomp "${WORKDIR}"/${BCP} ${PN} | ||
# The buildsystem has a different understanding of install_names than | ||
# we require. Since it builds modules like shared objects (wrong), many | ||
# objects (all modules) get an incorrect install_name. Fixing the build | ||
# system here is not really trivial. | ||
if [[ ${CHOST} == *-darwin* ]] ; then | ||
local mod | ||
pushd "${ED}"/usr/lib/R > /dev/null | ||
for mod in $(find . -name "*.dylib") ; do | ||
mod=${mod#./} | ||
install_name_tool -id "${EPREFIX}/usr/lib/R/${mod}" \ | ||
"${mod}" | ||
done | ||
popd > /dev/null | ||
fi | ||
docompress -x /usr/share/doc/${PF}/{BioC_mirrors.csv,CRAN_mirrors.csv,KEYWORDS.db,NEWS.rds} | ||
} | ||
|
||
pkg_postinst() { | ||
if use java; then | ||
einfo "Re-initializing java paths for ${P}" | ||
R CMD javareconf | ||
fi | ||
} |