forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-sports/xmoto: migrate to lua-single.eclass
Closes: https://bugs.gentoo.org/752705 Signed-off-by: Marek Szuba <[email protected]>
- Loading branch information
Marek Szuba
committed
Dec 1, 2020
1 parent
2c98597
commit bdf6bea
Showing
3 changed files
with
86 additions
and
0 deletions.
There are no files selected for viewing
13 changes: 13 additions & 0 deletions
13
games-sports/xmoto/files/xmoto-0.6.1_cmake_lua_version.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
--- a/src/CMakeLists.txt | ||
+++ b/src/CMakeLists.txt | ||
@@ -40,8 +40,8 @@ | ||
endif() | ||
find_package(PNG REQUIRED) | ||
|
||
-find_package(Lua) | ||
-set(USE_SYSTEM_Lua $<AND:$<BOOL:${PREFER_SYSTEM_Lua}>,$<BOOL:${LUA51_FOUND}>,$<NOT:$<BOOL:${WIN32}>>>) | ||
+find_package(Lua ${LUA_VERSION} EXACT REQUIRED) | ||
+set(USE_SYSTEM_Lua $<AND:$<BOOL:${PREFER_SYSTEM_Lua}>,$<BOOL:${LUA_FOUND}>,$<NOT:$<BOOL:${WIN32}>>>) | ||
if (NOT LUA_VERSION_STRING VERSION_LESS 5.2 AND LUA_VERSION_STRING VERSION_LESS 5.3) | ||
add_definitions("-DLUA_COMPAT_ALL") | ||
elseif (LUA_VERSION_STRING VERSION_GREATER_EQUAL "5.3") |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,72 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
LUA_COMPAT=( lua5-{1..3} ) | ||
|
||
inherit cmake lua-single | ||
|
||
DESCRIPTION="A challenging 2D motocross platform game, where physics play an important role" | ||
HOMEPAGE="https://xmoto.tuxfamily.org" | ||
SRC_URI="https://github.com/xmoto/xmoto/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="double-precision +nls" | ||
|
||
REQUIRED_USE="${LUA_REQUIRED_USE}" | ||
|
||
RDEPEND="app-arch/bzip2 | ||
dev-db/sqlite:3 | ||
dev-games/ode[double-precision=] | ||
${LUA_DEPS} | ||
dev-libs/libxdg-basedir | ||
dev-libs/libxml2 | ||
media-fonts/dejavu | ||
media-libs/libpng:0= | ||
media-libs/libsdl[joystick,opengl] | ||
media-libs/sdl-mixer[vorbis] | ||
media-libs/sdl-net | ||
media-libs/sdl-ttf | ||
net-misc/curl | ||
sys-libs/zlib:= | ||
virtual/jpeg:0 | ||
virtual/glu | ||
virtual/opengl | ||
nls? ( virtual/libintl )" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND="app-arch/xz-utils | ||
nls? ( sys-devel/gettext )" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${P}_lua_deprecated.patch" | ||
"${FILESDIR}/${PN}-0.6.1_cmake_lua_version.patch" | ||
) | ||
|
||
src_prepare() { | ||
sed -e "/^Icon/s/.xpm//" -i extra/xmoto.desktop || die | ||
sed -e "/add_subdirectory.*\(bzip2\|libccd\|lua\|ode\|xdgbasedir\)/d" -i src/CMakeLists.txt || die | ||
rm -rf vendor/{bzip2,lua,ode,xdgbasedir} || die | ||
|
||
cmake_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DUSE_GETTEXT=$(usex nls) | ||
-DOpenGL_GL_PREFERENCE=GLVND | ||
-DLUA_VERSION=$(lua_get_version) | ||
) | ||
|
||
cmake_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake_src_install | ||
|
||
rm -f "${ED}/usr/share/xmoto"/Textures/Fonts/DejaVuSans{Mono,}.ttf || die | ||
dosym ../../../fonts/dejavu/DejaVuSans.ttf /usr/share/xmoto/Textures/Fonts/DejaVuSans.ttf | ||
dosym ../../../fonts/dejavu/DejaVuSansMono.ttf /usr/share/xmoto/Textures/Fonts/DejaVuSansMono.ttf | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters