Skip to content

Commit

Permalink
kde-misc/latte-dock: new package
Browse files Browse the repository at this point in the history
Gentoo-bug: 614512
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
Petross404 authored and Michael Palimaka committed Apr 25, 2017
1 parent 34bbe08 commit c983b87
Show file tree
Hide file tree
Showing 4 changed files with 162 additions and 0 deletions.
1 change: 1 addition & 0 deletions kde-misc/latte-dock/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST latte-dock-0.6.tar.gz 387742 SHA256 235ebd17795a2342cd4c14274ce3b0ad0d9f5b05dc6a938e5c277ba276ba3481 SHA512 ddf51b84d8df18dabd9ad39d084b28829d39b0015ddf076b498bf6497aef434dd03f3b53355b9116b5090fd6842eef519a93ab62fc4022e53982ba3ad2f40d31 WHIRLPOOL beaad11777dacb7efdd48522fedfebcfc12ae61ccc9698843b6ef588254e4134e14bdcb353f1db280cf084c29e79c54f43d9d97b32917372294c9f3ac6d2e6bc
74 changes: 74 additions & 0 deletions kde-misc/latte-dock/latte-dock-0.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

KDE_GCC_MINIMAL="4.9"

inherit cmake-utils gnome2-utils kde5-functions

DESCRIPTION="Elegant dock, based on KDE Frameworks"
HOMEPAGE="https://store.kde.org/p/1169519/
https://github.com/psifidotos/Latte-Dock"

if [[ ${PV} = 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/psifidotos/Latte-Dock.git"
else
SRC_URI="https://github.com/psifidotos/Latte-Dock/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/Latte-Dock-${PV}"
fi

LICENSE="GPL-2+"
SLOT="0"
IUSE=""

DOCS=( CHANGELOG.md README.md TRANSLATORS )

BUILD_DIR="${S}/build"

RDEPEND="$(add_qt_dep qtcore)
$(add_qt_dep qtdbus)
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgraphicaleffects)
$(add_qt_dep qtgui 'xcb')
$(add_qt_dep qtwidgets)
$(add_qt_dep qtx11extras)
$(add_frameworks_dep kactivities)
$(add_frameworks_dep karchive)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep kdeclarative)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep knotifications)
$(add_frameworks_dep kpackage)
$(add_frameworks_dep kwayland)
$(add_frameworks_dep kwindowsystem)
$(add_frameworks_dep kxmlgui)
$(add_frameworks_dep plasma X)
x11-libs/libX11
x11-libs/libxcb"

DEPEND="${RDEPEND}
$(add_frameworks_dep extra-cmake-modules)"

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update

if has_version "dev-qt/qtcore:5.8" ; then
ewarn "Qt 5.8 is known to cause runtime problems. If you"
ewarn "experience problems while running Latte Dock, please check this"
ewarn "out: https://github.com/psifidotos/Latte-Dock/issues/183"
fi
}

pkg_postrm() {
gnome2_icon_cache_update
}
75 changes: 75 additions & 0 deletions kde-misc/latte-dock/latte-dock-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

KDE_GCC_MINIMAL="4.9"

inherit cmake-utils gnome2-utils kde5-functions

DESCRIPTION="Elegant dock, based on KDE Frameworks"
HOMEPAGE="https://store.kde.org/p/1169519/
https://github.com/psifidotos/Latte-Dock"

if [[ ${PV} = 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/psifidotos/Latte-Dock.git"
else
SRC_URI="https://github.com/psifidotos/Latte-Dock/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/Latte-Dock-${PV}"
fi

LICENSE="GPL-2+"
SLOT="0"
IUSE=""

DOCS=( CHANGELOG.md README.md TRANSLATORS )

BUILD_DIR="${S}/build"

RDEPEND="$(add_qt_dep qtcore)
$(add_qt_dep qtdbus)
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgraphicaleffects)
$(add_qt_dep qtgui 'xcb')
$(add_qt_dep qtwidgets)
$(add_qt_dep qtx11extras)
$(add_frameworks_dep kactivities)
$(add_frameworks_dep karchive)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep kdeclarative)
$(add_frameworks_dep kglobalaccel)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep knotifications)
$(add_frameworks_dep kpackage)
$(add_frameworks_dep kwayland)
$(add_frameworks_dep kwindowsystem)
$(add_frameworks_dep kxmlgui)
$(add_frameworks_dep plasma X)
x11-libs/libX11
x11-libs/libxcb"

DEPEND="${RDEPEND}
$(add_frameworks_dep extra-cmake-modules)"

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update

if has_version "dev-qt/qtcore:5.8" ; then
ewarn "Qt 5.8 is known to cause runtime problems. If you"
ewarn "experience problems while running Latte Dock, please check this"
ewarn "out: https://github.com/psifidotos/Latte-Dock/issues/183"
fi
}

pkg_postrm() {
gnome2_icon_cache_update
}
12 changes: 12 additions & 0 deletions kde-misc/latte-dock/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Petross404 (Petros S)</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
</pkgmetadata>

0 comments on commit c983b87

Please sign in to comment.