Skip to content

Commit

Permalink
games-strategy/naev: update to 0.7.0
Browse files Browse the repository at this point in the history
Migrate to EAPI 7, use github sources.

Closes: https://bugs.gentoo.org/546562
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Azamat H. Hackimov <[email protected]>
Signed-off-by: Marek Szuba <[email protected]>
  • Loading branch information
winterheart authored and Marek Szuba committed Dec 1, 2020
1 parent 727ef34 commit c9f8ba0
Show file tree
Hide file tree
Showing 3 changed files with 71 additions and 1 deletion.
2 changes: 2 additions & 0 deletions games-strategy/naev/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST naev-0.6.1.tar.bz2 1047908 BLAKE2B 3763440c64f89c5ceb5993a3e4ee356d0cc615df8b70dba14ce0fb35d12a0a136e82958349887d9c5a719e14d9ddfc47beb524b88650ea6f7a6859a6422d6898 SHA512 4766c80b49de5a7e748948f0404ac54edbc5afa80618150d1f993d66c7462ea73bfc5220d73073cb51cd76ff5dc6ecdf935d6f843051943136ceefaea9837203
DIST naev-0.7.0-ndata.zip 319608404 BLAKE2B e6edd79282171d4b327d220b33af37720e09f7137a26697de472e3494587525de5d9509865bfccc1093f5d4befa11faa10e0d4f4c59ea8621ecd8d564eb546fe SHA512 5fa8faad36e410f0d2af1c80e6fedbffdd020da72dc96b329ce623e9836490cfb515c1bb88719045491366ca96a32888374029eec6cd14ed86ac8597750995ca
DIST naev-0.7.0.tar.bz2 1076658 BLAKE2B 582bbfbc16e33d16600c19928ed6810dfe5fd3165930e6a51ec9b65d25305cd0bbfaf6f4cced12c5b7f76163ed4dc36b7108e81f4a4e82dc626c6045d3fe769f SHA512 9f8a2912e9f4f29ed6e276b008d4010da3ccdd309de5bb4360c393f2704aa7aff6e18db9e5d3657b4229e911ddec9b2a3312cf182c3c48a91a007a91138d84ae
DIST ndata-0.6.1.zip 303984255 BLAKE2B 154d8b326e2596cfe16fc646e7d482c07d7015253b6933889d12b93a2ee7e28649b1f3ffcb0c0ed2bfe9d1e3654623cab00113486d05fe6fd1262ce989bf9c25 SHA512 71c3024e1713b094b63cb0de3c70239d61c54142b715e61d5206c5eb3cb8c7a851fc1b388ecf891110dd8bb5c2b3759af71d20f39cb6e629c71b27386a57d7fe
2 changes: 1 addition & 1 deletion games-strategy/naev/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -12,6 +12,6 @@
</flag>
</use>
<upstream>
<remote-id type="sourceforge">naev</remote-id>
<remote-id type="github">naev/naev</remote-id>
</upstream>
</pkgmetadata>
68 changes: 68 additions & 0 deletions games-strategy/naev/naev-0.7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit xdg-utils

DESCRIPTION="A 2D space trading and combat game, in a similar vein to Escape Velocity"
HOMEPAGE="https://naev.org/ https://github.com/naev/naev"
SRC_URI="https://github.com/naev/naev/releases/download/${P}/${P}.tar.bz2
https://github.com/naev/naev/releases/download/${P}/${P}-ndata.zip"

LICENSE="GPL-2 GPL-3 public-domain CC-BY-3.0 CC-BY-SA-3.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug +mixer +openal"

RDEPEND="
media-libs/libsdl2[X,sound,video]
dev-libs/libzip
dev-libs/libxml2
>=media-libs/freetype-2:2
>=media-libs/libvorbis-1.2.1
>=media-libs/libpng-1.2:0=
virtual/glu
virtual/opengl
dev-lang/lua:0
mixer? ( media-libs/sdl2-mixer )
openal? ( media-libs/openal )
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

src_unpack() {
unpack ${P}.tar.bz2
}

src_configure() {
econf \
--enable-lua=shared \
$(use_enable debug) \
$(use_with openal) \
$(use_with mixer sdlmixer)
}

src_compile() {
emake V=1
}

src_install() {
emake \
DESTDIR="${D}" \
appicondir=/usr/share/pixmaps \
appdatadir=/usr/share/metainfo \
Graphicsdir=/usr/share/applications \
install
insinto /usr/share/${PN}
newins "${DISTDIR}/${P}-ndata.zip" ndata

rm -f "${D}/usr/share/doc/${PF}/LICENSE"
}

pkg_postinst() {
xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit c9f8ba0

Please sign in to comment.