Skip to content

Commit

Permalink
games-util/pyfa: version bump to 2.22.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Zuber <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
ZeroPointEnergy authored and juippis committed Jul 11, 2020
1 parent 916dd6d commit cdcb460
Show file tree
Hide file tree
Showing 2 changed files with 101 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-util/pyfa/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST pyfa-2.20.3.tar.gz 11835182 BLAKE2B 0a298f565317a4a8894fda64dc01175080bf2d6b3d118168f0015dee5988742ddca4170faa72565e5b08bbb66752668e081b142e8d8d19b5fea019dc874e5306 SHA512 0971da1b3f6db6c8e4a0d5b24c5a7f267bbf10531ea0cf98263e779c86cbea419a783088f37a7f5d2b18b7f498f525d5c80724ebaf2cff1ae1e5290e2fac5704
DIST pyfa-2.21.0.tar.gz 11876753 BLAKE2B 104dd1da117f014ff28f745cb5c89a77b7f6fdf850ba70fcbfef9d9f5d49ad053939baf356b12962dec9e32b746cd1a2b617937522dddabcaf06bc3a9c18d3bc SHA512 11ccbd1e89429176a5da24bd8bb5c896e43d78ac92b49c5374f8449cd9ade0fdb3c7370c5abe5860d7be92b7bf24b9557720f2c0c55073adc74eb517de512a4b
DIST pyfa-2.22.0.tar.gz 12627989 BLAKE2B 4070354dfbfee2a49fb1b4580c22d16320fd98f911bb2f69342d61bfdbf41e3b94d90ca3559f9e44ebdd1c784322d1bc6d9b14248cd05948a9e932bfcda3c585 SHA512 dc2ee166cdf385f322faee43252ebb09afc2c4ba4d9cbd9438bef0aeba0cf33d425bab887165992d1597bed9dfa8e40fcc776821d4075b91001bec4385db0563
DIST pyfa-2.22.1.tar.gz 12629381 BLAKE2B acec4f0f495a7abd78a663435b0a049f8be37320abea0d916c6a8f38b75c1f07683b60c9e20b8feb0533fdcfc881ac3069c87e8360be52f05afce63334ff1baa SHA512 98c84c3806d8ff632ebe9c1386f8b407f310ff58b0963406093dc9297faaf690a90b34387013f59c76fdd87055ecf8736b449f99131aaf9eb497970a4ee003b2
100 changes: 100 additions & 0 deletions games-util/pyfa/pyfa-2.22.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,100 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite"

inherit desktop eutils python-single-r1 xdg-utils

DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
HOMEPAGE="https://github.com/pyfa-org/Pyfa"

LICENSE="GPL-3+ all-rights-reserved"
SLOT="0"
if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://github.com/pyfa-org/Pyfa.git"
inherit git-r3
else
SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/Pyfa-${PV}"
fi

REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="mirror bindist"

DEPEND="
$(python_gen_cond_dep '
>=dev-python/cryptography-2.3[${PYTHON_MULTI_USEDEP}]
>=dev-python/logbook-1.0.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/pyyaml-5.1[${PYTHON_MULTI_USEDEP}]
>=dev-python/sqlalchemy-1.3.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/wxpython-4.0.6[webkit,${PYTHON_MULTI_USEDEP}]
')
${PYTHON_DEPS}"
RDEPEND="${DEPEND}
$(python_gen_cond_dep '
>=dev-python/beautifulsoup-4.6.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/markdown2-2.3.5[${PYTHON_MULTI_USEDEP}]
>=dev-python/packaging-16.8[${PYTHON_MULTI_USEDEP}]
dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
>=dev-python/requests-2.0.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/roman-2.0.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/matplotlib-3.1.2[wxwidgets,${PYTHON_MULTI_USEDEP}]
')"
BDEPEND="app-arch/zip"

PATCHES=(
# fix import path in the main script for systemwide installation
"${FILESDIR}/${PN}-2.9.3-import-pyfa.patch"
)

src_prepare() {
# get rid of CRLF line endings introduced in 1.1.10 so patches work
edos2unix config.py pyfa.py gui/bitmap_loader.py service/settings.py

default

# make python recognize pyfa as a package
touch __init__.py || die

sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
-e "s:%%EPREFIX%%:${EPREFIX}:" \
"${FILESDIR}/configforced-1.15.1.py" > configforced.py || die
sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
pyfa.py > pyfa || die
}

src_install() {
python_moduleinto ${PN}
python_domodule eos gui service utils graphs
python_domodule config*.py __init__.py version.yml configforced.py db_update.py
python_doscript pyfa

insinto /usr/share/${PN}

einfo "Creating database ..."
python ./db_update.py || die
doins eve.db

einfo "Compressing images ..."
pushd imgs > /dev/null || die
zip -r imgs.zip * || die "zip failed"
doins imgs.zip
popd > /dev/null || die

dodoc README.md
doicon -s 32 imgs/gui/pyfa.png
newicon -s 64 imgs/gui/pyfa64.png pyfa.png
domenu "${FILESDIR}/${PN}.desktop"
}

pkg_postinst() {
xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit cdcb460

Please sign in to comment.