forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnustep-base/gnustep-back-cairo: 0.26.2 bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
49 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST gnustep-back-0.25.0.tar.gz 974762 BLAKE2B ef3ef5bf822b2cd96ac8f6256708c275193db9ba2bfe3d669c3a50e1f4ff9bfb1560a0a2ee1c38e58a13e0e3e081548102dd83a06bdf880fe857046d3d7940ef SHA512 38a098e7fe207c902428c05f01ebf0336b33fb9213368038c2513236255723b642fd9576524ad119ee9511c708be21c155eeaaf297e05c6ebdab8e59efe05770 | ||
DIST gnustep-back-0.25.1.tar.gz 974775 BLAKE2B 8050c20f405da340a0f42655ca2b0f43761d60b8ee6eab7ce4bbd5f323f7ab8b59506b0b8c5c057eb8303c0b7efe4d80ab428ca100b319a9b927d74bdb37ddd4 SHA512 0515672c38265499dc3f0be5127053bc7b2478130cac69cb70c29e5887832472dfdcf90b756ab0926ba5967c0be93e041a1f820dc58f973e41b648e08a569656 | ||
DIST gnustep-back-0.26.2.tar.gz 969473 BLAKE2B a16b8663492ca1d59ac1267b3e5421cc14672251c273624e4bcc5e587783968baebfcca020c3f0ccaf73de9c0c43f872a303be4c1ef83c78e1bf102d47f2feea SHA512 99912430425e36b386b3f7bb3a49989c92edd20e3166292e6697c532a7f8ae17682c80bb39fa6177c67bb75bcd9befc44f53874eb5ca1406f51af44b15c9685e |
48 changes: 48 additions & 0 deletions
48
gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.26.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit eutils gnustep-base | ||
|
||
DESCRIPTION="Cairo back-end component for the GNUstep GUI Library" | ||
HOMEPAGE="http://www.gnustep.org" | ||
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris" | ||
IUSE="opengl xim" | ||
|
||
RDEPEND="${GNUSTEP_CORE_DEPEND} | ||
=gnustep-base/gnustep-gui-${PV%.*}* | ||
opengl? ( virtual/opengl virtual/glu ) | ||
x11-libs/libICE | ||
x11-libs/libSM | ||
x11-libs/libX11 | ||
x11-libs/libXext | ||
x11-libs/libXi | ||
x11-libs/libXmu | ||
x11-libs/libXt | ||
x11-libs/libXft | ||
x11-libs/libXrender | ||
>=media-libs/freetype-2.1.9 | ||
>=x11-libs/cairo-1.2.0[X] | ||
!gnustep-base/gnustep-back-art | ||
!gnustep-base/gnustep-back-xlib" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
S=${WORKDIR}/gnustep-back-${PV} | ||
|
||
src_configure() { | ||
egnustep_env | ||
|
||
myconf="$(use_enable opengl glx)" | ||
myconf="$myconf $(use_enable xim)" | ||
myconf="$myconf --enable-server=x11" | ||
myconf="$myconf --enable-graphics=cairo" | ||
|
||
econf $myconf | ||
} |