Skip to content

Commit

Permalink
x11-terms/kitty: Update flags.patch for -9999
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Matthias Coppens <[email protected]>
Closes: gentoo#19250
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
MatthiasCoppens authored and juippis committed Feb 2, 2021
1 parent a3b7507 commit e5d0e86
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 1 deletion.
49 changes: 49 additions & 0 deletions x11-terms/kitty/files/kitty-9999-flags.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
diff --git a/setup.py b/setup.py
index ce5309ee..9cb59461 100755
--- a/setup.py
+++ b/setup.py
@@ -278,7 +278,7 @@ def init_env(
df += ' -Og'
float_conversion = '-Wfloat-conversion'
fortify_source = '-D_FORTIFY_SOURCE=2'
- optimize = df if debug or sanitize else '-O3'
+ optimize = ''
sanitize_args = get_sanitize_args(cc, ccver) if sanitize else set()
cppflags_ = os.environ.get(
'OVERRIDE_CPPFLAGS', '-D{}DEBUG'.format('' if debug else 'N'),
@@ -289,7 +289,7 @@ def init_env(
cflags_ = os.environ.get(
'OVERRIDE_CFLAGS', (
'-Wextra {} -Wno-missing-field-initializers -Wall -Wstrict-prototypes {}'
- ' -pedantic-errors -Werror {} {} -fwrapv {} {} -pipe {} -fvisibility=hidden {}'
+ ' -pedantic-errors {} {} -fwrapv {} {} {} -fvisibility=hidden {}'
).format(
float_conversion,
'' if is_openbsd else '-std=c11',
@@ -306,7 +306,7 @@ def init_env(
)
ldflags_ = os.environ.get(
'OVERRIDE_LDFLAGS',
- '-Wall ' + ' '.join(sanitize_args) + ('' if debug else ' -O3')
+ '-Wall ' + ' '.join(sanitize_args)
)
ldflags = shlex.split(ldflags_)
ldflags.append('-shared')
@@ -764,7 +764,7 @@ def safe_makedirs(path: str) -> None:


def build_launcher(args: Options, launcher_dir: str = '.', bundle_type: str = 'source') -> None:
- cflags = '-Wall -Werror -fpie'.split()
+ cflags = '-Wall -fpie'.split()
cppflags = []
libs: List[str] = []
if args.profile or args.sanitize:
@@ -776,8 +776,6 @@ def build_launcher(args: Options, launcher_dir: str = '.', bundle_type: str = 's
cflags.append('-g')
if args.profile:
libs.append('-lprofiler')
- else:
- cflags.append('-O3')
if bundle_type.endswith('-freeze'):
cppflags.append('-DFOR_BUNDLE')
cppflags.append('-DPYVER="{}"'.format(sysconfig.get_python_version()))
2 changes: 1 addition & 1 deletion x11-terms/kitty/kitty-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -56,7 +56,7 @@ BDEPEND="virtual/pkgconfig"
$(python_gen_cond_dep '>=dev-python/sphinx-1.7[${PYTHON_MULTI_USEDEP}]')"

PATCHES=(
"${FILESDIR}"/kitty-0.17.2-flags.patch
"${FILESDIR}"/${P}-flags.patch
"${FILESDIR}"/${P}-remove-terminfo.patch
"${FILESDIR}"/${PN}-0.14.4-svg-icon.patch
)
Expand Down

0 comments on commit e5d0e86

Please sign in to comment.