Skip to content

Commit

Permalink
app-admin/keepassx: add missing handling of various cache updates, bu…
Browse files Browse the repository at this point in the history
…g #577596

With permission from poly-c.

Package-Manager: portage-2.3.0
  • Loading branch information
EvaSDK committed Sep 11, 2016
1 parent ee8ce4e commit f90cde8
Showing 1 changed file with 55 additions and 0 deletions.
55 changes: 55 additions & 0 deletions app-admin/keepassx/keepassx-2.0.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit cmake-utils gnome2-utils vcs-snapshot xdg

DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions"
HOMEPAGE="http://www.keepassx.org/"
SRC_URI="https://www.keepassx.org/releases/${PV}/${P}.tar.gz"

LICENSE="|| ( GPL-2 GPL-3 ) BSD GPL-2 LGPL-2.1 LGPL-3+ CC0-1.0 public-domain || ( LGPL-2.1 GPL-3 )"
SLOT="0"
KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux"
IUSE="test"

DEPEND="
dev-libs/libgcrypt:0=
dev-qt/qtcore:4
dev-qt/qtgui:4
dev-qt/qttest:4
sys-libs/zlib
x11-libs/libX11
x11-libs/libXtst
"
RDEPEND="${DEPEND}"

DOCS=(CHANGELOG)

src_prepare() {
xdg_src_prepare
cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DWITH_TESTS="$(usex test)"
)
cmake-utils_src_configure
}

pkg_preinst() {
gnome2_icon_savelist
xdg_pkg_preinst
}
pkg_postinst() {
gnome2_icon_cache_update
xdg_pkg_postinst
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_pkg_postrm
}

0 comments on commit f90cde8

Please sign in to comment.