Skip to content

Commit

Permalink
directfb: add options for divine and sawman
Browse files Browse the repository at this point in the history
Since DirectFB 1.7.x, the divine (virtual input) and sawman (window
manager) features have been merged in DirectFB itself rather than
being shipped as separate tarballs. This commit creates additional
options to enable those features.

Upcoming commits will get rid of the existing divine and sawman
Buildroot packages.

Signed-off-by: Thomas Petazzoni <[email protected]>
Signed-off-by: Peter Korsgaard <[email protected]>
  • Loading branch information
tpetazzoni authored and jacmet committed Sep 10, 2015
1 parent 26e6da5 commit e5ac8f6
Show file tree
Hide file tree
Showing 3 changed files with 87 additions and 0 deletions.
65 changes: 65 additions & 0 deletions package/directfb/0005-add-missing-idivine-header.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
Add idivine.h, which is missing from DirectFB tarballs

The idivine.h file was taken from the DirectFB Git repository.

Signed-off-by: Thomas Petazzoni <[email protected]>

Index: b/lib/divine/idivine.h
===================================================================
--- /dev/null
+++ b/lib/divine/idivine.h
@@ -0,0 +1,54 @@
+/*
+ (c) Copyright 2012-2013 DirectFB integrated media GmbH
+ (c) Copyright 2001-2013 The world wide DirectFB Open Source Community (directfb.org)
+ (c) Copyright 2000-2004 Convergence (integrated media) GmbH
+
+ All rights reserved.
+
+ Written by Denis Oliver Kropp <[email protected]>,
+ Andreas Shimokawa <[email protected]>,
+ Marek Pikarski <[email protected]>,
+ Sven Neumann <[email protected]>,
+ Ville Syrjälä <[email protected]> and
+ Claudio Ciccani <[email protected]>.
+
+ This library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2 of the License, or (at your option) any later version.
+
+ This library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with this library; if not, write to the
+ Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ Boston, MA 02111-1307, USA.
+*/
+
+
+
+#ifndef __IDIVINE_H__
+#define __IDIVINE_H__
+
+#include <divine.h>
+
+/*
+ * private data struct of IDiVine
+ */
+typedef struct {
+ int ref; /* reference counter */
+
+ DiVine *divine;
+} IDiVine_data;
+
+/*
+ * IDiVine constructor/destructor
+ */
+DFBResult IDiVine_Construct( IDiVine *thiz );
+
+void IDiVine_Destruct ( IDiVine *thiz );
+
+#endif
10 changes: 10 additions & 0 deletions package/directfb/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -45,6 +45,16 @@ config BR2_PACKAGE_DIRECTFB_TRACE
help
Enable call tracing for DirectFB applications

config BR2_PACKAGE_DIRECTFB_DIVINE
bool "divine"
help
Enable the DiVine feature (virtual input)

config BR2_PACKAGE_DIRECTFB_SAWMAN
bool "sawman"
help
Enable the SawMan feature (window manager)

config BR2_PACKAGE_DIRECTFB_ATI128
bool "compile ati128 graphics driver"
depends on BR2_i386 || BR2_x86_64
Expand Down
12 changes: 12 additions & 0 deletions package/directfb/directfb.mk
Original file line number Diff line number Diff line change
Expand Up @@ -53,6 +53,18 @@ ifeq ($(BR2_PACKAGE_DIRECTFB_TRACE),y)
DIRECTFB_CONF_OPTS += --enable-trace
endif

ifeq ($(BR2_PACKAGE_DIRECTFB_DIVINE),y)
DIRECTFB_CONF_OPTS += --enable-divine
else
DIRECTFB_CONF_OPTS += --disable-divine
endif

ifeq ($(BR2_PACKAGE_DIRECTFB_SAWMAN),y)
DIRECTFB_CONF_OPTS += --enable-sawman
else
DIRECTFB_CONF_OPTS += --disable-sawman
endif

DIRECTFB_GFX = \
$(if $(BR2_PACKAGE_DIRECTFB_ATI128),ati128) \
$(if $(BR2_PACKAGE_DIRECTFB_CLE266),cle266) \
Expand Down

0 comments on commit e5ac8f6

Please sign in to comment.