forked from wasmerio/wasmer
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge pull request wasmerio#385 from wasmerio/feature/better-tar-install
Improved installer
- Loading branch information
Showing
3 changed files
with
21 additions
and
3 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -150,6 +150,10 @@ jobs: | |
- image: circleci/rust:latest | ||
steps: | ||
- checkout | ||
- run: | ||
name: "Pull dependencies" | ||
command: | | ||
git clone [email protected]:wasmerio/wapm-cli.git | ||
- restore_cache: | ||
keys: | ||
- v8-cargo-cache-linux-nightly-{{ arch }}-{{ checksum "Cargo.lock" }} | ||
|
@@ -178,6 +182,7 @@ jobs: | |
command: | | ||
export LLVM_SYS_70_PREFIX="`pwd`/clang+llvm-7.0.0-x86_64-linux-gnu-ubuntu-16.04/" | ||
make production-release | ||
cargo build --release --manifest-path wapm-cli/Cargo.toml --features telemetry | ||
mkdir -p artifacts | ||
VERSION=$(cargo pkgid | cut -d# -f2 | cut -d: -f2) | ||
# GIT_VERSION=$(git describe --exact-match --tags) | ||
|
@@ -202,13 +207,20 @@ jobs: | |
- target/release/.fingerprint | ||
- target/release/build | ||
- target/release/deps | ||
- wapm-cli/target/release/.fingerprint | ||
- wapm-cli/target/release/build | ||
- wapm-cli/target/release/deps | ||
key: v8-cargo-cache-linux-nightly-{{ arch }}-{{ checksum "Cargo.lock" }} | ||
|
||
test-and-build-macos: | ||
macos: | ||
xcode: "9.0" | ||
steps: | ||
- checkout | ||
- run: | ||
name: "Pull dependencies" | ||
command: | | ||
git clone [email protected]:wasmerio/wapm-cli.git | ||
- restore_cache: | ||
keys: | ||
- v8-cargo-cache-darwin-nightly-{{ arch }}-{{ checksum "Cargo.lock" }} | ||
|
@@ -263,6 +275,7 @@ jobs: | |
export PATH="$HOME/.cargo/bin:$PATH" | ||
export LLVM_SYS_70_PREFIX="`pwd`/clang+llvm-7.0.0-x86_64-apple-darwin/" | ||
make production-release | ||
cargo build --release --manifest-path wapm-cli/Cargo.toml --features telemetry | ||
mkdir -p artifacts | ||
make build-install | ||
cp ./wasmer.tar.gz ./artifacts/$(./binary-name.sh) | ||
|
@@ -281,6 +294,9 @@ jobs: | |
- target/release/.fingerprint | ||
- target/release/build | ||
- target/release/deps | ||
- wapm-cli/target/release/.fingerprint | ||
- wapm-cli/target/release/build | ||
- wapm-cli/target/release/deps | ||
key: v8-cargo-cache-darwin-nightly-{ arch }}-{{ checksum "Cargo.lock" }} | ||
|
||
test-rust-nightly: | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters