Skip to content

Commit

Permalink
sunxi: add support for H6 boards and OrangePiOnePlus
Browse files Browse the repository at this point in the history
Specifications:

SoC	Allwinner H6 @ 1.8 Ghz
DRAM	1Gb LPDDR3
Power	DC 5V @ 3A
Video	HDMI (Type 2.0A - full)
Audio	HDMI, on-board microphone
Network	10/100/1000Mbps Ethernet (Realtek RTL8211)
Storage	microSD
USB	1 USB2.0 Host, 1 USB2.0 OTG
Debug	Serial UART

Flashing instructions:
 Standard sunxi SD card installation procedure - copy image to SD card,
 insert into SD card slot on the device and boot.

Signed-off-by: Zoltan HERPAI <[email protected]>
  • Loading branch information
wigyori committed Apr 11, 2021
1 parent c216353 commit 3225241
Show file tree
Hide file tree
Showing 8 changed files with 531 additions and 2 deletions.
6 changes: 6 additions & 0 deletions package/boot/arm-trusted-firmware-sunxi/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -37,6 +37,11 @@ define Package/arm-trusted-firmware-sunxi-a64
VARIANT:=sun50i_a64
endef

define Package/arm-trusted-firmware-sunxi-h6
$(call Package/arm-trusted-firmware-sunxi/Default)
VARIANT:=sun50i_h6
endef

export GCC_HONOUR_COPTS=s

MAKE_VARS = \
Expand All @@ -55,3 +60,4 @@ define Package/arm-trusted-firmware-sunxi/install
endef

$(eval $(call BuildPackage,arm-trusted-firmware-sunxi-a64))
$(eval $(call BuildPackage,arm-trusted-firmware-sunxi-h6))
10 changes: 10 additions & 0 deletions package/boot/uboot-sunxi/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -204,6 +204,15 @@ define U-Boot/orangepi_one
BUILD_DEVICES:=xunlong_orangepi-one
endef

define U-Boot/orangepi_one_plus
BUILD_SUBTARGET:=cortexa53
NAME:=Orange Pi One Plus (H6)
DEPENDS:=+PACKAGE_u-boot-orangepi_one_plus:arm-trusted-firmware-sunxi-h6
BUILD_DEVICES:=xunlong_orangepi-one-plus
UENV:=h6
ATF:=h6
endef

define U-Boot/orangepi_pc
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi PC (H3)
Expand Down Expand Up @@ -344,6 +353,7 @@ UBOOT_TARGETS := \
orangepi_zero \
orangepi_r1 \
orangepi_one \
orangepi_one_plus \
orangepi_pc \
orangepi_pc_plus \
orangepi_plus \
Expand Down
7 changes: 7 additions & 0 deletions package/boot/uboot-sunxi/uEnv-h6.txt
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
setenv mmc_rootpart 2
part uuid mmc ${mmc_bootdev}:${mmc_rootpart} uuid
setenv loadkernel fatload mmc \$mmc_bootdev \$kernel_addr_r uImage
setenv loaddtb fatload mmc \$mmc_bootdev \$fdt_addr_r dtb
setenv bootargs console=ttyS0,115200 earlyprintk root=PARTUUID=${uuid} rootwait
setenv uenvcmd run loadkernel \&\& run loaddtb \&\& booti \$kernel_addr_r - \$fdt_addr_r
run uenvcmd
17 changes: 15 additions & 2 deletions target/linux/sunxi/image/cortexa53.mk
Original file line number Diff line number Diff line change
Expand Up @@ -9,13 +9,18 @@ define Device/sun50i
KERNEL := kernel-bin
endef

define Device/sun50i-a64
SOC := sun50i-a64
$(Device/sun50i)
endef

define Device/sun50i-h5
SOC := sun50i-h5
$(Device/sun50i)
endef

define Device/sun50i-a64
SOC := sun50i-a64
define Device/sun50i-h6
SOC := sun50i-h6
$(Device/sun50i)
endef

Expand Down Expand Up @@ -79,6 +84,14 @@ define Device/pine64_sopine-baseboard
endef
TARGET_DEVICES += pine64_sopine-baseboard

define Device/xunlong_orangepi-one-plus
$(Device/sun50i-h6)
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi One Plus
SUNXI_DTS_DIR := allwinner/
endef
TARGET_DEVICES += xunlong_orangepi-one-plus

define Device/xunlong_orangepi-pc2
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi PC 2
Expand Down
Loading

0 comments on commit 3225241

Please sign in to comment.