forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
tfp-layerscape: update to LSDK-20.12
Fixes compilation with GCC11. Kept PKG_VERSION as there's some bug that chops off the 12 at the end. Refreshed other patch. Signed-off-by: Rosen Penev <[email protected]>
- Loading branch information
Showing
3 changed files
with
23 additions
and
10 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -11,8 +11,6 @@ Signed-off-by: Biwen Li <[email protected]> | |
plat/nxp/tools/pbl_ch3.mk | 5 ----- | ||
2 files changed, 8 deletions(-) | ||
|
||
diff --git a/plat/nxp/tools/pbl_ch2.mk b/plat/nxp/tools/pbl_ch2.mk | ||
index afa43520..ff624dd9 100644 | ||
--- a/plat/nxp/tools/pbl_ch2.mk | ||
+++ b/plat/nxp/tools/pbl_ch2.mk | ||
@@ -20,8 +20,6 @@ ifeq ($(RCW),"") | ||
|
@@ -32,8 +30,6 @@ index afa43520..ff624dd9 100644 | |
${CREATE_PBL} -r ${RCW} -i ${BUILD_PLAT}/bl2.bin -b ${BOOT_MODE} -c ${SOC_NUM} -d ${BL2_BASE} -e ${BL2_BASE} \ | ||
-o ${BUILD_PLAT}/bl2_${BOOT_MODE}.pbl ; | ||
# Swapping of RCW is required for QSPi Chassis 2 devices | ||
diff --git a/plat/nxp/tools/pbl_ch3.mk b/plat/nxp/tools/pbl_ch3.mk | ||
index 944ae3bb..9aa8f635 100644 | ||
--- a/plat/nxp/tools/pbl_ch3.mk | ||
+++ b/plat/nxp/tools/pbl_ch3.mk | ||
@@ -27,9 +27,6 @@ else | ||
|
@@ -55,6 +51,3 @@ index 944ae3bb..9aa8f635 100644 | |
# Add Block Copy command and populate boot loc ptrfor bl2.bin to RCW | ||
${CREATE_PBL} -r ${RCW} -i ${BUILD_PLAT}/bl2.bin -b ${BOOT_MODE} -c ${SOC_NUM} -d ${BL2_BASE} -e ${BL2_BASE} \ | ||
-o ${BUILD_PLAT}/bl2_${BOOT_MODE}.pbl -f ${BL2_SRC_OFFSET}; | ||
-- | ||
2.17.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
--- a/common/runtime_svc.c | ||
+++ b/common/runtime_svc.c | ||
@@ -38,7 +38,7 @@ uintptr_t handle_runtime_svc(uint32_t smc_fid, | ||
u_register_t x1, x2, x3, x4; | ||
int index; | ||
unsigned int idx; | ||
- const rt_svc_desc_t *rt_svc_descs; | ||
+ rt_svc_desc_t *rt_svc_descs = NULL; | ||
|
||
assert(handle); | ||
idx = get_unique_oen_from_smc_fid(smc_fid); | ||
@@ -48,7 +48,7 @@ uintptr_t handle_runtime_svc(uint32_t smc_fid, | ||
if (index < 0 || index >= (int)RT_SVC_DECS_NUM) | ||
SMC_RET1(handle, SMC_UNK); | ||
|
||
- rt_svc_descs = (rt_svc_desc_t *) RT_SVC_DESCS_START; | ||
+ memcpy(rt_svc_descs, (rt_svc_desc_t *)RT_SVC_DESCS_START, MAX_RT_SVCS); | ||
|
||
get_smc_params_from_ctx(handle, x1, x2, x3, x4); | ||
|