Skip to content

Commit

Permalink
dev-python/botocore: Bump to 1.34.38
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Feb 9, 2024
1 parent 347b8e3 commit 08ec056
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/botocore/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST botocore-1.34.34.gh.tar.gz 12682925 BLAKE2B 514e6946558d1014371ca7ae4c76614
DIST botocore-1.34.35.gh.tar.gz 12683490 BLAKE2B 4cb287495e77de15803b36755962a0e6446d00aa9a6056c5762261874adf297a55bd8fceb43aa518cb981ac09b5d00e87eb593f0356949b6f8b0cced65936ac0 SHA512 82a57540c6fa50957434254ff536bb0a6c73cec313372233c0e4b922a4d7539a7c2150d3c49df9bcd1840c29d2eb22b25d6d8c276a704dfa9a12a32974f17d33
DIST botocore-1.34.36.gh.tar.gz 12688895 BLAKE2B b05dbc906d6f49fe8df7c608cefa85bf08f59f9e086540366b5a46db4baa3edb7bbdb79ecfe3a9e0a8857cd9317f5deb6323b583ad092beadd9b0eb52c8c892f SHA512 6cd8985a729fd36a74ff3211b2021ceef7ea2c9a74ef259117e2df5c2fc97cbdf070539d47224720b33024af92ca9041f979fd7d7e84aba8955e820e22e96e2a
DIST botocore-1.34.37.gh.tar.gz 12691397 BLAKE2B ee44e6f4e3728e660dc8299bd14584b06e624c14443701782cb9f296700146dc1d438eee737579ecc1294374599799302373e0d7b668c7b649c76fea5fd3316c SHA512 289f6bf8a622a59ede8bfdac71fd31fea15193790ee0e0f2bd773be68ecec1c9de93325f25bb964d2094fd829c3292930416badb6abf78ad92ccc077fd651a7c
DIST botocore-1.34.38.gh.tar.gz 12694520 BLAKE2B ff21e6247fb2cc5f050abc78e45e21523310aadb0fedf9a028f23dcddeb2ed28b2a08e7fb7c817b8c8eb286ec4b6702f1312b5dcc141ffc8043175ebec6c33f5 SHA512 3b2eb3d9b1b48106c0176391cb76ca74b5d546938c61284ae4475cf33d13cfc95bf1f2d3b8c7eb8dc33907e18a351977fe9a6d0cadc9742f49c12a7775570a09
67 changes: 67 additions & 0 deletions dev-python/botocore/botocore-1.34.38.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )

inherit distutils-r1

DESCRIPTION="Low-level, data-driven core of boto 3"
HOMEPAGE="
https://github.com/boto/botocore/
https://pypi.org/project/botocore/
"
SRC_URI="
https://github.com/boto/botocore/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"

RDEPEND="
<dev-python/jmespath-2[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
"
# unbundled packages
RDEPEND+="
dev-python/requests[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/jsonschema[${PYTHON_USEDEP}]
)
"

EPYTEST_XDIST=1
distutils_enable_tests pytest

src_prepare() {
# unpin deps
sed -i -e "s:>=.*':':" setup.py || die

# unbundle deps
rm -r botocore/vendored || die
find -name '*.py' -exec sed -i \
-e 's:from botocore[.]vendored import:import:' \
-e 's:from botocore[.]vendored[.]:from :' \
{} + || die

distutils-r1_src_prepare
}

python_test() {
local EPYTEST_DESELECT=(
# rely on bundled six
tests/functional/test_six_imports.py::test_no_bare_six_imports
tests/functional/test_six_threading.py::test_six_thread_safety
)

local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest tests/{functional,unit}
}

0 comments on commit 08ec056

Please sign in to comment.