Skip to content

Commit

Permalink
media-gfx/fotema: Bump to 1.18.3
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jan 6, 2025
1 parent e8ca1f4 commit 11daaa3
Show file tree
Hide file tree
Showing 2 changed files with 94 additions and 0 deletions.
3 changes: 3 additions & 0 deletions media-gfx/fotema/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,4 @@
DIST fotema-1.14.4.tar.xz 78458268 BLAKE2B 4f8cc8f1ba3df27eca16b41e11ae947fe15b83321bc2da23f01a16012d862999a0cf6572353bc74cf2868a91404b199712b4f4d9df63ed87970469d57bb5be16 SHA512 189638c8d7e4466b1318ec06324cd1bfb3eaa36b9b7116b7e44a654d4cd09fb38961c0a5fa02469180f66844614555773e2306becd590eb7b8ba8fb074e9c3cc
DIST fotema-1.18.3-crates.tar.xz 62354556 BLAKE2B 6b8af1e6edf5efb751f60803b27e8001d916854bd7cdcf4e9a06bc21cfdd856e80ee58cc59fbd7750da5f159f3b231c597f4660534b65cb38dcc7421cd24213f SHA512 811df7a370b500c1e1cb8e9218026bb30b17da3860a88d8972601459c9c54101c18a59885040a2306ccc7c18081a1c3e7148ebb8b9bd48d3dfdba86157345192
DIST fotema-1.18.3.gh.tar.gz 8947271 BLAKE2B 7e1ba24aa38b1bd8b1e8291fa0bfcb7aad5d36f366bb5a0cc7114c5d72cef3083918f6a28cfcee713bf8e079822ee61146e1ee508dd0740f53591878078534aa SHA512 fa8bee36328b5a261eef7e1ef123dab724fb7521e77c5b8e3e4104d0693d4a16b486cc9f19149b6e4aeae8c598f910214a72c3d5ddb93cc1f74848f2100f66ec
DIST fotema-rust-faces-43c0d5acd6f3f4d90c6487708f2e511a73bf7c9e.gh.tar.gz 839519 BLAKE2B 7ba344d55c5d108e63556dda32aaf60cfbd2b14a05e2965ca69e54e2aab578f6ba49f7a7b89d6c32cb5ace4b80f7a84247dcbb43a98d5d709895810798966b0b SHA512 aac99659e2d82d342f52b5860d9f1e284e1658fa9e0986b1c54a81cc33f6391535a2773d79defc6a7bf1e52591dc91d91a1ef3742c38e599baed79975b42de51
91 changes: 91 additions & 0 deletions media-gfx/fotema/fotema-1.18.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,91 @@
# Copyright 2024-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

CRATES="
"

declare -A GIT_CRATES=(
[rust-faces]='https://github.com/blissd/fotema-rust-faces;43c0d5acd6f3f4d90c6487708f2e511a73bf7c9e;fotema-rust-faces-%commit%'
)

inherit cargo gnome2-utils meson xdg-utils

CRATE_P=${P}
DESCRIPTION="Photo gallery for Linux"
HOMEPAGE="https://github.com/blissd/fotema"
SRC_URI="
https://github.com/blissd/fotema/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
${CARGO_CRATE_URIS}
"
if [[ ${PKGBUMPING} != ${PVR} ]]; then
SRC_URI+="
https://dev.gentoo.org/~mgorny/dist/${CRATE_P}-crates.tar.xz
"
fi

# see LICENSES/
LICENSE="
CC-BY-2.0 CC-BY-4.0 CC-BY-NC-SA-4.0 CC-BY-SA-4.0 CC0-1.0
FDL-1.3+ GPL-3+ MIT
"
# Dependent crate licenses
LICENSE+="
Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD CC0-1.0 ISC MIT
MPL-2.0 Unicode-3.0 WTFPL-2 ZLIB
"
SLOT="0"
KEYWORDS="~amd64"

DEPEND="
>=dev-libs/glib-2.66:2
>=gui-libs/gtk-4.16:4
"
# indirect deps via crates
DEPEND+="
dev-libs/openssl:=
gui-libs/libadwaita
media-libs/fontconfig
media-libs/graphene
media-libs/lcms:2
media-libs/libshumate:=
media-libs/opencv:=[contribdnn]
media-video/ffmpeg:=
sci-libs/onnx
sys-libs/libseccomp
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/pango
"
RDEPEND="
${DEPEND}
media-libs/glycin-loaders
"
BDEPEND="
dev-libs/glib:2
"

QA_FLAGS_IGNORED="/usr/bin/fotema"

src_configure() {
local emesonargs=(
-Dprofile=$(usex debug development default)
)

meson_src_configure
ln -s "${CARGO_HOME}" "${BUILD_DIR}/cargo-home" || die

export ORT_STRATEGY=system
}

pkg_postinst() {
gnome2_schemas_update
xdg_icon_cache_update
}

pkg_postrm() {
gnome2_schemas_update
xdg_icon_cache_update
}

0 comments on commit 11daaa3

Please sign in to comment.