forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-fps/quake1-rally: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
4ed59a3
commit 27a8c4e
Showing
1 changed file
with
17 additions
and
16 deletions.
There are no files selected for viewing
33 changes: 17 additions & 16 deletions
33
...-fps/quake1-rally/quake1-rally-1.2.ebuild → ...s/quake1-rally/quake1-rally-1.2-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,38 +1,39 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
inherit eutils games | ||
EAPI=7 | ||
|
||
inherit edos2unix | ||
|
||
DESCRIPTION="TC which turns Quake into a Rally racing game" | ||
HOMEPAGE="http://wiki.quakeworld.nu/Quake_Rally" | ||
SRC_URI="http://ehall.freeshell.org/quake/qr12.zip | ||
http://ehall.freeshell.org/quake/qrlo1.zip" | ||
S="${WORKDIR}" | ||
|
||
LICENSE="all-rights-reserved" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
RESTRICT="mirror bindist" | ||
|
||
RDEPEND="" | ||
DEPEND="app-arch/unzip" | ||
RESTRICT="mirror bindist" | ||
|
||
S=${WORKDIR} | ||
BDEPEND="app-arch/unzip" | ||
|
||
src_unpack() { | ||
echo ">>> Unpacking qr12.zip to ${PWD}" | ||
einfo "Unpacking qr12.zip to ${PWD}" | ||
unzip -qoLL "${DISTDIR}"/qr12.zip || die "unpacking qr12.zip failed" | ||
echo ">>> Unpacking qrlo1.zip to ${PWD}" | ||
|
||
einfo "Unpacking qrlo1.zip to ${PWD}" | ||
unzip -qoLL "${DISTDIR}"/qrlo1.zip || die "unpacking qrlo1.zip failed" | ||
rm -f button.wav qrally.exe | ||
cd rally | ||
edos2unix $(find . -name '*.txt' -o -name '*.cfg') | ||
mv rally{,.example}.cfg | ||
|
||
rm -f button.wav qrally.exe || die | ||
cd rally || die | ||
|
||
edos2unix $(find . -name '*.txt' -o -name '*.cfg' || die) | ||
mv rally{,.example}.cfg || die | ||
} | ||
|
||
src_install() { | ||
insinto "${GAMES_DATADIR}/quake1" | ||
insinto /usr/share/quake1 | ||
doins -r * | ||
prepgamesdirs | ||
} |