Skip to content

Commit

Permalink
dev-python/stripe: Bump to 11.4.1
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 20, 2024
1 parent 481a894 commit 2edae00
Show file tree
Hide file tree
Showing 2 changed files with 96 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/stripe/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST stripe-11.3.0.tar.gz 1367031 BLAKE2B b46cae95059a1aa7087743772b5cb23456e64b276befa852b0c13ce417f624ac6d9a90e64a43aeb3d60941ad73cc87afa114d4161c5e5b3e5ae6033b4378f6c1 SHA512 4b8934653f138b86f7d64977f2817fc0ad54a89d794521af7d1f193ecdcbb366e78ece286a3c768f946d281aba998443e675e6db66fcd3a0084641053e55a182
DIST stripe-11.4.0.tar.gz 1378868 BLAKE2B 86444654843d90cd068c8f5b240fbc7f141a128c31b4d85e2b096fa202b5f1a662891f4ac0902725ebb2ec54f61e4fc45558239caa31f7db5c67bfc0c72e758f SHA512 083f9fee32d48c1a4097168871f56b9027f5098e9628b6ac29440ab4fced445b824795ba77129edf1e5cd41f99f086f26475d289d65f2e2fff94103913aa9d6a
DIST stripe-11.4.1.tar.gz 1379118 BLAKE2B 6acbbe35ab7625d9bb0be6c92b901c71b9d93a69d5b1bfd99826cdd1288db10a87c07e88a7f66a08dece7d84767b43760c3487e9f601658b2a0d13c27f9405d5 SHA512 1bf68094002226d9b47cf29cae54116f7fb5cbc7cb000a7dc3d95eb0cbbcb75b5979348aabab4417ca455a8a28bd8d90756f6258ff0ff1c6b0af3130e8fe0563
95 changes: 95 additions & 0 deletions dev-python/stripe/stripe-11.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,95 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} pypy3 )

inherit distutils-r1 pypi

DESCRIPTION="Stripe Python bindings"
HOMEPAGE="
https://github.com/stripe/stripe-python/
https://pypi.org/project/stripe/
"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="telemetry"

RDEPEND="
>=dev-python/requests-2.20[${PYTHON_USEDEP}]
>=dev-python/typing-extensions-4.5.0[${PYTHON_USEDEP}]
"
# please bump dev-util/stripe-mock dep to the latest version on every bump
BDEPEND="
test? (
>=dev-util/stripe-mock-0.192.0
dev-python/aiohttp[${PYTHON_USEDEP}]
dev-python/anyio[${PYTHON_USEDEP}]
dev-python/httpx[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/trio[${PYTHON_USEDEP}]
net-misc/curl
)
"

EPYTEST_XDIST=1
distutils_enable_tests pytest

DOCS=( LONG_DESCRIPTION.rst CHANGELOG.md README.md )

src_prepare() {
distutils-r1_src_prepare

if ! use telemetry; then
sed -i -e '/enable_telemetry/s:True:False:' stripe/__init__.py || die
fi
}

python_test() {
local EPYTEST_DESELECT=(
# exception message mismatch with aiohttp-3.10.0
"tests/test_integration.py::TestIntegration::test_async_timeout[asyncio-aiohttp]"
"tests/test_integration.py::TestIntegration::test_async_raw_request_timeout[asyncio-aiohttp]"
# Internet
tests/test_http_client.py::TestLiveHTTPClients::test_httpx_request_async_https
)

local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest tests -p anyio -p pytest_mock
}

src_test() {
local stripe_mock_port=12111
local stripe_mock_max_port=12121
local stripe_mock_logfile="${T}/stripe_mock_${EPYTHON}.log"
# Try to start stripe-mock until we find a free port
while [[ ${stripe_mock_port} -le ${stripe_mock_max_port} ]]; do
ebegin "Trying to start stripe-mock on port ${stripe_mock_port}"
stripe-mock --http-port "${stripe_mock_port}" &> "${stripe_mock_logfile}" &
local stripe_mock_pid=${!}
sleep 2
# Did stripe-mock start?
curl --fail -u "sk_test_123:" \
"http://127.0.0.1:${stripe_mock_port}/v1/customers" &> /dev/null
eend ${?} "Port ${stripe_mock_port} unavailable"
if [[ ${?} -eq 0 ]]; then
einfo "stripe-mock running on port ${stripe_mock_port}"
break
fi
(( stripe_mock_port++ ))
done
if [[ ${stripe_mock_port} -gt ${stripe_mock_max_port} ]]; then
eerror "Unable to start stripe-mock for tests"
die "Please see the logfile located at: ${stripe_mock_logfile}"
fi

local -x STRIPE_MOCK_PORT=${stripe_mock_port}
distutils-r1_src_test

# Tear down stripe-mock
kill "${stripe_mock_pid}" || die "Unable to stop stripe-mock"
}

0 comments on commit 2edae00

Please sign in to comment.