forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Bug: https://bugs.gentoo.org/692162 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Miroslav Šulc <[email protected]>
- Loading branch information
Showing
2 changed files
with
28 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST antlr-2.7.7.tar.gz 1816180 BLAKE2B 3a9a51070f8651befeb4d22be344b544e119db34a78522828c2ffc3c481c14b9c7784f0a9997a61f6faedde5b6d1fe12214cfd84fb274f7065f3ffe6a44abf1c SHA512 faa72d2ddcba434ef1233e70c1549e63eba67c00793966322e821cf7f015cccb804448cb92d8fbef0429f59928fad65ec954f8ffbda0acbb8e983de0806d349d | ||
DIST antlr-cpp-3.5.2.tar.gz 6927136 BLAKE2B 754d98614945692d122c54f2a9b4b694723794c1061982107ae3ca471ffb0967d67c4004b53490d0db10c4332adc8d7482c8567324dfa2c5fd1a67e12c228b3e SHA512 796150c569320793614b9cab45f507e9e22947314c38eb8f8601823cd0e6fe1ac08f4433c7600d511bf822e46f5e8a21d193633192ae68f1bb64b8354eec250e | ||
DIST antlr-cpp-4.7.1.zip 462076 BLAKE2B 209e7a4f50ae0686a21a85728f5a7478305971ac6653941e19b34a9fdd367fbcf87300c32a83cd6cc021216d564f6348e589ede7a3491a5411f16ca8fe373569 SHA512 24d53278db56b199e6787242f22339f74e07d2cd3ed56f851ad905b110c2ba3cb001e1e2fcbc8624f0e93e00ba1fe1b23630dd1a736558c694655aeb1c3129da | ||
DIST antlr-cpp-4.7.2.zip 1494927 BLAKE2B 007aac6655dc3c4e3a0c2073ca9c8c016b46bdf97dca4494d4ea2c44d27a458bfbb09811b3beb0aec1ce2873c3b62ad6789c6a9e3e7ddc62cde51c8357e9123b SHA512 3298b83a06ddd8d8852462401e46fe2eb83d20af4ba14c722cb31b33d929d1c5a4ffb694ee084495a4ae26ed3246b6781ca6045d11253c94efc09729fa001090 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,27 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit cmake-utils | ||
|
||
DESCRIPTION="The ANTLR 4 C++ Runtime" | ||
HOMEPAGE="https://www.antlr.org/" | ||
SRC_URI="https://www.antlr.org/download/antlr4-cpp-runtime-${PV}-source.zip -> ${P}.zip" | ||
LICENSE="BSD" | ||
SLOT="4" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
DEPEND="app-arch/zip" | ||
|
||
S="${WORKDIR}" | ||
|
||
src_prepare() { | ||
sed -i -e "s#DESTINATION lib#DESTINATION $(get_libdir)#" \ | ||
"${S}"/runtime/CMakeLists.txt || die "failed sed" | ||
|
||
sed -i -e "s#share/doc/libantlr4#share/doc/${P}#g" \ | ||
"${S}"/CMakeLists.txt || die "failed sed" | ||
|
||
cmake-utils_src_prepare | ||
} |