Skip to content

Commit

Permalink
mail-mta/ssmtp: Fix build w/ GCC-14
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/879873
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Jun 11, 2024
1 parent e33053f commit 45ea3f6
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 1 deletion.
43 changes: 43 additions & 0 deletions mail-mta/ssmtp/files/ssmtp-2.64_p11-gcc14.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
From 85acc260f11090415c0f94b7d726917d6a449018 Mon Sep 17 00:00:00 2001
From: psykose <[email protected]>
Date: Wed, 19 Apr 2023 20:11:39 +0000
Subject: main/ssmtp: fix int-conversion

fixes -Werror=int-conversion
--
diff --git a/ssmtp.c b/ssmtp.c
index af4d1e5..9a28320 100644
--- a/ssmtp.c
+++ b/ssmtp.c
@@ -55,21 +55,21 @@ bool_t use_oldauth = False; /* use old AUTH LOGIN username style */

#define ARPADATE_LENGTH 32 /* Current date in RFC format */
char arpadate[ARPADATE_LENGTH];
-char *auth_user = (char)NULL;
-char *auth_pass = (char)NULL;
-char *auth_method = (char)NULL; /* Mechanism for SMTP authentication */
-char *mail_domain = (char)NULL;
-char *from = (char)NULL; /* Use this as the From: address */
+char *auth_user = NULL;
+char *auth_pass = NULL;
+char *auth_method = NULL; /* Mechanism for SMTP authentication */
+char *mail_domain = NULL;
+char *from = NULL; /* Use this as the From: address */
char *hostname;
char *mailhost = "mailhub";
-char *minus_f = (char)NULL;
-char *minus_F = (char)NULL;
+char *minus_f = NULL;
+char *minus_F = NULL;
char *gecos;
-char *prog = (char)NULL;
+char *prog = NULL;
char *root = NULL;
char *tls_cert = "/etc/ssl/certs/ssmtp.pem"; /* Default Certificate */
-char *uad = (char)NULL;
-char *config_file = (char)NULL; /* alternate configuration file */
+char *uad = NULL;
+char *config_file = NULL; /* alternate configuration file */

headers_t headers, *ht;

4 changes: 3 additions & 1 deletion mail-mta/ssmtp/ssmtp-2.64_p11-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2023 Gentoo Authors
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand Down Expand Up @@ -47,6 +47,8 @@ RDEPEND="
)
"

PATCHES=( "${FILESDIR}"/${P}-gcc14.patch ) # bug 879873, from Alpine

src_prepare() {
drop_debian_patch() {
rm "${WORKDIR}"/debian/patches/${1} || die
Expand Down

0 comments on commit 45ea3f6

Please sign in to comment.