Skip to content

Commit

Permalink
app-portage/metagen: Python 3.12
Browse files Browse the repository at this point in the history
Signed-off-by: Sebastian Pipping <[email protected]>
  • Loading branch information
hartwork committed Nov 5, 2023
1 parent 12e836f commit 553f42b
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 1 deletion.
35 changes: 35 additions & 0 deletions app-portage/metagen/metagen-0.7.3-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="8"
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..12} )

inherit distutils-r1 pypi

DESCRIPTION="metadata.xml generator for ebuilds"
HOMEPAGE="https://cgit.gentoo.org/proj/metagen.git"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"

IUSE=""
DEPEND="dev-python/lxml[${PYTHON_USEDEP}]
sys-apps/portage[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"

python_install_all() {
distutils-r1_python_install_all
doman docs/metagen.1

# Bug 814545 and 832069
if [[ ${PF} != ${P} ]]; then # to be robust across bumps
mv "${ED}"/usr/share/doc/${P}/* "${ED}"/usr/share/doc/${PF}/ || die
rmdir "${ED}"/usr/share/doc/${P}/ || die
fi
}

python_test() {
"${PYTHON}" -c "from metagen import metagenerator; metagenerator.do_tests()" || die
}
2 changes: 1 addition & 1 deletion app-portage/metagen/metagen-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

EAPI="8"
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_COMPAT=( python3_{9..12} )

inherit distutils-r1 git-r3

Expand Down

0 comments on commit 553f42b

Please sign in to comment.