Skip to content

Commit

Permalink
dev-vcs/git-machete: add 3.20.0
Browse files Browse the repository at this point in the history
Signed-off-by: Marek Szuba <[email protected]>
  • Loading branch information
Marek Szuba committed Oct 24, 2023
1 parent 270be8a commit 6110cb7
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/git-machete/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST git-machete-3.17.6.gh.tar.gz 1638444 BLAKE2B 91995dec3dba53cd538db549248d9c42932ab4f4c3b7f016d60e4999617bd428c1c4fcfae3bc2aca75bba7bf62b4466e139ddada47a962f0f7d876cd220dbe34 SHA512 0766997db950a04ed5eec560be7fe1e76370d2c5f747bf121241280d44a3aff094c5828535bd11831ce1b326e05d48c8e4edf620c1dcccfbeb20e9d94c3cf023
DIST git-machete-3.18.0.gh.tar.gz 1639576 BLAKE2B cd77ef6c86dc2eee6430bec5d371566082dd9243dc9a99d7b60e78155ce7340f8f798d59073acbb65e75483389d8ffd9a6f75520ed9f1aaa517ea31281dbd672 SHA512 ca070000020defa69e4b8592ee77e8b7f6e7a8b0397b90f0f5b6b31a9d46a85f3d17ed96b7795fab145794182d7b40dd8acd9bda498533deada6e6efae24dbca
DIST git-machete-3.18.2.gh.tar.gz 1640834 BLAKE2B c6d19b2207fcfa649ff5a1a32a5764b7c133c0bbf9f4ee16b6dbf9b1085d328e355d7267ab07f76ae4ebb6de4db94256a85bd8fc89a4a2e54724955452f7f616 SHA512 7a1aff9e3f8a4792a33de455e97a3435a64e4a9feede2d53aa12a8d7c12528a00e232a756726b94267acb8d25264e6122240b30cf3498db03de4fafb6c6fe725
DIST git-machete-3.20.0.gh.tar.gz 1645348 BLAKE2B d07a7a78e835eb1afbed40d4133ba9ed914492cce03fbcd5c63bdd4260e65b6300e77d1f33175c7471667f044960b2948278db27b2d29731e7afe86564207311 SHA512 ba2a7e6741ad6cf47577301dd810fcd2bf7b2436fedf4b5fd566faad62fae54861d21b14ffa9395297e28e4176a9710b13e22dbb917bc7a8cc7f9f286c9f8afc
45 changes: 45 additions & 0 deletions dev-vcs/git-machete/git-machete-3.20.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools

inherit bash-completion-r1 distutils-r1

DESCRIPTION="Probably the sharpest git repo organizer & rebase/merge workflow automation tool"
HOMEPAGE="https://github.com/VirtusLab/git-machete https://pypi.org/project/git-machete/"
# No tests in PyPI tarballs
SRC_URI="https://github.com/VirtusLab/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv"

RDEPEND="dev-vcs/git"
BDEPEND="test? (
>=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
>=dev-python/pytest-xdist-3.2.1[${PYTHON_USEDEP}]
)"

DOCS=( CONTRIBUTING.md README.md )

distutils_enable_tests pytest

# Several of the fish- and zsh-completion tests appear to be broken
EPYTEST_DESELECT=(
tests/completion_e2e/test_completion_e2e.py::TestCompletionEndToEnd::test_completion
)

src_install() {
distutils-r1_src_install

newbashcomp completion/${PN}.completion.bash ${PN}

insinto /usr/share/fish/vendor_completions.d
doins completion/${PN}.fish

insinto /usr/share/zsh/site-functions
newins completion/${PN}.completion.zsh _${PN}
}

0 comments on commit 6110cb7

Please sign in to comment.