Skip to content

Commit

Permalink
app-emulation/plus42: add 1.1.16
Browse files Browse the repository at this point in the history
Signed-off-by: Bernard Cafarelli <[email protected]>
  • Loading branch information
voyageur committed Dec 20, 2024
1 parent 197f7d3 commit 63be2c7
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/plus42/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST plus42-upstream-1.1.11.tgz 7613219 BLAKE2B edd390be71318fbe351e997e3cedb2bf
DIST plus42-upstream-1.1.12.tgz 7613262 BLAKE2B 983388034eca0bfceb4d2ca129a7fad5192e642e6bb05365bb883b7cb9a7bc571181b28214c2d4a9efd97a87d2836f95e4755e33f7a98bcc8bba0b5a97e4f226 SHA512 b0502d3132e49fc29d3e5b6b9d9fe4d6de52ebf5a44937a3847932993563e7ba12cca72dfa6d505acaa5eb95ffd5692df4b10b35075e846a17a9a621f31df225
DIST plus42-upstream-1.1.13.tgz 7613465 BLAKE2B 88940160f2d5aa9c06b9b19b12a4bc747ef7c9e354075ca144997cffda42f7a07f3da602385b9e574402fa957463dce4bf3ba1237c11fa34d99bb3ed36249a67 SHA512 ff1f80be13337debf98e1a3e157e4bd5f017acde27e716254496606af8b4ffd967f8a03dc4e263e6fdf4ec62acf46fd5981297c0b29748b7dc0320969b14fa5b
DIST plus42-upstream-1.1.14.tgz 7613616 BLAKE2B 9d0ff8205188460e8f1a5bd539425954a82202ffb8f62beb76b81838d7f3ff325f5f20fffeadf5ceef750dc662b9f1673b94dc9f61297da55c7d0a36e7a8a574 SHA512 e2edcfeac9c464e9c22dc114392be81a5f70d2327d6787585a1b6038e665236119a031e9e6bf380c08e0147c77149df518335b3fdca238ed9684a4254b5f5af7
DIST plus42-upstream-1.1.16.tgz 7620137 BLAKE2B e403386ee121292fb4561352f7ba8db3e9ecf39506df643a7de21a3b54b29eb3f866e0d236eb70c1fc112c98a91cdd3f3bac5bafd3329c94ed420950bcf5b9ef SHA512 cac03b6431d9137d4ec1904fe5945b45d0c29219dbf820f0159a98fbfc81f2b7c638307b09424ad79b4322c250056d6c7b87c915ea2ee034bbf8f7276ad82a62
49 changes: 49 additions & 0 deletions app-emulation/plus42/plus42-1.1.16.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs

MY_PV="${PN}-upstream-${PV}"

DESCRIPTION="An Enhanced HP-42S Calculator Simulator"
HOMEPAGE="https://thomasokken.com/plus42/"
SRC_URI="https://thomasokken.com/plus42/upstream/${MY_PV}.tgz"
S=${WORKDIR}/${MY_PV}

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+alsa"

DEPEND="app-accessibility/at-spi2-core
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:3
alsa? ( media-libs/alsa-lib )"
RDEPEND="${DEPEND}"

DOCS=( CREDITS HISTORY README )

PATCHES=(
"${FILESDIR}/${PN}-1.0.9-fix-makefile.patch"
"${FILESDIR}/${PN}-1.0.12-fix-build-intel-lib.patch"
)

src_prepare() {
default
}

src_compile() {
local myconf
use alsa && myconf="AUDIO_ALSA=yes"
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${myconf} -C gtk
emake -C gtk clean
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C gtk
}

src_install() {
default
dobin gtk/plus42bin gtk/plus42dec
}

0 comments on commit 63be2c7

Please sign in to comment.