Skip to content

Commit

Permalink
app-misc/ddcutil: add 2.1.3
Browse files Browse the repository at this point in the history
Signed-off-by: Andrew Ammerlaan <[email protected]>
  • Loading branch information
Nowa-Ammerlaan committed Feb 8, 2024
1 parent afb331a commit 648c3ba
Show file tree
Hide file tree
Showing 2 changed files with 121 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/ddcutil/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST ddcutil-1.4.1.tar.gz 816782 BLAKE2B ebc8b8893fda9a1e5b278b198594619f7c26a30
DIST ddcutil-1.4.5.tar.gz 817492 BLAKE2B b6442d9f7ec3687a3e75d9784dc9f62563f42c72c82a8a2ea24a392c3c4f186578c2c2f6592ba12c324568a20b7b25082acce9e7b753c41c1ac925d9d6de62dd SHA512 c355f104b60dbc3c893dea473d841181cfcaacd0cb2e97bc41ea829185c7ccdcff19ab19189ee572e7f2f6b41cbb2bd6c569ad3c09f6d645f9e342b7d1a5310f
DIST ddcutil-2.0.0.tar.gz 882984 BLAKE2B 19f92ab7fb02130c84e029a8055fe85ea99b9bd2959ad3c86b698afba9a45844817c0828fd2ad3178b954493a12dc62e95815e2700a42d37c340f098ad9d3f16 SHA512 e1880cf0e3e724f6ac88f807a867a34f451422b58ce7d23bee7b2fc40b253ef8de13df7706749e0c8242fe5de6db8da91784d16fbf008bb5161732a598c3b9e7
DIST ddcutil-2.1.2.tar.gz 920903 BLAKE2B 2dbafc6f6da642a4cbbd245fac62c2bdac19543887de69a768f87257967a5c67902a676a3adc5a6ad90b4c6b540b36293196a4401a0f26c58951f1fbb55d024c SHA512 ed57e0d3de7c0badc0dabd81624e6425c807fb62c8e0e88660f5bd94aba954ea0a7eb2bed47cfe1d14a5917e0ccd40ca26c2b9d76c2b4b8df57d17095db7c02f
DIST ddcutil-2.1.3.tar.gz 924320 BLAKE2B a7e07a1bfad4c34f585f7ba09efda15877cba20002edeef952d2c0037ed1d7f67e6634999ff51a0b25c943c7debdcee4113b17e00011a3c6f390a8f8db13f297 SHA512 e58b0c2ea3f4cd0e15a3b772fdd840486d1c5d62bb797ad1500fdb8bcafe33ac3318162b66b972393e3f6f41186b2819e87c7c3c14a7a3bb6d6d79142c7ed5d6
120 changes: 120 additions & 0 deletions app-misc/ddcutil/ddcutil-2.1.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,120 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

# Check for bumps & cleanup with app-misc/ddcui

inherit autotools linux-info udev

DESCRIPTION="Program for querying and changing monitor settings"
HOMEPAGE="https://www.ddcutil.com/"
SRC_URI="https://github.com/rockowitz/ddcutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"

SLOT="0/5"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
IUSE="drm usb-monitor user-permissions video_cards_nvidia X"
REQUIRED_USE="drm? ( X )"

RDEPEND="
dev-libs/glib:2
>=dev-libs/jansson-2
sys-apps/i2c-tools
virtual/udev
drm? ( x11-libs/libdrm )
usb-monitor? (
dev-libs/hidapi
virtual/libusb:1
sys-apps/usbutils
)
user-permissions? (
acct-group/i2c
usb-monitor? ( acct-group/video )
)
X? (
x11-libs/libXrandr
x11-libs/libX11
)
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
# doc? ( app-text/doxygen[dot] )

PATCHES=(
"${FILESDIR}"/${PN}-1.4.1-no-werror.patch
)

pkg_pretend() {
# This program needs /dev/ic2-* devices to communicate with the monitor.
CONFIG_CHECK="~I2C_CHARDEV"
ERROR_I2C_CHARDEV="You must enable I2C_CHARDEV in your kernel to continue"
if use usb-monitor; then
CONFIG_CHECK+=" ~HIDRAW ~USB_HIDDEV"
ERROR_HIDRAW="HIDRAW is needed to support USB monitors"
ERROR_I2C_CHARDEV="USB_HIDDEV is needed to support USB monitors"
fi

# Now do the actual checks setup above
check_extra_config
}

src_prepare() {
default
eautoreconf
}

src_configure() {
local myeconfargs=(
# FAILS: doxyfile: No such file or directory
# $(use_enable doc doxygen)
$(use_enable drm)
--enable-udev
$(use_enable usb-monitor usb)
--enable-lib
$(use_enable X x11)
)

econf "${myeconfargs[@]}"
}

src_install() {
default
if use user-permissions; then
udev_dorules data/usr/lib/udev/rules.d/60-ddcutil-i2c.rules
if use usb-monitor; then
udev_dorules data/usr/lib/udev/rules.d/60-ddcutil-usb.rules
fi
fi
}

pkg_postinst() {
if use user-permissions; then
einfo "To allow non-root users access to the /dev/i2c-* devices, add those"
einfo "users to the i2c group: usermod -aG i2c user"
einfo "Restart the computer or reload the i2c-dev module to activate"
einfo "the new udev rule."
einfo "For more information read: http://www.ddcutil.com/i2c_permissions/"

if use usb-monitor; then
einfo "To allow non-root users access to USB monitors, add those users"
einfo "to the video group: usermod -aG video user"
einfo "Restart the computer, reload the hiddev and hidraw modules, or replug"
einfo "the monitor to activate the new udev rule."
einfo "For more information read: http://www.ddcutil.com/usb/"
fi

udev_reload
fi

if use video_cards_nvidia; then
ewarn "Please read the following webpage on proper usage with the nVidia "
ewarn "binary drivers, or it may not work: http://www.ddcutil.com/nvidia/"
fi
}

pkg_postrm() {
if use user-permissions; then
udev_reload
fi
}

0 comments on commit 648c3ba

Please sign in to comment.