Skip to content

Commit

Permalink
net-misc/anydesk: add 6.3.3
Browse files Browse the repository at this point in the history
Signed-off-by: Jaco Kroon <[email protected]>
Closes: gentoo#38925
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
jkroonza authored and juippis committed Nov 6, 2024
1 parent 49e1780 commit 6fa86dc
Show file tree
Hide file tree
Showing 2 changed files with 102 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/anydesk/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST anydesk-6.3.2-amd64.tar.gz 7039607 BLAKE2B dfc628baef862bddb944b02d39c3e270a0ac4dbe88704099f8b9022e7e758a367093432b78e86bcc1d9432fabe1c2842c4e811e59541433cb75a9734e09cff08 SHA512 a0fac07d6beb085666f4414f592b5b26b0f699ebc0b1ad5a587317a0c46b0f92a8d3b3e2e0ab08ce9e6c4c1c15789f8396158cc87075e623e32ce714ad071612
DIST anydesk-6.3.3-amd64.tar.gz 7048124 BLAKE2B 6b97a60709337e01e70f11cfe4a82d71465961de99bc075c900d0f656427502fa6543c68b9dcd30cb4a3091ba0bd10b3b1bea0ea0e7792ef51a76b376d1ffe29 SHA512 4819ee1a7420fed503c743601a8e4e5000150e176b1d695e34c8ffb5da2475ca2ccd6f5024c9d011661e7e0f133a592bcfc19a2e32ba2ffd9a92f701b0eb929f
101 changes: 101 additions & 0 deletions net-misc/anydesk/anydesk-6.3.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,101 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="8"

inherit desktop optfeature systemd xdg-utils

DESCRIPTION="Feature rich multi-platform remote desktop application"
HOMEPAGE="https://anydesk.com"
SRC_URI="https://download.anydesk.com/linux/${P}-amd64.tar.gz"

# OpeSSL/SSLeay, libvpx, zlib, Xiph, xxHash
LICENSE="AnyDesk-TOS BSD BSD-2 openssl ZLIB"
SLOT="0"
KEYWORDS="-* ~amd64"

# x11-libs/gtkglext is required and cannot be mitigated: https://bugs.gentoo.org/868255
RDEPEND="
app-accessibility/at-spi2-core:2
dev-libs/glib:2
media-libs/fontconfig:1.0
media-libs/freetype:2
media-libs/glu
media-libs/libglvnd
sys-auth/polkit
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:2
x11-libs/gtkglext
x11-libs/libX11
x11-libs/libxcb
x11-libs/libXdamage
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXi
x11-libs/libxkbfile
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libXtst
x11-libs/pango
"
BDEPEND="dev-util/patchelf"

RESTRICT="bindist mirror"

QA_PREBUILT="opt/${PN}/*"

src_install() {
local dst="/opt/${PN}"

exeinto ${dst}
doexe ${PN}

dodir /opt/bin
dosym "${dst}/${PN}" "/opt/bin/${PN}"

newinitd "${FILESDIR}/anydesk.init" anydesk
systemd_newunit "${FILESDIR}/anydesk-4.0.1.service" anydesk.service

insinto /usr/share/polkit-1/actions
doins polkit-1/com.anydesk.anydesk.policy

insinto /usr/share
doins -r icons

domenu "${FILESDIR}/anydesk.desktop"

dodoc copyright README
}

pkg_postinst() {
xdg_desktop_database_update
xdg_icon_cache_update

if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "To run AnyDesk as background service use:"
elog
elog "OpenRC:"
elog "# rc-service anydesk start"
elog "# rc-update add anydesk default"
elog
elog "Systemd:"
elog "# systemctl start anydesk.service"
elog "# systemctl enable anydesk.service"
elog
elog "Please see README at /usr/share/doc/${PF}/README.bz2 for"
elog "further information about the linux version of AnyDesk."
elog
fi

optfeature_header "AnyDesk additional tools:"
optfeature "lsb_release" sys-apps/lsb-release
optfeature "lspci" sys-apps/pciutils
optfeature "lsusb" sys-apps/usbutils
optfeature "sound support" media-libs/libcanberra[gtk2]
}

pkg_postrm() {
xdg_desktop_database_update
xdg_icon_cache_update
}

0 comments on commit 6fa86dc

Please sign in to comment.