forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
fix sound and lua config options; dep fixups
Package-Manager: portage-2.2.20.1
- Loading branch information
Michael Sterrett
committed
Nov 6, 2015
1 parent
958b0db
commit 6fe7401
Showing
1 changed file
with
81 additions
and
0 deletions.
There are no files selected for viewing
81 changes: 81 additions & 0 deletions
81
games-roguelike/crossfire-client/crossfire-client-1.71.0-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,81 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit autotools toolchain-funcs gnome2-utils games | ||
|
||
DESCRIPTION="Client for the nethack-style but more in the line of UO" | ||
HOMEPAGE="http://crossfire.real-time.com/" | ||
SRC_URI="mirror://sourceforge/crossfire/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="lua opengl sdl sound" | ||
|
||
RDEPEND=" | ||
sound? ( media-libs/sdl-mixer[vorbis] ) | ||
opengl? ( virtual/opengl | ||
media-libs/freeglut ) | ||
sdl? ( media-libs/libsdl[video] | ||
media-libs/sdl-image[png] ) | ||
lua? ( dev-lang/lua:0= ) | ||
x11-libs/gtk+:2 | ||
net-misc/curl | ||
media-libs/libpng:0 | ||
sys-libs/zlib" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
src_prepare() { | ||
sed -ri -e '/^.TH/s:$: 6:' $(find . -name "*man") || die | ||
sed -i -e 's/lua-5.1/lua/' configure.ac || die | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
# bugs in configure script so we cant use $(use_enable ...) | ||
local myconf | ||
|
||
use lua && myconf="${myconf} --enable-lua" | ||
use sdl || myconf="${myconf} --disable-sdl" | ||
use opengl || myconf="${myconf} --disable-opengl" | ||
use sound || myconf="${myconf} --disable-sound" | ||
|
||
egamesconf ${myconf} | ||
} | ||
|
||
src_compile() { | ||
# bug 139785 | ||
if use sound ; then | ||
emake -C sound-src AR="$(tc-getAR)" | ||
fi | ||
emake AR="$(tc-getAR)" | ||
} | ||
|
||
src_install() { | ||
local s | ||
|
||
default | ||
domenu gtk-v2/crossfire-client.desktop | ||
for s in 16 32 48 | ||
do | ||
newicon -s ${s} pixmaps/${s}x${s}.png ${PN}.png | ||
done | ||
prepgamesdirs | ||
} | ||
|
||
pkg_preinst() { | ||
games_pkg_preinst | ||
gnome2_icon_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
games_pkg_postinst | ||
gnome2_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_icon_cache_update | ||
} |