Skip to content

Commit

Permalink
games-puzzle/fish-fillets: respect AR
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/778590
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 10, 2021
1 parent 1189b6d commit 89640a2
Showing 1 changed file with 18 additions and 10 deletions.
28 changes: 18 additions & 10 deletions games-puzzle/fish-fillets/fish-fillets-1.0.1-r100.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand All @@ -12,49 +12,57 @@ DESCRIPTION="Underwater puzzle game - find a safe way out"
HOMEPAGE="http://fillets.sourceforge.net/"
SRC_URI="mirror://sourceforge/fillets/fillets-ng-${PV}.tar.gz
mirror://sourceforge/fillets/fillets-ng-data-${DATA_PV}.tar.gz"
S="${WORKDIR}/fillets-ng-${PV}"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

REQUIRED_USE="${LUA_REQUIRED_USE}"

RDEPEND="${LUA_DEPS}
RDEPEND="
${LUA_DEPS}
dev-libs/fribidi
>=media-libs/libsdl-1.2[sound,video]
>=media-libs/sdl-mixer-1.2.5[vorbis]
>=media-libs/sdl-image-1.2.2[png]
media-libs/sdl-ttf
media-libs/smpeg
x11-libs/libX11
media-libs/sdl-ttf
dev-libs/fribidi
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

S="${WORKDIR}/fillets-ng-${PV}"
PATCHES=(
"${FILESDIR}/${PN}-1.0.1-respect-AR.patch"
)

src_prepare() {
default

#.mod was renamed to .fmod in lua 5.1.3 - bug #223271
sed -i \
-e 's/\.mod(/.fmod(/' \
$(grep -rl "\.mod\>" "${WORKDIR}"/fillets-ng-data-${DATA_PV}) \
|| die "sed failed"
rm -f missing

rm -f missing || die
mv configure.in configure.ac || die
eautoreconf
}

src_configure() {
econf --datadir="/usr/share/${PN}"
econf --datadir=/usr/share/${PN}
}

src_install() {
rm -f COPYING || die

default
insinto "/usr/share/${PN}"

insinto /usr/share/${PN}
cd "${WORKDIR}"/fillets-ng-data-${DATA_PV} || die
rm -f COPYING
einstalldocs

doins -r *
newicon images/icon.png ${PN}.png
make_desktop_entry fillets "Fish Fillets NG"
Expand Down

0 comments on commit 89640a2

Please sign in to comment.