Skip to content

Commit

Permalink
sci-libs/hipFFT: add 6.3.0
Browse files Browse the repository at this point in the history
Signed-off-by: Sv. Lockal <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
AngryLoki authored and thesamesam committed Jan 5, 2025
1 parent ed438fd commit 8a910c2
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-libs/hipFFT/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST hipFFT-rocm-5.1.3.tar.gz 89397 BLAKE2B 3c29d5d660e9f3db8afd8c9e524296c29f50faf06a5d6a58ec628b5cc5ddb47ac2b99f137c7bc5090a311189b44014ea2f6f1f7547d22506f5ba18f837fbeb68 SHA512 8d7a90630cd8bfeade9cb026e45b6b6c1ab9c96dba424559a7ced8c881cd45c1cb06d3f7e82c8e6558e4ccb8bb41b6278842057a0cf0957b0644b1139f2c9706
DIST hipFFT-rocm-5.7.1.tar.gz 102616 BLAKE2B ee8d6dcb7924c8989987b02533126c4e4419d8dc83067a816f2253efe4537e094f1665d95699d4bf27f30cd13f3fc5df7d3b0062c267ecbdcbb3aad961fab6f6 SHA512 4bfd812fa1e949574b4170833755a435f47e893f0615b65d8d273af6e8f89ea4d28632a208de20321e834c8bc237b11816e2af0363b60adca9af736b9bc87465
DIST hipFFT-rocm-6.1.1.tar.gz 170796 BLAKE2B 8c957db8e7e2548918539c94262d912c2f33b70d8482b727c78c13323bdb6822c3e95439854b8ab4fed970d21ed0c6fd2ab8c2805db59d3a3606d73e7eb47468 SHA512 531be32b12ed5f0f2352e3e0a893ca988a4c8492e66fc9347b6754ae4e769549d6f638a760de35cb15ef2d301ab4200a76c832d769ecb0cd55e9e42f839a1876
DIST hipFFT-rocm-6.3.0.tar.gz 267945 BLAKE2B 33d9013ddb20b37b17a05dc647e74eaccede7e952723a177cb0f1e54f2b25cd6a76b1a8b00f419cf197e495dd654b04f418d28ca1023ea4bc88f0ccf8191d6c0 SHA512 a210e044a87845a861c127529143ea8517f5eef30a07007f43bd29a85b5c2999bd6002d12cd2a06c1c8b469ea3d52c081bbcc5146c5fc585df8505ddfa6a3e06
40 changes: 40 additions & 0 deletions sci-libs/hipFFT/hipFFT-6.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

ROCM_VERSION=${PV}

inherit cmake rocm

DESCRIPTION="CU / ROCM agnostic hip FFT implementation"
HOMEPAGE="https://github.com/ROCm/hipFFT"
SRC_URI="https://github.com/ROCm/hipFFT/archive/refs/tags/rocm-${PV}.tar.gz -> hipFFT-rocm-${PV}.tar.gz"
S="${WORKDIR}/hipFFT-rocm-${PV}"

REQUIRED_USE="${ROCM_REQUIRED_USE}"

LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~amd64"

RESTRICT="test"

RDEPEND="dev-util/hip
sci-libs/rocFFT:${SLOT}[${ROCM_USEDEP}]"
DEPEND="${RDEPEND}"

src_configure() {
# Note: hipcc is enforced; clang fails when libc++ is enabled
# with an error similar to https://github.com/boostorg/config/issues/392
rocm_use_hipcc

local mycmakeargs=(
-DROCM_SYMLINK_LIBS=OFF
-DBUILD_CLIENTS_TESTS=OFF
-DBUILD_CLIENTS_RIDER=OFF
-DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
)

cmake_src_configure
}

0 comments on commit 8a910c2

Please sign in to comment.