Skip to content

Commit

Permalink
dev-libs/rccl: fix tests compilation/execution with dev-cpp/gtest-1.15.2
Browse files Browse the repository at this point in the history
Applied the same patch as in 6.3.0.
Masked secondary device, as multiple devices with different capabilities break tests per https://rocm.docs.amd.com/projects/radeon/en/latest/docs/prerequisites.html#disable-igpu
No change in built object -> no revbump.

Closes: https://bugs.gentoo.org/947600
Signed-off-by: Sv. Lockal <[email protected]>
Closes: gentoo#40026
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
AngryLoki authored and thesamesam committed Jan 10, 2025
1 parent f144b20 commit b761d82
Show file tree
Hide file tree
Showing 3 changed files with 8 additions and 5 deletions.
6 changes: 4 additions & 2 deletions dev-libs/rccl/rccl-6.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2024 Gentoo Authors
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand Down Expand Up @@ -32,6 +32,7 @@ RESTRICT="!test? ( test )"

PATCHES=(
"${FILESDIR}/${PN}-6.0.2-fix-version-check.patch"
"${FILESDIR}/${PN}-6.1.1-headers-fix.patch"
)

src_prepare() {
Expand Down Expand Up @@ -67,5 +68,6 @@ src_configure() {
src_test() {
check_amdgpu
cd "${BUILD_DIR}" || die
LD_LIBRARY_PATH="${BUILD_DIR}" edob test/rccl-UnitTests
# APU (as second device, if any) expectedly breaks tests
HIP_VISIBLE_DEVICES=0 LD_LIBRARY_PATH="${BUILD_DIR}" edob test/rccl-UnitTests
}
7 changes: 4 additions & 3 deletions dev-libs/rccl/rccl-6.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2024 Gentoo Authors
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand Down Expand Up @@ -33,7 +33,7 @@ RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}/${PN}-6.0.2-fix-version-check.patch"
"${FILESDIR}/${PN}-6.3.0-same-rank-sendrecv.patch"
"${FILESDIR}/${PN}-6.3.0-headers-fix.patch"
"${FILESDIR}/${PN}-6.1.1-headers-fix.patch"
)

src_prepare() {
Expand Down Expand Up @@ -71,5 +71,6 @@ src_configure() {
src_test() {
check_amdgpu
cd "${BUILD_DIR}" || die
LD_LIBRARY_PATH="${BUILD_DIR}" edob test/rccl-UnitTests
# APU (as second device, if any) expectedly breaks tests
HIP_VISIBLE_DEVICES=0 LD_LIBRARY_PATH="${BUILD_DIR}" edob test/rccl-UnitTests
}

0 comments on commit b761d82

Please sign in to comment.