Skip to content

Commit

Permalink
dev-build/bmake: add 20241124
Browse files Browse the repository at this point in the history
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Nov 30, 2024
1 parent e8e5dea commit ce39e93
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-build/bmake/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST bmake-20240808.tar.gz 874139 BLAKE2B 626aecfc152ca3a1c0193f8f64722f20eb653faab031751284a305233e8f808a5c7ecdc78dcdac78f0043613c5eb45fa73611a3ff786b96dbac0183192192850 SHA512 c80a5eb028da68ecd002720301f66ae9708a75a564aaf468d98c4f76416defb8e52bad2024ef3661cafb0741d5afd0146a70d01fe58735f3d5a416acff4c44c7
DIST bmake-20240921.tar.gz 874802 BLAKE2B f6f636bdca8b86bfcd423f54db3d287fb944979c74b587cdf753aa9c8e2dab7c938342aa764f9c811b65d6ea54a241ffd74f99fe2f846c2c468370f4ff6942c0 SHA512 637b7044cfde1d067368e95ba57ff05367696b877893e3c28a3050671bcc11f91830f337af7a6ebf2b4022e4a5d68183a9be8375115490b5be8696162fe4bf42
DIST bmake-20241124.tar.gz 878189 BLAKE2B 13b05ae5bd0e23e949fe09282d57eb13926007dabd0550e1e06ab74b6b1464a528ede1b944ae240185637c1ccb45526ecf5ff14392eaddc8bcdaaf43a47c2d61 SHA512 6a13bdbfe1a50ee654502967aad728d047efd4cf97b811bca266210e701c2c4f99eaf57302fea42b9b7b78697ae2dd88f430d4e7c3edae0a6fabfc26a039f385
DIST mk-20210330.tar.gz 107380 BLAKE2B 9ac30a117d9ba31635cf8d8d29fdba76f148611f47628403ca8f807081c32509f10498d3c30fd24985e5420af4710fe59fc6315d71f2d0c1cfed93263a06553a SHA512 6acd3ee911442934082f4f877d795b07c5e23022eaa9c0874799d97e92a2f5a663cb45f94b7f9745c49cbbce6b7e755a29e381ccfb9e68a0be1eedbd22fd5d3b
57 changes: 57 additions & 0 deletions dev-build/bmake/bmake-20241124.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

MK_VER=20210330

DESCRIPTION="NetBSD's portable make"
HOMEPAGE="http://www.crufty.net/help/sjg/bmake.html"
SRC_URI="
http://void.crufty.net/ftp/pub/sjg/${P}.tar.gz
http://void.crufty.net/ftp/pub/sjg/mk-${MK_VER}.tar.gz"
S="${WORKDIR}/${PN}"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"

# Skip failing test (sandbox and csh)
PATCHES=(
"${FILESDIR}"/${PN}-20210206-tests.patch
)

src_prepare() {
default
cd "${WORKDIR}" || die
eapply "${FILESDIR}"/${PN}-20210314-mk-fixes.patch
}

src_configure() {
econf \
--with-mksrc=../mk \
--with-default-sys-path="${EPREFIX}"/usr/share/mk/${PN} \
--with-machine_arch=${ARCH}
}

src_compile() {
sh make-bootstrap.sh || die "bootstrap failed"
}

src_test() {
cd unit-tests || die

# the 'ternary' test uses ${A} internally, which
# conflicts with Gentoo's ${A}, hence unset it for
# the tests temporarily.
env -u A MAKEFLAGS= \
"${S}"/bmake -r -m / TEST_MAKE="${S}"/bmake test || die "tests compilation failed"
}

src_install() {
dobin ${PN}
doman ${PN}.1
FORCE_BSD_MK=1 SYS_MK_DIR=. \
sh ../mk/install-mk -v -m 644 "${ED}"/usr/share/mk/${PN} \
|| die "failed to install mk files"
}

0 comments on commit ce39e93

Please sign in to comment.