Skip to content

Commit

Permalink
dev-ml/dune: add 3.9.1
Browse files Browse the repository at this point in the history
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Jul 11, 2023
1 parent 390b615 commit d10337c
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/dune/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -11,3 +11,4 @@ DIST dune-3.7.0.tar.gz 2010139 BLAKE2B 045fc6ee033325b074aac869c32b55f243bc561b7
DIST dune-3.7.1.tar.gz 2011275 BLAKE2B dd0f473a720fc65ac550a2aab64930ff472a9bd306d603f088d813817df56148f676abe2a56ff3458bb1ed887784e565154eee08988bf984585b35bc9333d929 SHA512 d741b2a92e970f9747240d4356045f46447238f7c8d8c47ba0b1cad96b8194461a47fa315d86a1eef2033a4d38001c999e6033c31b0c75a311367fb78ea12b6b
DIST dune-3.8.0.tar.gz 2564537 BLAKE2B 773a2643b187f37dd2e21df41f18818753e249e66c2d98a4cfee3d9997f528827b2cf3c60d2992ffdc51397c393ac1a0fcc5339bdec2d87f82252114394d2355 SHA512 bba32fb508265329a2a46c9bd2e8b7e5f3d6d84390e842382ff4790f0d3414c9ff1d005c1af88988daaca29749729f1ced7b388f2d96432f01f2f4ea4714be98
DIST dune-3.9.0.tar.gz 2609923 BLAKE2B f9fe8fb3c2e002e1eec141f487709d592df969ab44d41012ebaa436f17b6ee679e2e763d479106ae722b8b61be03fceb701b314c40c001d5895db99e5fbbe4a6 SHA512 86cd66222553f8cd7c1d1fb9e4e55169f9cd6d92e0bde1c56846b5e0fb6ae8494ac15ebb68d9e8761240f46dcc9b480747e48b21b74cff86e52cc45d3d222070
DIST dune-3.9.1.tar.gz 2610113 BLAKE2B 0b97f6a951bd013a156a1417f6b65df17324adf13d48ad3b8bf45a4133cc77195e2118ae95f0cb9da488c26378b58ce677db8eb4b3cb028a73c779be57b2d611 SHA512 c997ec2205fa5391acbca9e196387cec1af69d3aed4cebe21d82edbe66bd91fda0c742e7ff2e3ffb8df88e2e379bbff68028574664cf375d04f4d3f3f2102f3b
68 changes: 68 additions & 0 deletions dev-ml/dune/dune-3.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit multiprocessing elisp-common

DESCRIPTION="A composable build system for OCaml"
HOMEPAGE="https://github.com/ocaml/dune"
SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
IUSE="emacs"
RESTRICT="strip test"

RDEPEND="
>=dev-lang/ocaml-4.08:=
emacs? ( >=app-editors/emacs-23.1:* )
"
DEPEND="${RDEPEND}"

QA_FLAGS_IGNORED="usr/bin/dune"

BYTECOMPFLAGS="-L ${S}/editor-integration/emacs"
SITEFILE="50${PN}-gentoo.el"

src_prepare() {
default

# This allows `dune --version` to output the correct version
# instead of "n/a"
sed -i "/^(name dune)/a (version ${PV})" dune-project || die
}

src_configure() {
./configure \
--libdir="$(ocamlc -where)" \
--mandir=/usr/share/man \
--docdir=/usr/doc \
--etcdir=/etc \
--datadir=/usr/share \
--sbindir=/usr/sbin \
--bindir=/usr/bin \
|| die
}

src_compile() {
ocaml boot/bootstrap.ml -j $(makeopts_jobs) --verbose || die
./_boot/dune.exe build @install -p "${PN}" --profile dune-bootstrap \
-j $(makeopts_jobs) --display short || die

use emacs && elisp-compile editor-integration/emacs/*.el
}

src_install() {
default

dodir /usr/share/doc
mv "${ED}"/usr/doc/dune "${ED}"/usr/share/doc/${PF} || die
rmdir "${ED}"/usr/doc || die

if use emacs ; then
elisp-install ${PN} editor-integration/emacs/*.el{,c}
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
}

0 comments on commit d10337c

Please sign in to comment.