Skip to content

Commit

Permalink
media-libs/urt: add 3.2_rc1_p20250101
Browse files Browse the repository at this point in the history
Switch to new upstream.

Closes: https://bugs.gentoo.org/881213
Closes: https://bugs.gentoo.org/920362
Closes: https://bugs.gentoo.org/944453
Signed-off-by: Viorel Munteanu <[email protected]>
  • Loading branch information
ceamac committed Jan 1, 2025
1 parent e9f1e2c commit e6c8169
Show file tree
Hide file tree
Showing 4 changed files with 101 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/urt/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST urt-3.1b.tar.Z 1016405 BLAKE2B 68742773591e2ae28702efb4286939c4000d32edd93110548abc25ab62bfa85e36354f20de6aa74c805ea1c4c8dfa23219c9e6fb08e1c73d90d2625404583aa1 SHA512 6c9070cd106f1d696d22f862cc1c4e10325fafc7bae51e8bb1fb98f6bf8babe21a133e21b3acc0c11cf1b28a23123c8ee7bb064c9d86301b14a1c217fbe1a12d
DIST urt-3.2_rc1_p20250101.tar.gz 1079866 BLAKE2B 519760a11b10d1cad1d2f9ba6b0de3918000ad9a6fa0a3edbf0382d8bdf99248aa12e89aec09bbe134db0138f8eb1326bad06a9c6ad581766b5f45bee3152989 SHA512 347fabddc2ff14f9313d2ed2ad7902b0fdc2108e1cb0d472f4040c2ab42c171360be390833359d813ad03bf4ea94537fe481a1bd5facfd9b72b2178622771e66
11 changes: 11 additions & 0 deletions media-libs/urt/files/urt-3.2_rc1_p20250101-respect-ldflags.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/get/getx11/makefile.src
+++ b/get/getx11/makefile.src
@@ -50,7 +50,7 @@

# getx11 - read RLE file to X11 display
getx11.out: $(X_O_FILES)
- ${CC} $(CFLAGS) $(X_O_FILES) -o getx11.new $(LIBS)
+ ${CC} $(CFLAGS) $(X_O_FILES) -o getx11.new $(LDFLAGS) $(LIBS)
mv getx11.new getx11.out

# Make prototypes.h and fn_decls.h. Only happens if HAVE_CPROTO is defined.
3 changes: 3 additions & 0 deletions media-libs/urt/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -5,4 +5,7 @@
<use>
<flag name="tools">Install tools</flag>
</use>
<upstream>
<remote-id type="github">sarnold/urt</remote-id>
</upstream>
</pkgmetadata>
86 changes: 86 additions & 0 deletions media-libs/urt/urt-3.2_rc1_p20250101.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,86 @@
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit edo flag-o-matic toolchain-funcs

COMMIT_ID=e5a6997b9d494f3010b2c32b1e3f0660ec7991ac
DESCRIPTION="the Utah Raster Toolkit is a library for dealing with raster images"
HOMEPAGE="https://sarnold.github.io/urt/ https://github.com/sarnold/urt"
SRC_URI="https://github.com/sarnold/urt/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT_ID}"

LICENSE="GPL-2 gif? ( free-noncomm )"
SLOT="0/3.1.0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
IUSE="gif postscript static-libs tiff tools X"

RDEPEND="
gif? ( media-libs/giflib )
postscript? ( app-text/ghostscript-gpl )
tiff? ( media-libs/tiff:= )
X? ( x11-libs/libXext )
"

DEPEND="
${RDEPEND}
X? ( x11-base/xorg-proto )
"

PATCHES=(
"${FILESDIR}"/${P}-respect-ldflags.patch
)

urt_config() {
use $1 && echo "#define $2" || echo "##define $2"
}

src_prepare() {
rm bin/README || die

default
}

src_configure() {
append-cflags -fPIC

sed -i -e '/^CFLAGS/s: -O2 : :' makefile.hdr || die

cat >> config/gentoo <<-EOF
$(urt_config X X11)
$(urt_config gif GIF)
$(urt_config postscript POSTSCRIPT)
$(urt_config tiff TIFF)
ExtraCFLAGS = ${CFLAGS}
MFLAGS = ${MAKEOPTS}
EOF

edob -m "Configuring" ./Configure config/gentoo
}

src_compile() {
tc-export AR RANLIB

emake CC="$(tc-getCC)"
}

src_install() {
mkdir -p man-dest/man{1,3,5}
# this just installs it into some local dirs
emake install

use tools && dobin bin/*

use static-libs && dolib.a lib/librle.a

dolib.so lib/librle.so
dolib.so lib/librle.so.3
dolib.so lib/librle.so.3.1.0
dosym librle.so /usr/$(get_libdir)/librle-0.0.0.so

insinto /usr/include
doins include/rle*.h
doman man-dest/man?/*.[135]
dodoc *-changes CHANGES* README* blurb
}

0 comments on commit e6c8169

Please sign in to comment.