forked from LiBwrt/openwrt-6.x
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
CI is supposed to catch all of these. Some of these predate CI. Signed-off-by: Rosen Penev <[email protected]>
- Loading branch information
Showing
30 changed files
with
109 additions
and
202 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -22,7 +22,7 @@ Signed-off-by: Masahiro Yamada <[email protected]> | |
|
||
--- a/scripts/check-config.sh | ||
+++ b/scripts/check-config.sh | ||
@@ -50,14 +50,13 @@ cat `find ${srctree} -name "Kconfig*"` |sed -n \ | ||
@@ -50,14 +50,13 @@ cat `find ${srctree} -name "Kconfig*"` | | ||
|sort |uniq > ${ok} | ||
comm -23 ${suspects} ${ok} >${new_adhoc} | ||
if [ -s ${new_adhoc} ]; then | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,6 @@ | ||
diff -ruN u-boot-2020.04.old/arch/arm/mach-kirkwood/Kconfig u-boot-2020.04/arch/arm/mach-kirkwood/Kconfig | ||
--- u-boot-2020.04.old/arch/arm/mach-kirkwood/Kconfig 2020-07-09 00:46:15.000000000 +0200 | ||
+++ u-boot-2020.04/arch/arm/mach-kirkwood/Kconfig 2020-07-09 01:07:00.309219477 +0200 | ||
@@ -44,6 +44,9 @@ | ||
--- a/arch/arm/mach-kirkwood/Kconfig | ||
+++ b/arch/arm/mach-kirkwood/Kconfig | ||
@@ -44,6 +44,9 @@ config TARGET_NET2BIG_V2 | ||
config TARGET_NETSPACE_V2 | ||
bool "LaCie netspace_v2 Board" | ||
|
||
|
@@ -11,17 +10,16 @@ diff -ruN u-boot-2020.04.old/arch/arm/mach-kirkwood/Kconfig u-boot-2020.04/arch/ | |
config TARGET_IB62X0 | ||
bool "ib62x0 Board" | ||
|
||
@@ -92,6 +95,7 @@ | ||
@@ -95,6 +98,7 @@ source "board/iomega/iconnect/Kconfig" | ||
source "board/keymile/Kconfig" | ||
source "board/LaCie/net2big_v2/Kconfig" | ||
source "board/LaCie/netspace_v2/Kconfig" | ||
+source "board/Marvell/netgear_ms2110/Kconfig" | ||
source "board/raidsonic/ib62x0/Kconfig" | ||
source "board/Seagate/dockstar/Kconfig" | ||
source "board/Seagate/goflexhome/Kconfig" | ||
diff -ruN u-boot-2020.04.old/board/Marvell/netgear_ms2110/Kconfig u-boot-2020.04/board/Marvell/netgear_ms2110/Kconfig | ||
--- u-boot-2020.04.old/board/Marvell/netgear_ms2110/Kconfig 1970-01-01 01:00:00.000000000 +0100 | ||
+++ u-boot-2020.04/board/Marvell/netgear_ms2110/Kconfig 2020-07-09 00:59:29.000000000 +0200 | ||
--- /dev/null | ||
+++ b/board/Marvell/netgear_ms2110/Kconfig | ||
@@ -0,0 +1,12 @@ | ||
+if TARGET_NETGEAR_MS2110 | ||
+ | ||
|
@@ -35,9 +33,8 @@ diff -ruN u-boot-2020.04.old/board/Marvell/netgear_ms2110/Kconfig u-boot-2020.04 | |
+ default "netgear_ms2110" | ||
+ | ||
+endif | ||
diff -ruN u-boot-2020.04.old/board/Marvell/netgear_ms2110/kwbimage.cfg u-boot-2020.04/board/Marvell/netgear_ms2110/kwbimage.cfg | ||
--- u-boot-2020.04.old/board/Marvell/netgear_ms2110/kwbimage.cfg 1970-01-01 01:00:00.000000000 +0100 | ||
+++ u-boot-2020.04/board/Marvell/netgear_ms2110/kwbimage.cfg 2020-07-09 00:59:29.000000000 +0200 | ||
--- /dev/null | ||
+++ b/board/Marvell/netgear_ms2110/kwbimage.cfg | ||
@@ -0,0 +1,167 @@ | ||
+# | ||
+# (C) Copyright 2009 | ||
|
@@ -206,19 +203,17 @@ diff -ruN u-boot-2020.04.old/board/Marvell/netgear_ms2110/kwbimage.cfg u-boot-20 | |
+ | ||
+# End of Header extension | ||
+DATA 0x0 0x0 | ||
diff -ruN u-boot-2020.04.old/board/Marvell/netgear_ms2110/MAINTAINERS u-boot-2020.04/board/Marvell/netgear_ms2110/MAINTAINERS | ||
--- u-boot-2020.04.old/board/Marvell/netgear_ms2110/MAINTAINERS 1970-01-01 01:00:00.000000000 +0100 | ||
+++ u-boot-2020.04/board/Marvell/netgear_ms2110/MAINTAINERS 2020-07-09 00:59:29.000000000 +0200 | ||
--- /dev/null | ||
+++ b/board/Marvell/netgear_ms2110/MAINTAINERS | ||
@@ -0,0 +1,6 @@ | ||
+NETGEAR_MS2110 BOARD | ||
+M: bodhi <[email protected]> | ||
+S: Maintained | ||
+F: board/Marvell/netgear_ms2110 | ||
+F: include/configs/netgear_ms2110.h | ||
+F: configs/netgear_ms2110_defconfig | ||
diff -ruN u-boot-2020.04.old/board/Marvell/netgear_ms2110/Makefile u-boot-2020.04/board/Marvell/netgear_ms2110/Makefile | ||
--- u-boot-2020.04.old/board/Marvell/netgear_ms2110/Makefile 1970-01-01 01:00:00.000000000 +0100 | ||
+++ u-boot-2020.04/board/Marvell/netgear_ms2110/Makefile 2020-07-09 00:59:29.000000000 +0200 | ||
--- /dev/null | ||
+++ b/board/Marvell/netgear_ms2110/Makefile | ||
@@ -0,0 +1,13 @@ | ||
+# | ||
+# (C) Copyright 2014 bodhi <[email protected]> | ||
|
@@ -233,9 +228,8 @@ diff -ruN u-boot-2020.04.old/board/Marvell/netgear_ms2110/Makefile u-boot-2020.0 | |
+ | ||
+obj-y := netgear_ms2110.o | ||
+ | ||
diff -ruN u-boot-2020.04.old/board/Marvell/netgear_ms2110/netgear_ms2110.c u-boot-2020.04/board/Marvell/netgear_ms2110/netgear_ms2110.c | ||
--- u-boot-2020.04.old/board/Marvell/netgear_ms2110/netgear_ms2110.c 1970-01-01 01:00:00.000000000 +0100 | ||
+++ u-boot-2020.04/board/Marvell/netgear_ms2110/netgear_ms2110.c 2020-07-09 00:59:29.000000000 +0200 | ||
--- /dev/null | ||
+++ b/board/Marvell/netgear_ms2110/netgear_ms2110.c | ||
@@ -0,0 +1,151 @@ | ||
+/* | ||
+ * Copyright (C) 2014-2017 bodhi <[email protected]> | ||
|
@@ -388,9 +382,8 @@ diff -ruN u-boot-2020.04.old/board/Marvell/netgear_ms2110/netgear_ms2110.c u-boo | |
+} | ||
+#endif /* CONFIG_RESET_PHY_R */ | ||
+ | ||
diff -ruN u-boot-2020.04.old/board/Marvell/netgear_ms2110/netgear_ms2110.h u-boot-2020.04/board/Marvell/netgear_ms2110/netgear_ms2110.h | ||
--- u-boot-2020.04.old/board/Marvell/netgear_ms2110/netgear_ms2110.h 1970-01-01 01:00:00.000000000 +0100 | ||
+++ u-boot-2020.04/board/Marvell/netgear_ms2110/netgear_ms2110.h 2020-07-09 00:59:29.000000000 +0200 | ||
--- /dev/null | ||
+++ b/board/Marvell/netgear_ms2110/netgear_ms2110.h | ||
@@ -0,0 +1,41 @@ | ||
+/* | ||
+ * (C) Copyright 2009 | ||
|
@@ -433,9 +426,8 @@ diff -ruN u-boot-2020.04.old/board/Marvell/netgear_ms2110/netgear_ms2110.h u-boo | |
+#define MV88E1116_RGMII_RXTM_CTRL (1 << 5) | ||
+ | ||
+#endif /* __NETGEAR_MS2110_H */ | ||
diff -ruN a/configs/netgear_ms2110_defconfig b/configs/netgear_ms2110_defconfig | ||
--- a/configs/netgear_ms2110_defconfig 1970-01-01 01:00:00.000000000 +0100 | ||
+++ b/configs/netgear_ms2110_defconfig 2020-07-14 17:59:18.000000000 +0200 | ||
--- /dev/null | ||
+++ b/configs/netgear_ms2110_defconfig | ||
@@ -0,0 +1,50 @@ | ||
+CONFIG_ARM=y | ||
+CONFIG_KIRKWOOD=y | ||
|
@@ -487,9 +479,8 @@ diff -ruN a/configs/netgear_ms2110_defconfig b/configs/netgear_ms2110_defconfig | |
+CONFIG_MVSATA_IDE=y | ||
+CONFIG_DM_RTC=y | ||
+CONFIG_RTC_MV=y | ||
diff -ruN a/include/configs/netgear_ms2110.h b/include/configs/netgear_ms2110.h | ||
--- a/include/configs/netgear_ms2110.h 1970-01-01 01:00:00.000000000 +0100 | ||
+++ b/include/configs/netgear_ms2110.h 2020-07-14 17:49:15.000000000 +0200 | ||
--- /dev/null | ||
+++ b/include/configs/netgear_ms2110.h | ||
@@ -0,0 +1,155 @@ | ||
+/* | ||
+ * (C) Copyright 2014-2017 bodhi <[email protected]> | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -19,7 +19,7 @@ Signed-off-by: Daniel Schwierzeck <[email protected]> | |
endif | ||
--- a/arch/mips/include/asm/arch-vrx200/config.h | ||
+++ b/arch/mips/include/asm/arch-vrx200/config.h | ||
@@ -167,7 +167,7 @@ | ||
@@ -168,7 +168,7 @@ | ||
#define CONFIG_SYS_TEXT_BASE 0xB0000000 | ||
#endif | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -22,8 +22,6 @@ Signed-off-by: Tom Rini <[email protected]> | |
delete mode 100644 include/linux/compiler-gcc4.h | ||
create mode 100644 include/linux/compiler-intel.h | ||
|
||
diff --git a/include/linux/compiler-gcc.h b/include/linux/compiler-gcc.h | ||
index 9896e54..22ab246 100644 | ||
--- a/include/linux/compiler-gcc.h | ||
+++ b/include/linux/compiler-gcc.h | ||
@@ -5,11 +5,28 @@ | ||
|
@@ -147,20 +145,6 @@ index 9896e54..22ab246 100644 | |
*/ | ||
-#ifndef __pure | ||
-# define __pure __attribute__((pure)) | ||
-#endif | ||
-#ifndef __aligned | ||
-# define __aligned(x) __attribute__((aligned(x))) | ||
-#endif | ||
-#define __printf(a,b) __attribute__((format(printf,a,b))) | ||
-#define noinline __attribute__((noinline)) | ||
-#define __attribute_const__ __attribute__((__const__)) | ||
-#define __maybe_unused __attribute__((unused)) | ||
-#define __always_unused __attribute__((unused)) | ||
- | ||
-#define __gcc_header(x) #x | ||
-#define _gcc_header(x) __gcc_header(linux/compiler-gcc##x.h) | ||
-#define gcc_header(x) _gcc_header(x) | ||
-#include gcc_header(__GNUC__) | ||
+#define __pure __attribute__((pure)) | ||
+#define __aligned(x) __attribute__((aligned(x))) | ||
+#define __printf(a, b) __attribute__((format(printf, a, b))) | ||
|
@@ -189,7 +173,9 @@ index 9896e54..22ab246 100644 | |
+ | ||
+#if GCC_VERSION >= 30400 | ||
+#define __must_check __attribute__((warn_unused_result)) | ||
+#endif | ||
#endif | ||
-#ifndef __aligned | ||
-# define __aligned(x) __attribute__((aligned(x))) | ||
+ | ||
+#if GCC_VERSION >= 40000 | ||
+ | ||
|
@@ -206,7 +192,17 @@ index 9896e54..22ab246 100644 | |
+ | ||
+#if GCC_VERSION >= 40100 && GCC_VERSION < 40600 | ||
+# define __compiletime_object_size(obj) __builtin_object_size(obj, 0) | ||
+#endif | ||
#endif | ||
-#define __printf(a,b) __attribute__((format(printf,a,b))) | ||
-#define noinline __attribute__((noinline)) | ||
-#define __attribute_const__ __attribute__((__const__)) | ||
-#define __maybe_unused __attribute__((unused)) | ||
-#define __always_unused __attribute__((unused)) | ||
- | ||
-#define __gcc_header(x) #x | ||
-#define _gcc_header(x) __gcc_header(linux/compiler-gcc##x.h) | ||
-#define gcc_header(x) _gcc_header(x) | ||
-#include gcc_header(__GNUC__) | ||
+ | ||
+#if GCC_VERSION >= 40300 | ||
+/* Mark functions as cold. gcc will assume any path leading to a call | ||
|
@@ -328,9 +324,6 @@ index 9896e54..22ab246 100644 | |
+ * code | ||
+ */ | ||
+#define uninitialized_var(x) x = x | ||
diff --git a/include/linux/compiler-gcc3.h b/include/linux/compiler-gcc3.h | ||
deleted file mode 100644 | ||
index 2befe65..0000000 | ||
--- a/include/linux/compiler-gcc3.h | ||
+++ /dev/null | ||
@@ -1,21 +0,0 @@ | ||
|
@@ -355,9 +348,6 @@ index 2befe65..0000000 | |
-#define uninitialized_var(x) x = x | ||
- | ||
-#define __always_inline inline __attribute__((always_inline)) | ||
diff --git a/include/linux/compiler-gcc4.h b/include/linux/compiler-gcc4.h | ||
deleted file mode 100644 | ||
index 27d11ca..0000000 | ||
--- a/include/linux/compiler-gcc4.h | ||
+++ /dev/null | ||
@@ -1,63 +0,0 @@ | ||
|
@@ -424,9 +414,6 @@ index 27d11ca..0000000 | |
-#define __compiletime_warning(message) __attribute__((warning(message))) | ||
-#define __compiletime_error(message) __attribute__((error(message))) | ||
-#endif | ||
diff --git a/include/linux/compiler-intel.h b/include/linux/compiler-intel.h | ||
new file mode 100644 | ||
index 0000000..d4c7113 | ||
--- /dev/null | ||
+++ b/include/linux/compiler-intel.h | ||
@@ -0,0 +1,45 @@ | ||
|
@@ -475,8 +462,6 @@ index 0000000..d4c7113 | |
+#define __builtin_bswap16 _bswap16 | ||
+#endif | ||
+ | ||
diff --git a/include/linux/compiler.h b/include/linux/compiler.h | ||
index 5be3dab..020ad16 100644 | ||
--- a/include/linux/compiler.h | ||
+++ b/include/linux/compiler.h | ||
@@ -5,16 +5,24 @@ | ||
|
@@ -505,7 +490,7 @@ index 5be3dab..020ad16 100644 | |
extern void __chk_user_ptr(const volatile void __user *); | ||
extern void __chk_io_ptr(const volatile void __iomem *); | ||
#else | ||
@@ -27,20 +35,32 @@ extern void __chk_io_ptr(const volatile void __iomem *); | ||
@@ -27,20 +35,32 @@ extern void __chk_io_ptr(const volatile | ||
# define __chk_user_ptr(x) (void)0 | ||
# define __chk_io_ptr(x) (void)0 | ||
# define __builtin_warning(x, y...) (1) | ||
|
@@ -538,7 +523,7 @@ index 5be3dab..020ad16 100644 | |
|
||
/* Intel compiler defines __GNUC__. So we will overwrite implementations | ||
* coming from above header files here | ||
@@ -49,6 +69,13 @@ extern void __chk_io_ptr(const volatile void __iomem *); | ||
@@ -49,6 +69,13 @@ extern void __chk_io_ptr(const volatile | ||
# include <linux/compiler-intel.h> | ||
#endif | ||
|
||
|
@@ -552,7 +537,7 @@ index 5be3dab..020ad16 100644 | |
/* | ||
* Generic compiler-dependent macros required for kernel | ||
* build go below this comment. Actual compiler/compiler version | ||
@@ -117,7 +144,7 @@ void ftrace_likely_update(struct ftrace_branch_data *f, int val, int expect); | ||
@@ -117,7 +144,7 @@ void ftrace_likely_update(struct ftrace_ | ||
*/ | ||
#define if(cond, ...) __trace_if( (cond , ## __VA_ARGS__) ) | ||
#define __trace_if(cond) \ | ||
|
@@ -561,7 +546,7 @@ index 5be3dab..020ad16 100644 | |
({ \ | ||
int ______r; \ | ||
static struct ftrace_branch_data \ | ||
@@ -144,6 +171,10 @@ void ftrace_likely_update(struct ftrace_branch_data *f, int val, int expect); | ||
@@ -144,6 +171,10 @@ void ftrace_likely_update(struct ftrace_ | ||
# define barrier() __memory_barrier() | ||
#endif | ||
|
||
|
@@ -572,7 +557,7 @@ index 5be3dab..020ad16 100644 | |
/* Unreachable code */ | ||
#ifndef unreachable | ||
# define unreachable() do { } while (1) | ||
@@ -156,6 +187,135 @@ void ftrace_likely_update(struct ftrace_branch_data *f, int val, int expect); | ||
@@ -156,6 +187,135 @@ void ftrace_likely_update(struct ftrace_ | ||
(typeof(ptr)) (__ptr + (off)); }) | ||
#endif | ||
|
||
|
@@ -708,7 +693,7 @@ index 5be3dab..020ad16 100644 | |
#endif /* __KERNEL__ */ | ||
|
||
#endif /* __ASSEMBLY__ */ | ||
@@ -228,7 +388,7 @@ void ftrace_likely_update(struct ftrace_branch_data *f, int val, int expect); | ||
@@ -228,7 +388,7 @@ void ftrace_likely_update(struct ftrace_ | ||
|
||
/* | ||
* Rather then using noinline to prevent stack consumption, use | ||
|
@@ -717,7 +702,7 @@ index 5be3dab..020ad16 100644 | |
*/ | ||
#define noinline_for_stack noinline | ||
|
||
@@ -270,11 +430,28 @@ void ftrace_likely_update(struct ftrace_branch_data *f, int val, int expect); | ||
@@ -270,11 +430,28 @@ void ftrace_likely_update(struct ftrace_ | ||
# define __section(S) __attribute__ ((__section__(#S))) | ||
#endif | ||
|
||
|
@@ -746,7 +731,7 @@ index 5be3dab..020ad16 100644 | |
/* Compile time object size, -1 for unknown */ | ||
#ifndef __compiletime_object_size | ||
# define __compiletime_object_size(obj) -1 | ||
@@ -284,7 +461,48 @@ void ftrace_likely_update(struct ftrace_branch_data *f, int val, int expect); | ||
@@ -284,8 +461,49 @@ void ftrace_likely_update(struct ftrace_ | ||
#endif | ||
#ifndef __compiletime_error | ||
# define __compiletime_error(message) | ||
|
@@ -760,11 +745,11 @@ index 5be3dab..020ad16 100644 | |
+# define __compiletime_error_fallback(condition) \ | ||
+ do { ((void)sizeof(char[1 - 2 * condition])); } while (0) | ||
+# endif | ||
#endif | ||
+#endif | ||
+#ifndef __compiletime_error_fallback | ||
+# define __compiletime_error_fallback(condition) do { } while (0) | ||
+#endif | ||
+ | ||
#endif | ||
+#define __compiletime_assert(condition, msg, prefix, suffix) \ | ||
+ do { \ | ||
+ bool __cond = !(condition); \ | ||
|
@@ -792,10 +777,11 @@ index 5be3dab..020ad16 100644 | |
+#define compiletime_assert_atomic_type(t) \ | ||
+ compiletime_assert(__native_word(t), \ | ||
+ "Need native word sized stores/loads for atomicity.") | ||
+ | ||
/* | ||
* Prevent the compiler from merging or refetching accesses. The compiler | ||
@@ -293,11 +511,45 @@ void ftrace_likely_update(struct ftrace_branch_data *f, int val, int expect); | ||
* is also forbidden from reordering successive instances of ACCESS_ONCE(), | ||
@@ -293,11 +511,45 @@ void ftrace_likely_update(struct ftrace_ | ||
* to make the compiler aware of ordering is to put the two invocations of | ||
* ACCESS_ONCE() in different C statements. | ||
* | ||
|
@@ -847,6 +833,3 @@ index 5be3dab..020ad16 100644 | |
+# define nokprobe_inline inline | ||
+#endif | ||
#endif /* __LINUX_COMPILER_H */ | ||
-- | ||
2.7.4 | ||
|
Oops, something went wrong.