forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Refreshed all patches. Compile-tested on: imx6 Runtime-tested on: imx6 Signed-off-by: Koen Vandeputte <[email protected]>
- Loading branch information
Koen Vandeputte
committed
Jun 24, 2019
1 parent
4589f23
commit 92b8fe0
Showing
6 changed files
with
9 additions
and
36 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -71,9 +71,6 @@ Signed-off-by: Kevin Darbyshire-Bryant <[email protected]> | |
create mode 100644 include/uapi/linux/tc_act/tc_ctinfo.h | ||
create mode 100644 net/sched/act_ctinfo.c | ||
|
||
diff --git a/include/net/tc_act/tc_ctinfo.h b/include/net/tc_act/tc_ctinfo.h | ||
new file mode 100644 | ||
index 000000000000..f071c1d70a25 | ||
--- /dev/null | ||
+++ b/include/net/tc_act/tc_ctinfo.h | ||
@@ -0,0 +1,33 @@ | ||
|
@@ -110,8 +107,6 @@ index 000000000000..f071c1d70a25 | |
+#define to_ctinfo(a) ((struct tcf_ctinfo *)a) | ||
+ | ||
+#endif /* __NET_TC_CTINFO_H */ | ||
diff --git a/include/uapi/linux/pkt_cls.h b/include/uapi/linux/pkt_cls.h | ||
index be382fb0592d..71e10c5a96a0 100644 | ||
--- a/include/uapi/linux/pkt_cls.h | ||
+++ b/include/uapi/linux/pkt_cls.h | ||
@@ -68,7 +68,8 @@ enum { | ||
|
@@ -124,9 +119,6 @@ index be382fb0592d..71e10c5a96a0 100644 | |
}; | ||
|
||
#define TCA_ID_MAX __TCA_ID_MAX | ||
diff --git a/include/uapi/linux/tc_act/tc_ctinfo.h b/include/uapi/linux/tc_act/tc_ctinfo.h | ||
new file mode 100644 | ||
index 000000000000..f5f26d95d0e7 | ||
--- /dev/null | ||
+++ b/include/uapi/linux/tc_act/tc_ctinfo.h | ||
@@ -0,0 +1,29 @@ | ||
|
@@ -159,8 +151,6 @@ index 000000000000..f5f26d95d0e7 | |
+#define TCA_CTINFO_MAX (__TCA_CTINFO_MAX - 1) | ||
+ | ||
+#endif | ||
diff --git a/net/sched/Kconfig b/net/sched/Kconfig | ||
index e95741388311..1d79d5dba6e4 100644 | ||
--- a/net/sched/Kconfig | ||
+++ b/net/sched/Kconfig | ||
@@ -866,6 +866,23 @@ config NET_ACT_CONNMARK | ||
|
@@ -187,8 +177,6 @@ index e95741388311..1d79d5dba6e4 100644 | |
config NET_ACT_SKBMOD | ||
tristate "skb data modification action" | ||
depends on NET_CLS_ACT | ||
diff --git a/net/sched/Makefile b/net/sched/Makefile | ||
index f0403f49edcb..bb3c2bc44af7 100644 | ||
--- a/net/sched/Makefile | ||
+++ b/net/sched/Makefile | ||
@@ -21,6 +21,7 @@ obj-$(CONFIG_NET_ACT_CSUM) += act_csum.o | ||
|
@@ -199,9 +187,6 @@ index f0403f49edcb..bb3c2bc44af7 100644 | |
obj-$(CONFIG_NET_ACT_SKBMOD) += act_skbmod.o | ||
obj-$(CONFIG_NET_ACT_IFE) += act_ife.o | ||
obj-$(CONFIG_NET_IFE_SKBMARK) += act_meta_mark.o | ||
diff --git a/net/sched/act_ctinfo.c b/net/sched/act_ctinfo.c | ||
new file mode 100644 | ||
index 000000000000..8975cb4976aa | ||
--- /dev/null | ||
+++ b/net/sched/act_ctinfo.c | ||
@@ -0,0 +1,395 @@ | ||
|
@@ -600,8 +585,6 @@ index 000000000000..8975cb4976aa | |
+MODULE_AUTHOR("Kevin Darbyshire-Bryant <[email protected]>"); | ||
+MODULE_DESCRIPTION("Connection tracking mark actions"); | ||
+MODULE_LICENSE("GPL"); | ||
diff --git a/tools/testing/selftests/tc-testing/config b/tools/testing/selftests/tc-testing/config | ||
index 203302065458..9d1fddcfb887 100644 | ||
--- a/tools/testing/selftests/tc-testing/config | ||
+++ b/tools/testing/selftests/tc-testing/config | ||
@@ -37,6 +37,7 @@ CONFIG_NET_ACT_SKBEDIT=m | ||
|
@@ -612,6 +595,3 @@ index 203302065458..9d1fddcfb887 100644 | |
CONFIG_NET_ACT_CONNMARK=m | ||
CONFIG_NET_ACT_SKBMOD=m | ||
CONFIG_NET_ACT_IFE=m | ||
-- | ||
2.20.1 (Apple Git-117) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -31,11 +31,9 @@ Signed-off-by: Kevin Darbyshire-Bryant <[email protected]> | |
arch/mips/boot/compressed/calc_vmlinuz_load_addr.c | 2 +- | ||
2 files changed, 3 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/arch/mips/boot/compressed/Makefile b/arch/mips/boot/compressed/Makefile | ||
index 3c453a1f1ff1..172801ed35b8 100644 | ||
--- a/arch/mips/boot/compressed/Makefile | ||
+++ b/arch/mips/boot/compressed/Makefile | ||
@@ -78,6 +78,8 @@ OBJCOPYFLAGS_piggy.o := --add-section=.image=$(obj)/vmlinux.bin.z \ | ||
@@ -78,6 +78,8 @@ OBJCOPYFLAGS_piggy.o := --add-section=.i | ||
$(obj)/piggy.o: $(obj)/dummy.o $(obj)/vmlinux.bin.z FORCE | ||
$(call if_changed,objcopy) | ||
|
||
|
@@ -44,11 +42,9 @@ index 3c453a1f1ff1..172801ed35b8 100644 | |
# Calculate the load address of the compressed kernel image | ||
hostprogs-y := calc_vmlinuz_load_addr | ||
|
||
diff --git a/arch/mips/boot/compressed/calc_vmlinuz_load_addr.c b/arch/mips/boot/compressed/calc_vmlinuz_load_addr.c | ||
index 240f1d12df75..080b926d2623 100644 | ||
--- a/arch/mips/boot/compressed/calc_vmlinuz_load_addr.c | ||
+++ b/arch/mips/boot/compressed/calc_vmlinuz_load_addr.c | ||
@@ -9,7 +9,7 @@ | ||
@@ -13,7 +13,7 @@ | ||
#include <stdint.h> | ||
#include <stdio.h> | ||
#include <stdlib.h> | ||
|
@@ -57,6 +53,3 @@ index 240f1d12df75..080b926d2623 100644 | |
|
||
int main(int argc, char *argv[]) | ||
{ | ||
-- | ||
2.20.1 (Apple Git-117) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -13,7 +13,7 @@ Signed-off-by: Russell King <[email protected]> | |
|
||
--- a/drivers/net/phy/phylink.c | ||
+++ b/drivers/net/phy/phylink.c | ||
@@ -333,6 +333,13 @@ static void phylink_mac_config(struct ph | ||
@@ -337,6 +337,13 @@ static void phylink_mac_config(struct ph | ||
pl->ops->mac_config(pl->netdev, pl->link_an_mode, state); | ||
} | ||
|
||
|
@@ -27,7 +27,7 @@ Signed-off-by: Russell King <[email protected]> | |
static void phylink_mac_an_restart(struct phylink *pl) | ||
{ | ||
if (pl->link_config.an_enabled && | ||
@@ -436,12 +443,12 @@ static void phylink_resolve(struct work_ | ||
@@ -440,12 +447,12 @@ static void phylink_resolve(struct work_ | ||
case MLO_AN_PHY: | ||
link_state = pl->phy_state; | ||
phylink_resolve_flow(pl, &link_state); | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -16,7 +16,7 @@ Signed-off-by: Russell King <[email protected]> | |
|
||
--- a/drivers/net/phy/phylink.c | ||
+++ b/drivers/net/phy/phylink.c | ||
@@ -453,28 +453,21 @@ static void phylink_resolve(struct work_ | ||
@@ -457,28 +457,21 @@ static void phylink_resolve(struct work_ | ||
|
||
case MLO_AN_INBAND: | ||
phylink_get_mac_state(pl, &link_state); | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -15,7 +15,7 @@ Signed-off-by: Russell King <[email protected]> | |
|
||
--- a/drivers/net/phy/phylink.c | ||
+++ b/drivers/net/phy/phylink.c | ||
@@ -943,8 +943,8 @@ void phylink_start(struct phylink *pl) | ||
@@ -947,8 +947,8 @@ void phylink_start(struct phylink *pl) | ||
|
||
if (pl->link_an_mode == MLO_AN_FIXED && !IS_ERR(pl->link_gpio)) | ||
mod_timer(&pl->link_poll, jiffies + HZ); | ||
|
@@ -26,7 +26,7 @@ Signed-off-by: Russell King <[email protected]> | |
if (pl->phydev) | ||
phy_start(pl->phydev); | ||
} | ||
@@ -965,8 +965,8 @@ void phylink_stop(struct phylink *pl) | ||
@@ -969,8 +969,8 @@ void phylink_stop(struct phylink *pl) | ||
|
||
if (pl->phydev) | ||
phy_stop(pl->phydev); | ||
|