Skip to content

Commit

Permalink
tools: add isl (used for graphite on GCC 5)
Browse files Browse the repository at this point in the history
Signed-off-by: Felix Fietkau <[email protected]>

SVN-Revision: 47464
  • Loading branch information
Felix Fietkau committed Nov 13, 2015
1 parent edd8706 commit 3d41dba
Show file tree
Hide file tree
Showing 3 changed files with 38 additions and 5 deletions.
2 changes: 1 addition & 1 deletion toolchain/gcc/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -32,7 +32,7 @@ config GCC_USE_GRAPHITE
config GCC_USE_SYSTEM_PPL_CLOOG
bool
prompt "Use the system versions of PPL and CLooG"
depends on GCC_USE_GRAPHITE
depends on GCC_USE_GRAPHITE && GCC_VERSION_4_8
default n

config EXTRA_GCC_CONFIG_OPTIONS
Expand Down
14 changes: 10 additions & 4 deletions tools/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -13,10 +13,14 @@ tools-y :=

ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
BUILD_TOOLCHAIN := y
endif
ifdef CONFIG_GCC_USE_GRAPHITE
ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
BUILD_PPL_CLOOG = y
ifdef CONFIG_GCC_USE_GRAPHITE
ifneq ($(CONFIG_GCC_VERSION_4_8),)
ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
BUILD_PPL_CLOOG = y
endif
else
BUILD_ISL = y
endif
endif
endif
ifneq ($(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_kmod-b43legacy)$(CONFIG_BRCMSMAC_USE_FW_FROM_WL),)
Expand All @@ -37,6 +41,7 @@ tools-$(CONFIG_TARGET_ar71xx) += lzma-old squashfs
tools-y += lzma squashfs4
tools-$(BUILD_B43_TOOLS) += b43-tools
tools-$(BUILD_PPL_CLOOG) += ppl cloog
tools-$(BUILD_ISL) += isl
tools-$(CONFIG_USE_SPARSE) += sparse

# builddir dependencies
Expand Down Expand Up @@ -67,6 +72,7 @@ $(curdir)/sdcc/compile := $(curdir)/bison/install
$(curdir)/b43-tools/compile := $(curdir)/bison/install
$(curdir)/padjffs2/compile := $(curdir)/findutils/install
$(curdir)/cloog/compile := $(curdir)/ppl/install
$(curdir)/isl/compile := $(curdir)/gmp/install
$(curdir)/bc/compile := $(curdir)/bison/install
$(curdir)/findutils/compile := $(curdir)/bison/install
$(curdir)/gengetopt/compile := $(curdir)/libtool/install
Expand Down
27 changes: 27 additions & 0 deletions tools/isl/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
#
# Copyright (C) 2009-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk

PKG_NAME:=isl
PKG_VERSION:=0.14.1

PKG_SOURCE_URL:=http://isl.gforge.inria.fr
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_MD5SUM:=94fcd11e0b1c79250ae341affb1845ea

HOST_BUILD_PARALLEL:=1

include $(INCLUDE_DIR)/host-build.mk

unexport CFLAGS

HOST_CONFIGURE_ARGS += \
--enable-static \
--disable-shared \
--with-gmp-prefix=$(STAGING_DIR_HOST)

$(eval $(call HostBuild))

0 comments on commit 3d41dba

Please sign in to comment.