forked from openwrt/packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge pull request openwrt#927 from commodo/python-push2
python: add patch to abort build on failed module build
- Loading branch information
Showing
1 changed file
with
21 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
Abort on failed module build | ||
|
||
When building a Python module fails, the setup.py script currently | ||
doesn't exit with an error, and simply continues. This is not a really | ||
nice behavior, so this patch changes setup.py to abort with an error, | ||
so that the build issue is clearly noticeable. | ||
|
||
Signed-off-by: Thomas Petazzoni <[email protected]> | ||
|
||
Index: b/setup.py | ||
=================================================================== | ||
--- a/setup.py | ||
+++ b/setup.py | ||
@@ -283,6 +283,7 @@ | ||
print "Failed to build these modules:" | ||
print_three_column(failed) | ||
+ sys.exit(1) | ||
|
||
def build_extension(self, ext): | ||
|