Skip to content

Commit

Permalink
Merge pull request openwrt#927 from commodo/python-push2
Browse files Browse the repository at this point in the history
python: add patch to abort build on failed module build
  • Loading branch information
sbyx committed Feb 19, 2015
2 parents 39c3541 + 999cc6a commit 10313e9
Showing 1 changed file with 21 additions and 0 deletions.
21 changes: 21 additions & 0 deletions lang/python/patches/170-abort-on-failed-modules.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
Abort on failed module build

When building a Python module fails, the setup.py script currently
doesn't exit with an error, and simply continues. This is not a really
nice behavior, so this patch changes setup.py to abort with an error,
so that the build issue is clearly noticeable.

Signed-off-by: Thomas Petazzoni <[email protected]>

Index: b/setup.py
===================================================================
--- a/setup.py
+++ b/setup.py
@@ -283,6 +283,7 @@
print "Failed to build these modules:"
print_three_column(failed)
print
+ sys.exit(1)

def build_extension(self, ext):

0 comments on commit 10313e9

Please sign in to comment.