Skip to content

Commit

Permalink
kernel: Update kernel 5.4 to version 5.4.50
Browse files Browse the repository at this point in the history
Run tested: ath79, ipq40xx
Build tested: ath79, ipq40xx

Signed-off-by: Hauke Mehrtens <[email protected]>
  • Loading branch information
hauke committed Jul 4, 2020
1 parent 6062d85 commit 68d9cb8
Show file tree
Hide file tree
Showing 55 changed files with 100 additions and 383 deletions.
4 changes: 2 additions & 2 deletions include/kernel-version.mk
Original file line number Diff line number Diff line change
Expand Up @@ -8,11 +8,11 @@ endif

LINUX_VERSION-4.14 = .187
LINUX_VERSION-4.19 = .131
LINUX_VERSION-5.4 = .48
LINUX_VERSION-5.4 = .50

LINUX_KERNEL_HASH-4.14.187 = 5b223475eaeea196aa7e127d3f253bca5c35d8afdc72ca75230ce1ecdd1454bd
LINUX_KERNEL_HASH-4.19.131 = 19dfb9f6cc4ba30104b65dcce7d78240a4ae188cb366747d5f8eae35e98964ba
LINUX_KERNEL_HASH-5.4.48 = bf20ddafcd04c114d34654bb10d1eb74f1864f3d14b676c6f0d42d60bbcf1d53
LINUX_KERNEL_HASH-5.4.50 = ad10f4c1e900f4e3eb4903b65dbcb4ca74250de63aa9fa7105b9b3c3f9a8a6e2

remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/arch/powerpc/platforms/4xx/pci.c
+++ b/arch/powerpc/platforms/4xx/pci.c
@@ -1904,9 +1904,9 @@ static void __init ppc4xx_configure_pcie
@@ -1902,9 +1902,9 @@ static void __init ppc4xx_configure_pcie
* if it works
*/
out_le32(mbase + PECFG_PIM0LAL, 0x00000000);
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ Signed-off-by: John Crispin <[email protected]>

--- a/drivers/usb/host/ehci-platform.c
+++ b/drivers/usb/host/ehci-platform.c
@@ -159,6 +159,11 @@ static int ehci_platform_probe(struct pl
@@ -269,6 +269,11 @@ static int ehci_platform_probe(struct pl
ehci = hcd_to_ehci(hcd);

if (pdata == &ehci_platform_defaults && dev->dev.of_node) {
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -706,7 +706,7 @@
EXPORT_SYMBOL(xfrm_parse_spi);
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
@@ -3958,14 +3958,16 @@ static bool tcp_parse_aligned_timestamp(
@@ -3968,14 +3968,16 @@ static bool tcp_parse_aligned_timestamp(
{
const __be32 *ptr = (const __be32 *)(th + 1);

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -36,7 +36,7 @@ Signed-off-by: Phil Elwell <[email protected]>
- reg
--- a/drivers/tty/serial/amba-pl011.c
+++ b/drivers/tty/serial/amba-pl011.c
@@ -2659,6 +2659,11 @@ static int pl011_probe(struct amba_devic
@@ -2660,6 +2660,11 @@ static int pl011_probe(struct amba_devic
if (IS_ERR(uap->clk))
return PTR_ERR(uap->clk);

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -26,7 +26,7 @@ Signed-off-by: Phil Howard <[email protected]>
struct nvmem_config nvmem_cfg = {
.name = "rv3028_nvram",
.word_size = 1,
@@ -669,6 +671,21 @@ static int rv3028_probe(struct i2c_clien
@@ -671,6 +673,21 @@ static int rv3028_probe(struct i2c_clien
if (ret)
return ret;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,7 @@ Signed-off-by: Phil Elwell <[email protected]>

--- a/drivers/net/ethernet/broadcom/genet/bcmgenet.c
+++ b/drivers/net/ethernet/broadcom/genet/bcmgenet.c
@@ -2151,7 +2151,7 @@ static void bcmgenet_init_tx_ring(struct
@@ -2149,7 +2149,7 @@ static void bcmgenet_init_tx_ring(struct

bcmgenet_tdma_ring_writel(priv, index, 0, TDMA_PROD_INDEX);
bcmgenet_tdma_ring_writel(priv, index, 0, TDMA_CONS_INDEX);
Expand All @@ -27,7 +27,7 @@ Signed-off-by: Phil Elwell <[email protected]>
/* Disable rate control for now */
bcmgenet_tdma_ring_writel(priv, index, flow_period_val,
TDMA_FLOW_PERIOD);
@@ -3575,9 +3575,12 @@ static int bcmgenet_probe(struct platfor
@@ -3573,9 +3573,12 @@ static int bcmgenet_probe(struct platfor
netif_set_real_num_rx_queues(priv->dev, priv->hw_params->rx_queues + 1);

/* Set default coalescing parameters */
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,7 @@ Signed-off-by: Jonathan Bell <[email protected]>

--- a/drivers/usb/host/xhci.c
+++ b/drivers/usb/host/xhci.c
@@ -1452,6 +1452,103 @@ command_cleanup:
@@ -1453,6 +1453,103 @@ command_cleanup:
}

/*
Expand Down Expand Up @@ -119,7 +119,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
* non-error returns are a promise to giveback() the urb later
* we drop ownership so next owner (or urb unlink) can get it
*/
@@ -5327,6 +5424,7 @@ static const struct hc_driver xhci_hc_dr
@@ -5334,6 +5431,7 @@ static const struct hc_driver xhci_hc_dr
.endpoint_reset = xhci_endpoint_reset,
.check_bandwidth = xhci_check_bandwidth,
.reset_bandwidth = xhci_reset_bandwidth,
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -33,7 +33,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
#define USB_VENDOR_ID_BELKIN 0x050d
#define USB_DEVICE_ID_FLIP_KVM 0x3201

@@ -1231,6 +1234,9 @@
@@ -1234,6 +1237,9 @@
#define USB_VENDOR_ID_XAT 0x2505
#define USB_DEVICE_ID_XAT_CSR 0x0220

Expand All @@ -53,7 +53,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
{ HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_MULTI_TOUCH), HID_QUIRK_MULTI_INPUT },
{ HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_PIXART_USB_OPTICAL_MOUSE), HID_QUIRK_ALWAYS_POLL },
{ HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_PIXART_USB_OPTICAL_MOUSE2), HID_QUIRK_ALWAYS_POLL },
@@ -177,6 +178,7 @@ static const struct hid_device_id hid_qu
@@ -178,6 +179,7 @@ static const struct hid_device_id hid_qu
{ HID_USB_DEVICE(USB_VENDOR_ID_WISEGROUP_LTD2, USB_DEVICE_ID_SMARTJOY_DUAL_PLUS), HID_QUIRK_NOGET | HID_QUIRK_MULTI_INPUT },
{ HID_USB_DEVICE(USB_VENDOR_ID_WISEGROUP, USB_DEVICE_ID_QUAD_USB_JOYPAD), HID_QUIRK_NOGET | HID_QUIRK_MULTI_INPUT },
{ HID_USB_DEVICE(USB_VENDOR_ID_XIN_MO, USB_DEVICE_ID_XIN_MO_DUAL_ARCADE), HID_QUIRK_MULTI_INPUT },
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -38,7 +38,7 @@ Signed-off-by: Phil Elwell <[email protected]>
static inline void bcmgenet_writel(u32 value, void __iomem *offset)
{
/* MIPS chips strapped for BE will automagically configure the
@@ -1997,6 +2001,11 @@ static void reset_umac(struct bcmgenet_p
@@ -1995,6 +1999,11 @@ static void reset_umac(struct bcmgenet_p
bcmgenet_rbuf_ctrl_set(priv, 0);
udelay(10);

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@ Signed-off-by: Phil Elwell <[email protected]>

--- a/drivers/net/ethernet/broadcom/genet/bcmgenet.c
+++ b/drivers/net/ethernet/broadcom/genet/bcmgenet.c
@@ -3476,7 +3476,7 @@ static int bcmgenet_probe(struct platfor
@@ -3474,7 +3474,7 @@ static int bcmgenet_probe(struct platfor
priv = netdev_priv(dev);
priv->irq0 = platform_get_irq(pdev, 0);
priv->irq1 = platform_get_irq(pdev, 1);
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -65,7 +65,7 @@ Cc: [email protected]

--- a/drivers/pci/controller/dwc/pcie-designware-host.c
+++ b/drivers/pci/controller/dwc/pcie-designware-host.c
@@ -343,12 +343,8 @@ int dw_pcie_host_init(struct pcie_port *
@@ -345,12 +345,8 @@ int dw_pcie_host_init(struct pcie_port *
if (!bridge)
return -ENOMEM;

Expand All @@ -82,7 +82,7 @@ Cc: [email protected]

--- a/drivers/pci/controller/pci-aardvark.c
+++ b/drivers/pci/controller/pci-aardvark.c
@@ -1023,7 +1023,8 @@ static int advk_pcie_probe(struct platfo
@@ -1019,7 +1019,8 @@ static int advk_pcie_probe(struct platfo
return ret;
}

Expand Down Expand Up @@ -224,7 +224,7 @@ Cc: [email protected]
return ret;
--- a/drivers/pci/controller/pcie-rcar.c
+++ b/drivers/pci/controller/pcie-rcar.c
@@ -1143,7 +1143,8 @@ static int rcar_pcie_probe(struct platfo
@@ -1144,7 +1144,8 @@ static int rcar_pcie_probe(struct platfo
pcie->dev = dev;
platform_set_drvdata(pdev, pcie);

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -34,7 +34,7 @@ Signed-off-by: Jonas Gorski <[email protected]>

--- a/drivers/usb/host/ehci-platform.c
+++ b/drivers/usb/host/ehci-platform.c
@@ -57,6 +57,9 @@ static int ehci_platform_reset(struct us
@@ -62,6 +62,9 @@ static int ehci_platform_reset(struct us

ehci->has_synopsys_hc_bug = pdata->has_synopsys_hc_bug;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -32,7 +32,7 @@ Signed-off-by: David S. Miller <[email protected]>
s32 tin_deficit;
u32 tin_backlog;
u32 tin_dropped;
@@ -1919,7 +1918,7 @@ begin:
@@ -1943,7 +1942,7 @@ begin:
while (b->tin_deficit < 0 ||
!(b->sparse_flow_count + b->bulk_flow_count)) {
if (b->tin_deficit <= 0)
Expand All @@ -41,7 +41,7 @@ Signed-off-by: David S. Miller <[email protected]>
if (b->sparse_flow_count + b->bulk_flow_count)
empty = false;

@@ -2241,8 +2240,7 @@ static int cake_config_besteffort(struct
@@ -2265,8 +2264,7 @@ static int cake_config_besteffort(struct

cake_set_rate(b, rate, mtu,
us_to_ns(q->target), us_to_ns(q->interval));
Expand All @@ -51,7 +51,7 @@ Signed-off-by: David S. Miller <[email protected]>

return 0;
}
@@ -2253,8 +2251,7 @@ static int cake_config_precedence(struct
@@ -2277,8 +2275,7 @@ static int cake_config_precedence(struct
struct cake_sched_data *q = qdisc_priv(sch);
u32 mtu = psched_mtu(qdisc_dev(sch));
u64 rate = q->rate_bps;
Expand All @@ -61,7 +61,7 @@ Signed-off-by: David S. Miller <[email protected]>
u32 i;

q->tin_cnt = 8;
@@ -2267,18 +2264,14 @@ static int cake_config_precedence(struct
@@ -2291,18 +2288,14 @@ static int cake_config_precedence(struct
cake_set_rate(b, rate, mtu, us_to_ns(q->target),
us_to_ns(q->interval));

Expand All @@ -83,7 +83,7 @@ Signed-off-by: David S. Miller <[email protected]>
}

return 0;
@@ -2347,8 +2340,7 @@ static int cake_config_diffserv8(struct
@@ -2371,8 +2364,7 @@ static int cake_config_diffserv8(struct
struct cake_sched_data *q = qdisc_priv(sch);
u32 mtu = psched_mtu(qdisc_dev(sch));
u64 rate = q->rate_bps;
Expand All @@ -93,7 +93,7 @@ Signed-off-by: David S. Miller <[email protected]>
u32 i;

q->tin_cnt = 8;
@@ -2364,18 +2356,14 @@ static int cake_config_diffserv8(struct
@@ -2388,18 +2380,14 @@ static int cake_config_diffserv8(struct
cake_set_rate(b, rate, mtu, us_to_ns(q->target),
us_to_ns(q->interval));

Expand All @@ -115,7 +115,7 @@ Signed-off-by: David S. Miller <[email protected]>
}

return 0;
@@ -2414,17 +2402,11 @@ static int cake_config_diffserv4(struct
@@ -2438,17 +2426,11 @@ static int cake_config_diffserv4(struct
cake_set_rate(&q->tins[3], rate >> 2, mtu,
us_to_ns(q->target), us_to_ns(q->interval));

Expand All @@ -137,7 +137,7 @@ Signed-off-by: David S. Miller <[email protected]>

return 0;
}
@@ -2455,15 +2437,10 @@ static int cake_config_diffserv3(struct
@@ -2479,15 +2461,10 @@ static int cake_config_diffserv3(struct
cake_set_rate(&q->tins[2], rate >> 2, mtu,
us_to_ns(q->target), us_to_ns(q->interval));

Expand Down

This file was deleted.

This file was deleted.

Loading

0 comments on commit 68d9cb8

Please sign in to comment.