Skip to content

Commit

Permalink
ffmpeg: Fix pkgconfig files to be more cross compile friendly
Browse files Browse the repository at this point in the history
Before:

prefix=/usr
exec_prefix=${prefix}
libdir=/usr/lib
includedir=/usr/include

After:

prefix=/usr
exec_prefix=/usr
libdir=${exec_prefix}/lib
includedir=${prefix}/include

Numbered the other patch file.

Signed-off-by: Rosen Penev <[email protected]>
  • Loading branch information
neheb committed Sep 29, 2019
1 parent 1086846 commit 7477663
Show file tree
Hide file tree
Showing 3 changed files with 16 additions and 1 deletion.
2 changes: 1 addition & 1 deletion multimedia/ffmpeg/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=ffmpeg
PKG_VERSION:=3.4.6
PKG_RELEASE:=3
PKG_RELEASE:=4

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://ffmpeg.org/releases/
Expand Down
15 changes: 15 additions & 0 deletions multimedia/ffmpeg/patches/010-pkgconfig.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
--- a/ffbuild/pkgconfig_generate.sh
+++ b/ffbuild/pkgconfig_generate.sh
@@ -28,9 +28,9 @@ version=$(grep ${name}_VERSION= $name/${name}.version | cut -d= -f2)

cat <<EOF > $name/$fullname.pc
prefix=$prefix
-exec_prefix=\${prefix}
-libdir=$libdir
-includedir=$incdir
+exec_prefix=${prefix}
+libdir=\${exec_prefix}/lib
+includedir=\${prefix}/include

Name: $fullname
Description: $comment

0 comments on commit 7477663

Please sign in to comment.