Skip to content

Commit

Permalink
Merge pull request openwrt#13028 from neheb/ldnsss
Browse files Browse the repository at this point in the history
ldns: fix compilation without deprecated APIs
  • Loading branch information
neheb authored Aug 8, 2020
2 parents b91235e + a89a876 commit cdcbe88
Show file tree
Hide file tree
Showing 3 changed files with 20 additions and 2 deletions.
2 changes: 1 addition & 1 deletion libs/ldns/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=ldns
PKG_VERSION:=1.7.1
PKG_RELEASE:=2
PKG_RELEASE:=3

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.nlnetlabs.nl/downloads/ldns
Expand Down
2 changes: 1 addition & 1 deletion libs/ldns/patches/001-compile-for-darwin.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
@@ -881,7 +881,7 @@ AC_ARG_WITH(xcode-sdk, AC_HELP_STRING([--with-xcode-sdk],
@@ -861,7 +861,7 @@ AC_ARG_WITH(xcode-sdk, AC_HELP_STRING([--with-xcode-sdk],
[],[with_xcode_sdk="yes"])
if test "x_$with_xcode_sdk" != "x_no" ; then
# check OSX deployment target, if needed
Expand Down
18 changes: 18 additions & 0 deletions libs/ldns/patches/030-signzone.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
--- a/examples/ldns-signzone.c
+++ b/examples/ldns-signzone.c
@@ -535,6 +535,7 @@ init_openssl_engine ( const char * const id )
static void
shutdown_openssl ( ENGINE * const e )
{
+#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(HAVE_LIBRESSL)
if ( e != NULL ) {
ENGINE_free ( e );
ENGINE_cleanup ();
@@ -544,6 +545,7 @@ shutdown_openssl ( ENGINE * const e )
EVP_cleanup ();
CRYPTO_cleanup_all_ex_data ();
ERR_free_strings ();
+#endif
}
#endif

0 comments on commit cdcbe88

Please sign in to comment.