forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: HardenedBSD
- Loading branch information
Showing
243 changed files
with
6,254 additions
and
1,330 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -7,7 +7,7 @@ CATEGORIES= archivers | |
MASTER_SITES= https://github.com/megastep/makeself/releases/download/release-${PORTVERSION}/ | ||
EXTRACT_SUFX= .run | ||
|
||
MAINTAINER= [email protected] | ||
MAINTAINER= [email protected] | ||
COMMENT= Neat script to make self-extracting archives | ||
|
||
LICENSE= GPLv2 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
--- gme/blargg_endian.h.orig 2021-02-10 16:11:06 UTC | ||
+++ gme/blargg_endian.h | ||
@@ -33,9 +33,7 @@ | ||
#if defined (LSB_FIRST) || defined (__LITTLE_ENDIAN__) || BLARGG_CPU_X86 || \ | ||
(defined (LITTLE_ENDIAN) && LITTLE_ENDIAN+0 != 1234) | ||
#define BLARGG_LITTLE_ENDIAN 1 | ||
-#endif | ||
- | ||
-#if defined (MSB_FIRST) || defined (__BIG_ENDIAN__) || defined (WORDS_BIGENDIAN) || \ | ||
+#elif defined (MSB_FIRST) || defined (__BIG_ENDIAN__) || defined (WORDS_BIGENDIAN) || \ | ||
defined (__sparc__) || BLARGG_CPU_POWERPC || \ | ||
(defined (BIG_ENDIAN) && BIG_ENDIAN+0 != 4321) | ||
#define BLARGG_BIG_ENDIAN 1 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,49 +2,37 @@ | |
# $FreeBSD$ | ||
|
||
PORTNAME= libsamplerate | ||
PORTVERSION= 0.1.9 | ||
PORTREVISION= 1 | ||
DISTVERSION= 0.2.1 | ||
CATEGORIES= audio | ||
MASTER_SITES= http://www.mega-nerd.com/SRC/ | ||
MASTER_SITES= https://github.com/libsndfile/${PORTNAME}/releases/download/${DISTVERSION}/ | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Secret Rabbit Code: a Sample Rate Converter for audio | ||
|
||
LICENSE= BSD2CLAUSE | ||
LICENSE_FILE= ${WRKSRC}/COPYING | ||
|
||
USES= cpe libtool pathfix pkgconfig | ||
USE_LDCONFIG= yes | ||
USES= cmake cpe pkgconfig tar:bz2 | ||
|
||
CPE_VENDOR= ${CPE_PRODUCT}_project | ||
GNU_CONFIGURE= yes | ||
INSTALL_TARGET= install-strip | ||
TEST_TARGET= check | ||
|
||
OPTIONS_DEFINE= CPU_CLIP DOCS EXAMPLES | ||
CPU_CLIP_DESC= Allow machine-dependent clipping | ||
|
||
.include <bsd.port.options.mk> | ||
|
||
MAKE_ARGS+= htmldocdir=${PREFIX}/share/doc/libsamplerate | ||
|
||
.if ${PORT_OPTIONS:MCPU_CLIP} | ||
MANUAL_PACKAGE_BUILD= CPU_CLIP may customize the package for the build machine | ||
.else | ||
CONFIGURE_ARGS+= --disable-cpu-clip | ||
.endif | ||
|
||
.if defined(MAINTAINER_MODE) || defined(PACKAGE_BUILDING) | ||
BUILD_DEPENDS += ${LOCALBASE}/lib/libfftw3.so:math/fftw3 | ||
.else | ||
CONFIGURE_ARGS+= --disable-fftw | ||
.endif | ||
|
||
.if ${PORT_OPTIONS:MEXAMPLES} | ||
LIB_DEPENDS+= libsndfile.so:audio/libsndfile | ||
.elif defined(MAINTAINER_MODE) || defined(PACKAGE_BUILDING) | ||
BUILD_DEPENDS += libsndfile>=0:audio/libsndfile | ||
.else | ||
CONFIGURE_ARGS+= --disable-sndfile | ||
.endif | ||
|
||
USE_LDCONFIG= yes | ||
|
||
TEST_TARGET= test | ||
|
||
CMAKE_ON= BUILD_SHARED_LIBS LIBSAMPLERATE_INSTALL | ||
|
||
OPTIONS_DEFINE= DOCS EXAMPLES TEST | ||
|
||
EXAMPLES_LIB_DEPENDS= libsndfile.so:audio/libsndfile | ||
EXAMPLES_CMAKE_BOOL= LIBSAMPLERATE_EXAMPLES | ||
|
||
TEST_LIB_DEPENDS= libfftw3.so:math/fftw3 \ | ||
libsndfile.so:audio/libsndfile | ||
TEST_CMAKE_BOOL= BUILD_TESTING | ||
|
||
do-install-EXAMPLES-on: | ||
${INSTALL_PROGRAM} ${WRKDIR}/.build/examples/timewarp-file ${STAGEDIR}${PREFIX}/bin/ | ||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/timewarp-file | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1478374868 | ||
SHA256 (libsamplerate-0.1.9.tar.gz) = 0a7eb168e2f21353fb6d84da152e4512126f7dc48ccb0be80578c565413444c1 | ||
SIZE (libsamplerate-0.1.9.tar.gz) = 4336641 | ||
TIMESTAMP = 1611794308 | ||
SHA256 (libsamplerate-0.2.1.tar.bz2) = f6323b5e234753579d70a0af27796dde4ebeddf58aae4be598e39b3cee00c90a | ||
SIZE (libsamplerate-0.2.1.tar.bz2) = 3747188 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
--- cmake/FindSndFile.cmake.orig 2021-01-28 01:50:45 UTC | ||
+++ cmake/FindSndFile.cmake | ||
@@ -16,10 +16,6 @@ pkg_check_modules(PC_SndFile QUIET sndfile) | ||
|
||
set(SndFile_VERSION ${PC_SndFile_VERSION}) | ||
|
||
-find_package(Vorbis COMPONENTS Enc QUIET) | ||
-find_package(FLAC QUIET) | ||
-find_package(Opus QUIET) | ||
- | ||
find_path(SndFile_INCLUDE_DIR sndfile.h | ||
HINTS | ||
${PC_SndFile_INCLUDEDIR} | ||
@@ -42,15 +38,14 @@ find_package_handle_standard_args(SndFile | ||
|
||
if(SndFile_FOUND) | ||
|
||
- set(SndFile_LIBRARIES ${SndFile_LIBRARY} ${Vorbis_Enc_LIBRARIES} ${FLAC_LIBRARIES} ${OPUS_LIBRARIES}) | ||
- set(SndFile_INCLUDE_DIRS ${SndFile_INCLUDE_DIR} ${Vorbis_Enc_INCLUDE_DIRS} ${FLAC_INCLUDE_DIRS} ${OPUS_INCLUDE_DIRS}) | ||
+ set(SndFile_LIBRARIES ${SndFile_LIBRARY}) | ||
+ set(SndFile_INCLUDE_DIRS ${SndFile_INCLUDE_DIR}) | ||
|
||
if(NOT TARGET SndFile::sndfile) | ||
add_library(SndFile::sndfile UNKNOWN IMPORTED) | ||
set_target_properties(SndFile::sndfile PROPERTIES | ||
INTERFACE_INCLUDE_DIRECTORIES "${SndFile_INCLUDE_DIR}" | ||
- IMPORTED_LOCATION "${SndFile_LIBRARY}" | ||
- INTERFACE_LINK_LIBRARIES "Vorbis::vorbisenc;Opus::opus;FLAC::FLAC") | ||
+ IMPORTED_LOCATION "${SndFile_LIBRARY}") | ||
endif() | ||
endif() | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
--- examples/CMakeLists.txt.orig 2021-01-28 01:57:53 UTC | ||
+++ examples/CMakeLists.txt | ||
@@ -1,31 +1,5 @@ | ||
-find_package(ALSA) | ||
-set(HAVE_ALSA ${ALSA_FOUND} PARENT_SCOPE) | ||
-# ALSA::ALSA target is exported since CMake >= 3.12, create it for | ||
-# old CMake versions | ||
-if(ALSA_FOUND) | ||
- if(NOT TARGET ALSA::ALSA) | ||
- add_library(ALSA::ALSA UNKNOWN IMPORTED) | ||
- set_target_properties(ALSA::ALSA PROPERTIES | ||
- INTERFACE_INCLUDE_DIRECTORIES "${ALSA_INCLUDE_DIRS}" | ||
- IMPORTED_LOCATION "${ALSA_LIBRARIES}") | ||
- endif() | ||
-endif() | ||
- | ||
add_executable(timewarp-file timewarp-file.c) | ||
target_link_libraries(timewarp-file | ||
PRIVATE | ||
samplerate | ||
$<$<BOOL:${SndFile_FOUND}>:SndFile::sndfile>) | ||
- | ||
-add_executable(varispeed-play varispeed-play.c audio_out.c audio_out.h) | ||
-target_link_libraries(varispeed-play | ||
- PRIVATE | ||
- samplerate | ||
- $<$<BOOL:${SndFile_FOUND}>:SndFile::sndfile>) | ||
-if(WIN32) | ||
- target_link_libraries(varispeed-play PRIVATE winmm) | ||
-elseif(APPLE) | ||
- target_link_libraries(varispeed-play PRIVATE "-framework CoreAudio") | ||
-elseif(ALSA_FOUND) | ||
- target_link_libraries(varispeed-play PRIVATE ALSA::ALSA) | ||
-endif() |
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,22 +1,25 @@ | ||
%%PORTEXAMPLES%%bin/sndfile-resample | ||
%%PORTEXAMPLES%%bin/timewarp-file | ||
include/samplerate.h | ||
lib/libsamplerate.a | ||
lib/cmake/SampleRate/SampleRateConfig.cmake | ||
lib/cmake/SampleRate/SampleRateConfigVersion.cmake | ||
lib/cmake/SampleRate/SampleRateTargets-%%CMAKE_BUILD_TYPE%%.cmake | ||
lib/cmake/SampleRate/SampleRateTargets.cmake | ||
lib/libsamplerate.so | ||
lib/libsamplerate.so.0 | ||
lib/libsamplerate.so.0.1.8 | ||
lib/libsamplerate.so.0.2.1 | ||
libdata/pkgconfig/samplerate.pc | ||
%%PORTDOCS%%%%DOCSDIR%%/SRC.css | ||
%%PORTDOCS%%%%DOCSDIR%%/SRC.png | ||
%%PORTDOCS%%%%DOCSDIR%%/api.html | ||
%%PORTDOCS%%%%DOCSDIR%%/api_callback.html | ||
%%PORTDOCS%%%%DOCSDIR%%/api_full.html | ||
%%PORTDOCS%%%%DOCSDIR%%/api_misc.html | ||
%%PORTDOCS%%%%DOCSDIR%%/api_simple.html | ||
%%PORTDOCS%%%%DOCSDIR%%/download.html | ||
%%PORTDOCS%%%%DOCSDIR%%/faq.html | ||
%%PORTDOCS%%%%DOCSDIR%%/history.html | ||
%%PORTDOCS%%%%DOCSDIR%%/index.html | ||
%%PORTDOCS%%%%DOCSDIR%%/license.html | ||
%%PORTDOCS%%%%DOCSDIR%%/lists.html | ||
%%PORTDOCS%%%%DOCSDIR%%/quality.html | ||
%%PORTDOCS%%%%DOCSDIR%%/win32.html | ||
%%PORTDOCS%%%%DOCSDIR%%/api.md | ||
%%PORTDOCS%%%%DOCSDIR%%/api_callback.md | ||
%%PORTDOCS%%%%DOCSDIR%%/api_full.md | ||
%%PORTDOCS%%%%DOCSDIR%%/api_misc.md | ||
%%PORTDOCS%%%%DOCSDIR%%/api_simple.md | ||
%%PORTDOCS%%%%DOCSDIR%%/bugs.md | ||
%%PORTDOCS%%%%DOCSDIR%%/download.md | ||
%%PORTDOCS%%%%DOCSDIR%%/faq.md | ||
%%PORTDOCS%%%%DOCSDIR%%/history.md | ||
%%PORTDOCS%%%%DOCSDIR%%/index.md | ||
%%PORTDOCS%%%%DOCSDIR%%/license.md | ||
%%PORTDOCS%%%%DOCSDIR%%/lists.md | ||
%%PORTDOCS%%%%DOCSDIR%%/quality.md | ||
%%PORTDOCS%%%%DOCSDIR%%/win32.md |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,9 +2,9 @@ | |
# $FreeBSD$ | ||
|
||
PORTNAME= libsndfile | ||
DISTVERSION= 1.0.30 | ||
DISTVERSION= 1.0.31 | ||
CATEGORIES= audio | ||
MASTER_SITES= https://github.com/erikd/${PORTNAME}/releases/download/v${DISTVERSION}/ | ||
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/${DISTVERSION}/ | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Reading and writing files containing sampled sound (like WAV or AIFF) | ||
|
@@ -39,13 +39,9 @@ EXTERNAL_LIB_DEPENDS= libFLAC.so:audio/flac \ | |
libopus.so:audio/opus \ | ||
libvorbis.so:audio/libvorbis | ||
|
||
MANPAGES_CMAKE_ON= -DINSTALL_MANPAGES:BOOL=ON | ||
MANPAGES_CMAKE_OFF= -DINSTALL_MANPAGES:BOOL=OFF | ||
|
||
MANPAGES_CMAKE_BOOL= INSTALL_MANPAGES | ||
STATIC_CMAKE_OFF= -DBUILD_SHARED_LIBS:BOOL=ON | ||
|
||
TEST_CMAKE_ON= -DBUILD_TESTING:BOOL=ON | ||
TEST_CMAKE_OFF= -DBUILD_TESTING:BOOL=OFF | ||
TEST_CMAKE_BOOL= BUILD_TESTING | ||
|
||
.include <bsd.port.options.mk> | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1602326605 | ||
SHA256 (libsndfile-1.0.30.tar.bz2) = 9df273302c4fa160567f412e10cc4f76666b66281e7ba48370fb544e87e4611a | ||
SIZE (libsndfile-1.0.30.tar.bz2) = 852320 | ||
TIMESTAMP = 1611780647 | ||
SHA256 (libsndfile-1.0.31.tar.bz2) = a8cfb1c09ea6e90eff4ca87322d4168cdbe5035cb48717b40bf77e751cc02163 | ||
SIZE (libsndfile-1.0.31.tar.bz2) = 875335 |
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,13 +2,13 @@ | |
# $FreeBSD$ | ||
|
||
PORTNAME= librime | ||
PORTVERSION= 1.6.1 | ||
PORTVERSION= 1.7.2 | ||
CATEGORIES= chinese textproc | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Rime Input Method Engine, the core library | ||
|
||
LICENSE= GPLv3 | ||
LICENSE= BSD3CLAUSE | ||
|
||
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \ | ||
libcapnp.so:devel/capnproto \ | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1600707948 | ||
SHA256 (rime-librime-1.6.1_GH0.tar.gz) = 774ebd2ddb9c1301a8a981c65788e0fab71ef54505e04f39b3ce4dfdb8510302 | ||
SIZE (rime-librime-1.6.1_GH0.tar.gz) = 2856751 | ||
TIMESTAMP = 1612809012 | ||
SHA256 (rime-librime-1.7.2_GH0.tar.gz) = 341df211520d44409dfef07401246076f750e82a94e8d60bc2f583e70d7fd6a8 | ||
SIZE (rime-librime-1.7.2_GH0.tar.gz) = 2859403 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,8 +2,7 @@ | |
# $FreeBSD$ | ||
|
||
PORTNAME= rime-cantonese | ||
DISTVERSION= g20201212 | ||
PORTREVISION= 1 | ||
DISTVERSION= g20210208 | ||
CATEGORIES= chinese textproc | ||
|
||
MAINTAINER= [email protected] | ||
|
@@ -29,7 +28,7 @@ OPTIONS_SUB= yes | |
|
||
USE_GITHUB= yes | ||
GH_ACCOUNT= rime | ||
GH_TAGNAME= 99785a30d1f3bffef4142bbc7b73435a73a16cb1 | ||
GH_TAGNAME= 40e6ab15124252307e0b321c8fe54e710392cc74 | ||
|
||
NO_ARCH= yes | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1608031935 | ||
SHA256 (rime-rime-cantonese-g20201212-99785a30d1f3bffef4142bbc7b73435a73a16cb1_GH0.tar.gz) = 0a34a829c2cf2379259cfa9fec5bea57697049aee9e5f051fb94a428d8804cc1 | ||
SIZE (rime-rime-cantonese-g20201212-99785a30d1f3bffef4142bbc7b73435a73a16cb1_GH0.tar.gz) = 3585583 | ||
TIMESTAMP = 1612809892 | ||
SHA256 (rime-rime-cantonese-g20210208-40e6ab15124252307e0b321c8fe54e710392cc74_GH0.tar.gz) = b9f7a7ddb4dfdb7fa7490d475009c8195968f59e3699e3e0eae9edfda926ad63 | ||
SIZE (rime-rime-cantonese-g20210208-40e6ab15124252307e0b321c8fe54e710392cc74_GH0.tar.gz) = 3585396 |
Oops, something went wrong.