Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: HardenedBSD
  • Loading branch information
fichtner committed Dec 21, 2020
1 parent 9b34002 commit 6778489
Show file tree
Hide file tree
Showing 170 changed files with 20,148 additions and 1,509 deletions.
9 changes: 3 additions & 6 deletions audio/drumkv1-lv2/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $FreeBSD$

PORTNAME= drumkv1
DISTVERSION= 0.9.17
PORTREVISION= 1
DISTVERSION= 0.9.19
CATEGORIES= audio multimedia
MASTER_SITES= SF
PKGNAMESUFFIX= -lv2
Expand All @@ -18,12 +17,10 @@ LIB_DEPENDS= libjack.so:audio/jack \
libsndfile.so:audio/libsndfile \
liblo.so:audio/liblo

USES= compiler:c++11-lang gl gmake localbase:ldflags pkgconfig qt:5 shared-mime-info
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-alsa-midi
USES= cmake compiler:c++17-lang gl localbase:ldflags pkgconfig qt:5 shared-mime-info
USE_QT= core gui widgets xml buildtools_build linguisttools_build qmake_build
USE_GL= gl

BINARY_ALIAS= qmake-qt5=${QMAKE}
CMAKE_OFF= CONFIG_ALSA_MIDI

.include <bsd.port.mk>
6 changes: 3 additions & 3 deletions audio/drumkv1-lv2/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1599672669
SHA256 (drumkv1-0.9.17.tar.gz) = a2071c7335ebd819a5dbe407dfeab0a4fa67d3087e1b14753ac64ade0af30ea5
SIZE (drumkv1-0.9.17.tar.gz) = 346081
TIMESTAMP = 1608540298
SHA256 (drumkv1-0.9.19.tar.gz) = 2e63945c8f6d06550c7817c7cd6e0a8ed0d38d6b5f13c43ca8e279320ccb2e71
SIZE (drumkv1-0.9.19.tar.gz) = 347123
2 changes: 1 addition & 1 deletion audio/drumkv1-lv2/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -3,8 +3,8 @@ lib/lv2/drumkv1.lv2/drumkv1.so
lib/lv2/drumkv1.lv2/drumkv1.ttl
lib/lv2/drumkv1.lv2/drumkv1_ui.ttl
lib/lv2/drumkv1.lv2/manifest.ttl
man/fr/man1/drumkv1.1.gz
man/man1/drumkv1.1.gz
man/man1/drumkv1.fr.1.gz
share/applications/drumkv1.desktop
share/icons/hicolor/32x32/apps/drumkv1.png
share/icons/hicolor/32x32/mimetypes/application-x-drumkv1-preset.png
Expand Down
53 changes: 24 additions & 29 deletions audio/libsidplayfp/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME= libsidplayfp
PORTVERSION= 1.8.6
PORTVERSION= 2.0.5
CATEGORIES= audio
MASTER_SITES= SF/sidplay-residfp/libsidplayfp/${PORTVERSION:R}

Expand All @@ -11,38 +11,36 @@ COMMENT= Library to play Commodore 64 music derived from libsidplay2
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING

USES= gmake libtool pathfix pkgconfig
GNU_CONFIGURE= yes
BUILD_DEPENDS= libgcrypt-config:security/libgcrypt
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error

USES= libtool pathfix pkgconfig
USE_LDCONFIG= yes

GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-exsid=no \
--with-gcrypt

INSTALL_TARGET= install-strip

PLIST_SUB+= SIDPLAYFP_SHLIB_VER=${SIDPLAYFP_SHLIB_VERSION:C/\.[[:digit:].]+//} \
SIDPLAYFP_SHLIB_VERSION=${SIDPLAYFP_SHLIB_VERSION} \
STILVIEW_SHLIB_VER=${STILVIEW_SHLIB_VERSION:C/\.[[:digit:].]+//} \
STILVIEW_SHLIB_VERSION=${STILVIEW_SHLIB_VERSION}

PORTDOCS= NEWS README TODO

OPTIONS_DEFINE= DEBUG DOCS DOXYGEN
OPTIONS_SUB= yes

DEBUG_CONFIGURE_ON= --enable-debug=full
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen

OPTIONS_GROUP= OPTIMIZATION
OPTIONS_GROUP_OPTIMIZATION= BHINTS INLINE MMX
OPTIONS_DEFAULT= BHINTS INLINE

OPTIMIZATION_DESC= Increase performance by optimization
BHINTS_DESC= Enable branch hints in reSID engine
BHINTS_CONFIGURE_ENABLE= branch-hints
INLINE_DESC= Enable inlining in reSID engine at bigger code size
INLINE_CONFIGURE_ENABLE= inline
MMX_DESC= Enable MMX code in reSIDfp for old x86 non-SSE2 CPU
MMX_CONFIGURE_ENABLE= mmx

BUILD_DEPENDS+= xa65:devel/xa65

SIDPLAYFP_SHLIB_VERSION= 4.2.7
STILVIEW_SHLIB_VERSION= 0.0.3
PLIST_SUB+= \
SIDPLAYFP_SHLIB_VER=${SIDPLAYFP_SHLIB_VERSION:C/\.[[:digit:].]+//} \
SIDPLAYFP_SHLIB_VERSION=${SIDPLAYFP_SHLIB_VERSION} \
STILVIEW_SHLIB_VER=${STILVIEW_SHLIB_VERSION:C/\.[[:digit:].]+//} \
STILVIEW_SHLIB_VERSION=${STILVIEW_SHLIB_VERSION}

DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_CONFIGURE_ENV_OFF= ac_cv_prog_HAVE_DOXYGEN=false

SIDPLAYFP_SHLIB_VERSION= 5.2.15
STILVIEW_SHLIB_VERSION= 0.0.4

post-build-DOXYGEN-on:
${MAKE_CMD} doc -C ${WRKSRC}
Expand All @@ -54,8 +52,5 @@ post-install-DOCS-on:
post-install-DOXYGEN-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
${INSTALL_DATA} ${WRKSRC}/docs/html/* ${STAGEDIR}${DOCSDIR}/html
@${FIND} ${STAGEDIR}${DOCSDIR}/html -type f | \
${SED} 's|${STAGEDIR}${PREFIX}/||' > ${WRKDIR}/PLIST.doc
@${SED} -i -e '/PLIST.doc/ r ${WRKDIR}/PLIST.doc' ${TMPPLIST}

.include <bsd.port.mk>
6 changes: 3 additions & 3 deletions audio/libsidplayfp/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1464016730
SHA256 (libsidplayfp-1.8.6.tar.gz) = dcf2da21d4bbb6acc79c1da5809fdafc643f1082c5191640763533809bdbf153
SIZE (libsidplayfp-1.8.6.tar.gz) = 671485
TIMESTAMP = 1605953222
SHA256 (libsidplayfp-2.0.5.tar.gz) = e0a70c898e318bcb915f0e73aa3559e0402588b8ed1959734e3df90267ce6d13
SIZE (libsidplayfp-2.0.5.tar.gz) = 805133
13 changes: 0 additions & 13 deletions audio/libsidplayfp/files/patch-Makefile.in

This file was deleted.

Loading

0 comments on commit 6778489

Please sign in to comment.