forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
498 changed files
with
4,448 additions
and
2,281 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1686905718 | ||
SHA256 (unrarsrc-6.2.8.tar.gz) = 1777e3d3b073815ff68a411ddb1ab76d0a4e1f58ecc7080035b27b52967ff911 | ||
SIZE (unrarsrc-6.2.8.tar.gz) = 246249 | ||
TIMESTAMP = 1689913695 | ||
SHA256 (unrarsrc-6.2.9.tar.gz) = 477aecdad08062b20eb63e14f60dc70293dcb92ec7b1d80ab3ea8acec33c2cb4 | ||
SIZE (unrarsrc-6.2.9.tar.gz) = 246388 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
- workaround for error: reference to 'byte' is ambiguous, see https://github.com/trilomix/GDS3D/issues/23 | ||
|
||
--- ../libgdsto3d/gdsparse.cpp.orig 2023-07-20 10:59:11.684448000 -0700 | ||
+++ ../libgdsto3d/gdsparse.cpp 2023-07-20 10:59:35.325794000 -0700 | ||
@@ -127,7 +127,7 @@ | ||
|
||
bool GDSParse::ParseFile(char *topcell) | ||
{ | ||
- byte recordtype, datatype; | ||
+ ::byte recordtype, datatype; | ||
char *tempstr; | ||
//struct ProcessLayer *layer = NULL; | ||
|
||
@@ -1086,7 +1086,7 @@ | ||
|
||
short GDSParse::GetBitArray() | ||
{ | ||
- byte byte1; | ||
+ ::byte byte1; | ||
|
||
fread(&byte1, 1, 1, _iptr); | ||
fread(&byte1, 1, 1, _iptr); | ||
@@ -1097,8 +1097,8 @@ | ||
|
||
double GDSParse::GetEightByteReal() | ||
{ | ||
- byte value; | ||
- byte b8, b2, b3, b4, b5, b6, b7; | ||
+ ::byte value; | ||
+ ::byte b8, b2, b3, b4, b5, b6, b7; | ||
double sign=1.0; | ||
double exponent; | ||
double mant; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,41 @@ | ||
PORTNAME= idn | ||
PORTVERSION= 0.2 | ||
CATEGORIES= databases | ||
PKGNAMEPREFIX= postgresql${PGSQL_VER:S/.//}- | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= PostgreSQL extension for libidn2 | ||
WWW= https://github.com/dyninc/postgresql-idn | ||
|
||
LICENSE= BSD3CLAUSE | ||
LICENSE_FILE= ${WRKSRC}/COPYRIGHT | ||
|
||
LIB_DEPENDS= libidn.so:dns/libidn \ | ||
libidn2.so:dns/libidn2 | ||
|
||
USES= gmake pgsql | ||
WANT_PGSQL= server | ||
USE_GITHUB= yes | ||
GH_ACCOUNT= dyninc | ||
GH_PROJECT= postgresql-idn | ||
GH_TAGNAME= d4ffaec | ||
|
||
BUILD_WRKSRC= ${WRKSRC}/sources | ||
|
||
PLIST_FILES= \ | ||
lib/postgresql/idn.so \ | ||
share/postgresql/extension/idn.control \ | ||
share/postgresql/extension/idn--0.2.sql | ||
|
||
post-patch: | ||
@${REINPLACE_CMD} -e 's|CreateTemplateTupleDesc(3, false)|CreateTemplateTupleDesc(3)|g' \ | ||
${BUILD_WRKSRC}/idn.c | ||
|
||
do-install: | ||
${MKDIR} ${STAGEDIR}${PREFIX}/lib/postgresql | ||
${MKDIR} ${STAGEDIR}${PREFIX}/share/postgresql/extension | ||
${INSTALL_LIB} ${BUILD_WRKSRC}/idn.so ${STAGEDIR}${PREFIX}/lib/postgresql/idn.so | ||
${INSTALL_DATA} ${BUILD_WRKSRC}/idn--0.2.sql ${STAGEDIR}${PREFIX}/share/postgresql/extension | ||
${INSTALL_DATA} ${BUILD_WRKSRC}/idn.control ${STAGEDIR}${PREFIX}/share/postgresql/extension | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
TIMESTAMP = 1689853106 | ||
SHA256 (dyninc-postgresql-idn-0.2-d4ffaec_GH0.tar.gz) = 77648e741c96ae186dcd4ce835cada228877864e390e1854c5099277337a0b06 | ||
SIZE (dyninc-postgresql-idn-0.2-d4ffaec_GH0.tar.gz) = 14784 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
At a fundamental level, this extension grants access to a number of | ||
functions provided by the libidn and libidn2 libraries. Not all of the | ||
functions provided by these libraries are exposed. | ||
|
||
Whenever possible, the code will transform the encoding of the data in | ||
the database to UTF-8 before further processing. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -5,6 +5,9 @@ PORTREVISION= 2 | |
CATEGORIES= deskutils | ||
PKGNAMESUFFIX= -${FLAVOR} | ||
|
||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/ | ||
PATCHFILES+= 79d33dd337deeb357ce92c3d1e2b5b56b6f2c97d.patch:-p1 # Fix build with Qt 6.5.x | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Qt${FLAVOR:S/qt//} based clipboard manager | ||
WWW= https://github.com/hluk/CopyQ | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,5 @@ | ||
TIMESTAMP = 1680456044 | ||
TIMESTAMP = 1689891691 | ||
SHA256 (hluk-CopyQ-v7.0.0_GH0.tar.gz) = 5898ba2025f8e9f61a4b4732e85adf3b1653fad20b5c1f1b0c879a7b72cd4d48 | ||
SIZE (hluk-CopyQ-v7.0.0_GH0.tar.gz) = 3323354 | ||
SHA256 (79d33dd337deeb357ce92c3d1e2b5b56b6f2c97d.patch) = 1e35ffd348245b2ca74671e17e38ea77888c589730da69974f6440923226872e | ||
SIZE (79d33dd337deeb357ce92c3d1e2b5b56b6f2c97d.patch) = 1734 |
Oops, something went wrong.