Skip to content

Commit

Permalink
tailscale: update to 1.40.0
Browse files Browse the repository at this point in the history
Signed-off-by: Zephyr Lykos <[email protected]>
  • Loading branch information
mochaaP authored and 1715173329 committed May 3, 2023
1 parent 829a9a6 commit 69c9833
Show file tree
Hide file tree
Showing 4 changed files with 7 additions and 7 deletions.
8 changes: 4 additions & 4 deletions net/tailscale/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=tailscale
PKG_VERSION:=1.36.0
PKG_VERSION:=1.40.0
PKG_RELEASE:=1

PKG_SOURCE:=tailscale-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/tailscale/tailscale/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=25b293a7e65d7b962f0c56454d66fa56c89c3aa995467218f24efa335b924c76
PKG_HASH:=6964176889943e0e0b25d8d69e14226cfb1c1a9944a257b24cb2dd212f797141

PKG_MAINTAINER:=Jan Pavlinec <[email protected]>
PKG_LICENSE:=BSD-3-Clause
Expand All @@ -27,8 +27,8 @@ PKG_BUILD_FLAGS:=no-mips16
GO_PKG:=\
tailscale.com/cmd/tailscale \
tailscale.com/cmd/tailscaled
GO_PKG_LDFLAGS:=-X 'tailscale.com/version.Long=$(PKG_VERSION)-$(PKG_RELEASE) (OpenWrt)'
GO_PKG_LDFLAGS_X:=tailscale.com/version.Short=$(PKG_VERSION)
GO_PKG_LDFLAGS:=-X 'tailscale.com/version.longStamp=$(PKG_VERSION)-$(PKG_RELEASE) (OpenWrt)'
GO_PKG_LDFLAGS_X:=tailscale.com/version.shortStamp=$(PKG_VERSION)

include $(INCLUDE_DIR)/package.mk
include ../../lang/golang/golang-package.mk
Expand Down
2 changes: 1 addition & 1 deletion net/tailscale/patches/010-fake_iptables.patch
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
+++ b/go.mod
@@ -2,6 +2,8 @@ module tailscale.com

go 1.19
go 1.20

+replace github.com/coreos/go-iptables => ./patched/go-iptables
+
Expand Down
2 changes: 1 addition & 1 deletion net/tailscale/patches/020-tailscaled_fake_iptables.patch
Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,7 @@
}
}

@@ -1635,11 +1635,6 @@ func checkIPv6(logf logger.Logf) error {
@@ -1676,11 +1676,6 @@ func checkIPv6(logf logger.Logf) error {
return fmt.Errorf("kernel doesn't support IPv6 policy routing: %w", err)
}

Expand Down
2 changes: 1 addition & 1 deletion net/tailscale/patches/030-default_to_netfilter_off.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/cmd/tailscale/cli/up.go
+++ b/cmd/tailscale/cli/up.go
@@ -143,7 +143,7 @@ func defaultNetfilterMode() string {
@@ -147,7 +147,7 @@ func defaultNetfilterMode() string {
if distro.Get() == distro.Synology {
return "off"
}
Expand Down

0 comments on commit 69c9833

Please sign in to comment.