Skip to content

Commit

Permalink
dev-vcs/repo: add 2.45
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/931692
Signed-off-by: Joe Kappus <[email protected]>
Signed-off-by: Florian Schmaus <[email protected]>
  • Loading branch information
joecool1029 authored and Flowdalic committed May 23, 2024
1 parent 19698cd commit a9650fc
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/repo/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST repo-2.37.tar.gz 273445 BLAKE2B 7934581c5c55896d8ba58f5841a028f4676062197498ef601fa005f4e19428eee552e66d057a1e0d033eff8691df2de8e130ff96aec0e4537a462be81796e249 SHA512 6aa11e9fc9d899866dd89788c94ef188ea89dc6757a4e4fe0f1284898315723f72b3b97b60d39194f34e56332057545eb9c99b6483bc3e0513f747410226b9fa
DIST repo-2.40.tar.gz 277118 BLAKE2B 57ebd20e323a4c3d02885c71f599bf57d23e68b8199b136095ce77a479a815439c51844b11744e0c9555091e91821ba49715c57d985a3a30579497b4617b6361 SHA512 0cd9df29edf14acdaeb0e4d07dea13f6e3bfa77ac36ffe7c4042d050c5d3fb36a7ff9a249e521aef7d7e5fbff9fe1c4b94df02c0d435353e0c169a94254f78ba
DIST repo-2.45.tar.gz 279358 BLAKE2B 1035621e5f4f139ae1a7057ea30bf9431d4a39c46a6dd79dcc89653d5aa628d43ffc1793b27100f64dd14c37c06bfcfeb02a2b16ba5abe3cb6e18bf6dd981dba SHA512 0fc285dd3c2483ff72f791e207448ace85256f03aa75ac2af5982fbac2b190b66a2bc3d44a7b1eca6e7df8500483d9dfb72a1fc79ef74c64eb0a12b020ea93ff
33 changes: 33 additions & 0 deletions dev-vcs/repo/repo-2.45.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# NB: The ${PV} tracks the *repo launcher version*, not the last signed release
# of the repo project. The launcher only gets a new update when changes are
# made in it.

EAPI="8"

PYTHON_COMPAT=( python3_{10..12} )

inherit bash-completion-r1 python-r1

DESCRIPTION="Google tool for managing git, particularly multiple repos"
HOMEPAGE="https://gerrit.googlesource.com/git-repo"
SRC_URI="https://github.com/GerritCodeReview/git-repo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="${PYTHON_DEPS}
!app-admin/radmind
"

S="${WORKDIR}/git-${P}"

src_install() {
python_foreach_impl python_doscript ${PN}
newbashcomp completion.bash ${PN}
doman man/*.[0-9]
}

0 comments on commit a9650fc

Please sign in to comment.