Skip to content

Commit

Permalink
Infrastructure: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Apr 9, 2015
1 parent b012249 commit 01ce2ef
Show file tree
Hide file tree
Showing 10 changed files with 113 additions and 479 deletions.
11 changes: 11 additions & 0 deletions CHANGES
Original file line number Diff line number Diff line change
Expand Up @@ -10,6 +10,17 @@ in the release notes and/or placed into UPDATING.

All ports committers are allowed to commit to this file.

20150409:
AUTHOR: [email protected]

Add a new USES=gnustep to handle the GNUstep ports. Now the dependencies on
GNUstep libraries is done via the regular LIB_DEPENDS

USE_GNUSTEP is now a macro that accept many arguments: back, build, gui, back
Depending on the feature needed for a given port

Reuse USES=objc to avoid duplicating code

20150408:
AUTHOR: [email protected]

Expand Down
2 changes: 1 addition & 1 deletion GIDs
Original file line number Diff line number Diff line change
Expand Up @@ -296,7 +296,6 @@ boinc:*:973:
radicale:*:974:
unifi:*:975:
minetest:*:976:
sguil:*:978:
ums:*:979:
hbase:*:980:
uvncrep:*:981:
Expand All @@ -308,6 +307,7 @@ kamailio:*:986:
spark:*:987:
emby:*:989:
oozie:*:990:
sguil:*:991:
ebnetd:*:999:
nogroup:*:65533:
nobody:*:65534:
1 change: 1 addition & 0 deletions MOVED
Original file line number Diff line number Diff line change
Expand Up @@ -7463,3 +7463,4 @@ sysutils/puppet27||2015-04-07|Has expired: Does not work with Ruby 2.x
www/rubygem-form_data|www/rubygem-http-form_data|2015-04-07|Has expired: Use www/rubygem-http-form_data instead (renamed by upstream)
www/typo345||2015-04-07|Has expired: Upgrade to www/typo3 or www/typo3-lts
multimedia/mediabrowser|multimedia/emby-server|2015-04-08|Project renamed
deskutils/preferencepanes|deskutils/systempreferences|2015-04-08|preferencepanes merged into systempreferences
22 changes: 1 addition & 21 deletions Mk/Scripts/find-lib.sh
Original file line number Diff line number Diff line change
Expand Up @@ -14,26 +14,6 @@ fi
lib=$1
dirs="${LIB_DIRS} `cat ${LOCALBASE}/libdata/ldconfig/* 2>/dev/null || :`"

resolv_symlink() {
local file tgt
file=${1}
if [ ! -L ${file} ] ; then
echo ${file}
return
fi

tgt=`readlink ${file}`
case $tgt in
/*)
echo $tgt
return
;;
esac

file=${file%/*}/${tgt}
absolute_path ${file}
}

absolute_path() {
local file myifs target
file=$1
Expand All @@ -55,7 +35,7 @@ absolute_path() {

for libdir in ${dirs} ; do
test -f ${libdir}/${lib} || continue
libfile=`resolv_symlink ${libdir}/${lib}`
libfile=${libdir}/${lib}
[ `file -b -L --mime-type ${libfile}` = "application/x-sharedlib" ] || continue
echo $libfile
break
Expand Down
79 changes: 79 additions & 0 deletions Mk/Uses/gnustep.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
# $FreeBSD$
#
# Handle GNUstep related ports
#
# Feature: gnustep
# Usage: USES=gnustep
#
# Defined specific dependencies under USE_GNUSTEP
# Expected arguments for USE_GNUSTEP:
#
# base: depends on the gnustep-base port
# gui: depends on the gnustep-gui port
# back: depends on the gnustep-back port
# build: prepare the build dependencies for a regular GNUstep port
#

.if !defined(_INCLUDE_USES_GNUSTEP_MK)
_INCLUDE_USES_GNUSTEP_MK= yes
.include "${USESDIR}/gmake.mk"

GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
DEFAULT_LIBVERSION?= 0.0.1

GNUSTEP_SYSTEM_ROOT= ${GNUSTEP_PREFIX}/System
GNUSTEP_MAKEFILES= ${GNUSTEP_SYSTEM_ROOT}/Library/Makefiles
GNUSTEP_SYSTEM_LIBRARIES= ${GNUSTEP_SYSTEM_ROOT}/Library/Libraries
GNUSTEP_SYSTEM_TOOLS= ${GNUSTEP_SYSTEM_ROOT}/Tools

GNUSTEP_LOCAL_ROOT= ${GNUSTEP_PREFIX}/Local
GNUSTEP_LOCAL_LIBRARIES= ${GNUSTEP_LOCAL_ROOT}/Library/Libraries
GNUSTEP_LOCAL_TOOLS= ${GNUSTEP_LOCAL_ROOT}/Tools

LIB_DIRS+= ${GNUSTEP_SYSTEM_LIBRARIES} \
${GNUSTEP_LOCAL_LIBRARIES}

.for a in FLAGS CFLAGS CPPFLAGS OBJCFLAGS INCLUDE_DIRS LDFLAGS LIB_DIRS
MAKE_ENV+= ADDITIONAL_${a}="${ADDITIONAL_${a}}"
.endfor

MAKEFILE= GNUmakefile
#MAKE_ENV+= GNUSTEP_CONFIG_FILE=${PORTSDIR}/devel/gnustep-make/files/GNUstep.conf
GNU_CONFIGURE_PREFIX= ${GNUSTEP_PREFIX}

.if ${MACHINE_ARCH} == "i386"
GNU_ARCH= ix86
.else
GNU_ARCH= ${MACHINE_ARCH}
.endif

PLIST_SUB+= GNU_ARCH=${GNU_ARCH} VERSION=${PORTVERSION}
PLIST_SUB+= MAJORVERSION=${PORTVERSION:C/([0-9]).*/\1/1}
PLIST_SUB+= LIBVERSION=${DEFAULT_LIBVERSION}
PLIST_SUB+= MAJORLIBVERSION=${DEFAULT_LIBVERSION:C/([0-9]).*/\1/1}

.if defined(USE_GNUSTEP)
. if ${USE_GNUSTEP:Mbase}
LIB_DEPENDS+= libgnustep-base.so:${PORTSDIR}/lang/gnustep-base
. endif

. if ${USE_GNUSTEP:Mbuild}
PATH:= ${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}:${PATH}
MAKE_ENV+= PATH="${PATH}" GNUSTEP_MAKEFILES="${GNUSTEP_MAKEFILES}" GNUSTEP_SYSTEM_ROOT="${GNUSTEP_SYSTEM_ROOT}"
CONFIGURE_ENV+= PATH="${PATH}" GNUSTEP_MAKEFILES="${GNUSTEP_MAKEFILES}" GNUSTEP_SYSTEM_ROOT="${GNUSTEP_SYSTEM_ROOT}"
BUILD_DEPENDS+= gnustep-make>0:${PORTSDIR}/devel/gnustep-make
.include "${USESDIR}/objc.mk"
. endif

. if ${USE_GNUSTEP:Mgui}
LIB_DEPENDS+= libgnustep-gui.so:${PORTSDIR}/x11-toolkits/gnustep-gui
. endif

. if ${USE_GNUSTEP:Mback}
BUILD_DEPENDS+= gnustep-back>0:${PORTSDIR}/x11-toolkits/gnustep-back
RUN_DEPENDS+= gnustep-back>0:${PORTSDIR}/x11-toolkits/gnustep-back
. endif

.endif

.endif
Loading

0 comments on commit 01ce2ef

Please sign in to comment.