forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
285 changed files
with
3,434 additions
and
1,208 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.3_Linux_x86_deb_langpack_ar.tar.gz) = cda861b351933183d60563913aea9af905a3bbec9bc7e8eb2121c40765765ce1 | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.3_Linux_x86_deb_langpack_ar.tar.gz) = 2255921 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.4_Linux_x86_deb_langpack_ar.tar.gz) = b98adf0cfd71412cb898bfcc65e946213e9a350119e33f5fa7fb0cc84a4425cb | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.4_Linux_x86_deb_langpack_ar.tar.gz) = 2256033 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,98 +1,17 @@ | ||
#!/usr/bin/perl -w | ||
#!/bin/sh | ||
|
||
# Copyright (C) 1997,1998,1999, Roger Espel Llima | ||
# Copyright (C) 2000, Sergey Babkin | ||
# Copyright (C) 2009, Alex Kozlov | ||
# | ||
# Permission is hereby granted, free of charge, to any person obtaining a copy | ||
# of this software and any associated documentation files (the "Software"), to | ||
# deal in the Software without restriction, including without limitation the | ||
# rights to use, copy, modify, merge, publish, distribute, sublicense, | ||
# and/or sell copies of the Software, and to permit persons to whom the | ||
# Software is furnished to do so, subject to the following conditions: | ||
# | ||
# The above copyright notice and this permission notice shall be included in | ||
# all copies or substantial portions of the Software. | ||
# | ||
# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR | ||
# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, | ||
# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE | ||
# SOFTWARE'S COPYRIGHT HOLDER(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER | ||
# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, | ||
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN | ||
# THE SOFTWARE | ||
# NB! needs bsdtar/libarchive v2.8+ | ||
|
||
# (whew, that's done!) | ||
PATH=/bin:/usr/bin | ||
|
||
# why does the world need another rpm2cpio? because the existing one | ||
# won't build unless you have half a ton of things that aren't really | ||
# required for it, since it uses the same library used to extract RPM's. | ||
# in particular, it won't build on the HPsUX box i'm on. | ||
if [ $# -eq 0 ]; then | ||
f=/dev/stdin | ||
elif [ $# -eq 1 ]; then | ||
f=$1 | ||
else | ||
echo Usage: rpm2cpio [file.rpm] | ||
echo dumps the contents to stdout as a GNU cpio archive | ||
exit 0 | ||
fi | ||
|
||
use strict; | ||
|
||
my ($f, $rpm, $filter) = (); | ||
|
||
if ($#ARGV == -1) { | ||
$f = "STDIN"; | ||
} elsif ($#ARGV == 0) { | ||
open($f, "< $ARGV[0]") or die "Can't read file $ARGV[0]\n"; | ||
} else { | ||
print "rpm2cpio v1.3, perl version by orabidoo\n"; | ||
print "use: rpm2cpio [file.rpm]\n"; | ||
print "dumps the contents to stdout as a GNU cpio archive\n"; | ||
exit 0; | ||
} | ||
|
||
read $f, $rpm, 96; | ||
|
||
my ($magic, $major, undef) = unpack("NCC", $rpm); | ||
|
||
die "Not an RPM\n" if $magic != 0xedabeedb; | ||
die "Not a version 3 or 4 RPM\n" if $major != 3 and $major != 4; | ||
|
||
read $f, $rpm, 16 or die "No header\n"; | ||
while(1) { | ||
($magic, undef, my $sections, my $bytes) = unpack("N4", $rpm); | ||
my ($smagic, $smagic2) = unpack("nN", $rpm); | ||
|
||
#printf(STDERR "0x%x 0x%x 0x%x 0x%x 0x%x\n", | ||
# tell($f)-16, $magic, $sections, $bytes, $smagic); | ||
|
||
if ($smagic == 0x1f8b) { | ||
$filter = "gzip -cd"; | ||
last; | ||
} | ||
# BZh | ||
if ($smagic == 0x425a and ($smagic2 & 0xff000000) == 0x68000000) { | ||
$filter = "bzip2 -cd"; | ||
last; | ||
} | ||
# 0xFD, '7zXZ', 0x0 | ||
if ($smagic == 0xfd37 and $smagic2 == 0x7a585a00) { | ||
$filter = "xz -cd"; | ||
last; | ||
} | ||
# assume lzma if there is no sig | ||
if ($magic != 0x8eade801) { | ||
$filter = "lzma -cd"; | ||
last; | ||
} | ||
|
||
# skip the headers | ||
seek $f, 16 * $sections + $bytes, 1 or die "File is too small\n"; | ||
do { | ||
read $f, $rpm, 1 or die "No header\n" ; | ||
} while(0 == unpack("C", $rpm)); | ||
read $f, $rpm, 15, 1 or die "No header\n" ; | ||
} | ||
|
||
open(ZCAT, "| $filter") or die "can't pipe to $filter\n"; | ||
|
||
while($rpm ne '') { | ||
print ZCAT $rpm; | ||
read $f, $rpm, 10240; # read in blocks | ||
} | ||
|
||
close ZCAT; | ||
close $f; | ||
tar cf - --format=newc @- < ${f} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,20 +1,7 @@ | ||
Convert .rpm files for extraction with /usr/bin/cpio | ||
Convert .rpm files to cpio format | ||
|
||
Quoting the author: | ||
|
||
why does the world need another rpm2cpio? because the existing one | ||
Why does the world need another rpm2cpio? because the existing one | ||
won't build unless you have half a ton of things that aren't really | ||
required for it, since it uses the same library used to extract RPM's. | ||
in particular, it won't build on the HPsUX box I'm on. | ||
|
||
(this one needs just perl) | ||
|
||
Updated version by Sergey Babkin that doesn't slurp the entire file | ||
into memory and supports the newer bzip2 compressed rpms. | ||
|
||
BUGS: if the rpm contains more than one cpio file this version | ||
extracts only the first one. (I don't know how widespread these | ||
types of rpms are, i haven't yet seen one. If you do, try the | ||
binary rpm2cpio that comes with the archivers/rpm port.) | ||
|
||
Now called rpm2cpio.pl so that it doesn't conflict with the binary one. | ||
This version just a tiny wrapper around bsdtar. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.3_Linux_x86_deb_langpack_zh-CN.tar.gz) = c70ca2d6fbfaf8593ef5f595074a8e128d3000fa3d03b80131a4cbdeefc07e0e | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.3_Linux_x86_deb_langpack_zh-CN.tar.gz) = 567871 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.3_Linux_x86_deb_helppack_zh-CN.tar.gz) = 2652cefc90bc186aa122cf15414bf556c3742ef80a86b09c8d8a14614c349fcf | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.3_Linux_x86_deb_helppack_zh-CN.tar.gz) = 10640758 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.4_Linux_x86_deb_langpack_zh-CN.tar.gz) = c0ee26bade610d9a9dc2a6fbdcaa206cc4fed0b17f612d56d9f1b35e57edb3de | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.4_Linux_x86_deb_langpack_zh-CN.tar.gz) = 568046 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.4_Linux_x86_deb_helppack_zh-CN.tar.gz) = cc858c50d5e104dac31601c58b97702b848ed1dda9a7086bb18670af6f45bc31 | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.4_Linux_x86_deb_helppack_zh-CN.tar.gz) = 10640742 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.3_Linux_x86_deb_langpack_zh-TW.tar.gz) = b82520b9713577305d32de4e3fc491441aa2d787886e43228801df5cffa40d69 | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.3_Linux_x86_deb_langpack_zh-TW.tar.gz) = 565049 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.3_Linux_x86_deb_helppack_zh-TW.tar.gz) = 2d19f71e4fae5728dc08150e6e9677020431764fcadc0170ebaa795d7fb9e91b | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.3_Linux_x86_deb_helppack_zh-TW.tar.gz) = 10697265 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.4_Linux_x86_deb_langpack_zh-TW.tar.gz) = c9ed61d58661003e37d58096b6ce95f0f959a02b80ff437395da0808037a3a95 | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.4_Linux_x86_deb_langpack_zh-TW.tar.gz) = 565091 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.4_Linux_x86_deb_helppack_zh-TW.tar.gz) = ff72a5a67ed4f56f7d79c66e26f0021b2662e2d697459171fd30875161859faf | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.4_Linux_x86_deb_helppack_zh-TW.tar.gz) = 10697112 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -10,19 +10,14 @@ DISTNAME= ${PORTNAME}${PORTVERSION:S/.//} | |
MAINTAINER= [email protected] | ||
COMMENT= Convert MASM/TASM files to NASM compatible sources | ||
|
||
USES= perl5 zip | ||
USES= perl5 zip dos2unix shebangfix | ||
SHEBANG_FILES= nomyso.pl | ||
USE_PERL5= run | ||
NO_WRKSUBDIR= yes | ||
NO_BUILD= yes | ||
|
||
PLIST_FILES= bin/${PORTNAME}.pl | ||
|
||
post-patch: | ||
@${REINPLACE_CMD} -E \ | ||
-e 's|[[:cntrl:]]$$||' \ | ||
-e 's|/usr/bin/perl|${PERL}|' \ | ||
${WRKSRC}/${PORTNAME}.pl | ||
|
||
do-install: | ||
@${INSTALL_SCRIPT} \ | ||
${WRKSRC}/${PORTNAME}.pl \ | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
27 changes: 27 additions & 0 deletions
27
databases/mysql57-client/files/patch-cmake_os_DragonFly.cmake
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,27 @@ | ||
--- cmake/os/DragonFly.cmake.orig 2015-12-17 10:53:10 UTC | ||
+++ cmake/os/DragonFly.cmake | ||
@@ -0,0 +1,24 @@ | ||
+INCLUDE(CheckCSourceRuns) | ||
+ | ||
+# We require at least GCC 4.4 or Clang 3.3. | ||
+IF(NOT FORCE_UNSUPPORTED_COMPILER) | ||
+ IF(CMAKE_COMPILER_IS_GNUCC) | ||
+ EXECUTE_PROCESS(COMMAND ${CMAKE_C_COMPILER} -dumpversion | ||
+ OUTPUT_VARIABLE GCC_VERSION) | ||
+ IF(GCC_VERSION VERSION_LESS 4.4) | ||
+ MESSAGE(FATAL_ERROR "GCC 4.4 or newer is required!") | ||
+ ENDIF() | ||
+ ELSEIF(CMAKE_C_COMPILER_ID MATCHES "Clang") | ||
+ CHECK_C_SOURCE_RUNS(" | ||
+ int main() | ||
+ { | ||
+ return (__clang_major__ < 3) || | ||
+ (__clang_major__ == 3 && __clang_minor__ < 3); | ||
+ }" HAVE_SUPPORTED_CLANG_VERSION) | ||
+ IF(NOT HAVE_SUPPORTED_CLANG_VERSION) | ||
+ MESSAGE(FATAL_ERROR "Clang 3.3 or newer is required!") | ||
+ ENDIF() | ||
+ ELSE() | ||
+ MESSAGE(FATAL_ERROR "Unsupported compiler!") | ||
+ ENDIF() | ||
+ENDIF() |
11 changes: 11 additions & 0 deletions
11
databases/mysql57-client/files/patch-cmd-line-utils_libedit_chartype.h
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- cmd-line-utils/libedit/chartype.h.orig 2015-11-29 19:16:24 UTC | ||
+++ cmd-line-utils/libedit/chartype.h | ||
@@ -49,7 +49,7 @@ | ||
TODO : Verify if FreeBSD & AIX stores ISO 10646 in wchar_t. */ | ||
#if !defined(__NetBSD__) && !defined(__sun) \ | ||
&& !(defined(__APPLE__) && defined(__MACH__)) \ | ||
- && !defined(__FreeBSD__) && !defined(_AIX) | ||
+ && !defined(__FreeBSD__) && !defined(_AIX) && !defined(__DragonFly__) | ||
#ifndef __STDC_ISO_10646__ | ||
/* In many places it is assumed that the first 127 code points are ASCII | ||
* compatible, so ensure wchar_t indeed does ISO 10646 and not some other |
20 changes: 20 additions & 0 deletions
20
databases/mysql57-client/files/patch-cmd-line-utils_libedit_vi.c
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
--- cmd-line-utils/libedit/vi.c.orig 2015-11-29 19:16:24 UTC | ||
+++ cmd-line-utils/libedit/vi.c | ||
@@ -919,7 +919,7 @@ vi_comment_out(EditLine *el, Int c __att | ||
* NB: posix implies that we should enter insert mode, however | ||
* this is against historical precedent... | ||
*/ | ||
-#if defined(__weak_reference) && !defined(__FreeBSD__) | ||
+#if defined(__weak_reference) && !defined(__FreeBSD__) && !defined(__DragonFly__) | ||
__weakref_visible char *my_get_alias_text(const char *) | ||
__weak_reference(get_alias_text); | ||
#endif | ||
@@ -928,7 +928,7 @@ protected el_action_t | ||
vi_alias(EditLine *el __attribute__((__unused__)), | ||
Int c __attribute__((__unused__))) | ||
{ | ||
-#if defined(__weak_reference) && !defined(__FreeBSD__) | ||
+#if defined(__weak_reference) && !defined(__FreeBSD__) && !defined(__DragonFly__) | ||
char alias_name[3]; | ||
char *alias_text; | ||
|
11 changes: 11 additions & 0 deletions
11
databases/mysql57-client/files/patch-libmysql_CMakeLists.txt
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- libmysql/CMakeLists.txt.orig 2015-11-29 19:16:24 UTC | ||
+++ libmysql/CMakeLists.txt | ||
@@ -260,7 +260,7 @@ IF(NOT DISABLE_SHARED) | ||
COMPONENT SharedLibraries) | ||
IF(UNIX) | ||
# libtool compatability | ||
- IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE) | ||
+ IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD|DragonFly" OR APPLE) | ||
SET(OS_SHARED_LIB_VERSION "${SHARED_LIB_MAJOR_VERSION}") | ||
ELSE() | ||
SET(OS_SHARED_LIB_VERSION |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
11 changes: 11 additions & 0 deletions
11
databases/mysql57-server/files/patch-cmd-line-utils_libedit_chartype.h
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- cmd-line-utils/libedit/chartype.h.orig 2015-11-29 19:16:24 UTC | ||
+++ cmd-line-utils/libedit/chartype.h | ||
@@ -49,7 +49,7 @@ | ||
TODO : Verify if FreeBSD & AIX stores ISO 10646 in wchar_t. */ | ||
#if !defined(__NetBSD__) && !defined(__sun) \ | ||
&& !(defined(__APPLE__) && defined(__MACH__)) \ | ||
- && !defined(__FreeBSD__) && !defined(_AIX) | ||
+ && !defined(__FreeBSD__) && !defined(_AIX) && !defined(__DragonFly__) | ||
#ifndef __STDC_ISO_10646__ | ||
/* In many places it is assumed that the first 127 code points are ASCII | ||
* compatible, so ensure wchar_t indeed does ISO 10646 and not some other |
20 changes: 20 additions & 0 deletions
20
databases/mysql57-server/files/patch-cmd-line-utils_libedit_vi.c
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
--- cmd-line-utils/libedit/vi.c.orig 2015-11-29 19:16:24 UTC | ||
+++ cmd-line-utils/libedit/vi.c | ||
@@ -919,7 +919,7 @@ vi_comment_out(EditLine *el, Int c __att | ||
* NB: posix implies that we should enter insert mode, however | ||
* this is against historical precedent... | ||
*/ | ||
-#if defined(__weak_reference) && !defined(__FreeBSD__) | ||
+#if defined(__weak_reference) && !defined(__FreeBSD__) && !defined(__DragonFly__) | ||
__weakref_visible char *my_get_alias_text(const char *) | ||
__weak_reference(get_alias_text); | ||
#endif | ||
@@ -928,7 +928,7 @@ protected el_action_t | ||
vi_alias(EditLine *el __attribute__((__unused__)), | ||
Int c __attribute__((__unused__))) | ||
{ | ||
-#if defined(__weak_reference) && !defined(__FreeBSD__) | ||
+#if defined(__weak_reference) && !defined(__FreeBSD__) && !defined(__DragonFly__) | ||
char alias_name[3]; | ||
char *alias_text; | ||
|
Oops, something went wrong.