Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Aug 20, 2015
1 parent 60c15c9 commit 2ccf9bb
Show file tree
Hide file tree
Showing 391 changed files with 1,490 additions and 2,394 deletions.
1 change: 1 addition & 0 deletions archivers/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -136,6 +136,7 @@
SUBDIR += pear-Horde_Compress_Fast
SUBDIR += pear-Horde_Pack
SUBDIR += pear-PHP_Archive
SUBDIR += peazip
SUBDIR += pecl-lzf
SUBDIR += pecl-phk
SUBDIR += pecl-rar
Expand Down
6 changes: 1 addition & 5 deletions archivers/file-roller/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -45,14 +45,10 @@ post-patch:
${WRKSRC}/src/fr-command-tar.c \
${WRKSRC}/src/fr-command-zip.c

.include <bsd.port.options.mk>

post-install:
.if ${PORT_OPTIONS:MDOCS}
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}/${DOCSDIR}
.endfor
.endif

.include <bsd.port.mk>
115 changes: 115 additions & 0 deletions archivers/peazip/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
# Created by: Alonso Cardenas Marquez <[email protected]>
# $FreeBSD$

PORTNAME= peazip
PORTVERSION= 5.7.1
CATEGORIES= archivers
MASTER_SITES= https://github.com/giorgiotani/PeaZip/releases/download/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src

MAINTAINER= [email protected]
COMMENT= Free archiver and file compressor

BUILD_DEPENDS= lazbuild:${PORTSDIR}/editors/lazarus \
fpcres:${PORTSDIR}/lang/fpc-utils

USES= dos2unix zip
USE_FPC= cairo fcl-base fcl-image fcl-process hash pasjpeg paszlib x11
USE_GNOME= #

SUB_FILES= pea pealauncher peazip

DOS2UNIX_REGEX= .*\.([txt]|pas|lpi|txt)
LAZARUS_PROJECT_FILES= project_pea.lpi project_peach.lpi project_gwrap.lpi
LAZBUILD_CMD= ${LOCALBASE}/bin/lazbuild -d
LCL_UNITS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}/lcl/units/${BUILDNAME}
LAZARUS_VER= 1.4.2
LAZARUS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}
ARCHIVER_FILES= #

OPTIONS_DEFINE= 7Z ARC ZPAQ UNACE
OPTIONS_SINGLE= LCL
OPTIONS_SINGLE_LCL= GTK2 QT4

7Z_DESC= 7z file archiver support
ARC_DESC= Arc file archiver support
ZPAQ_DESC= Zpaq file archiver support
UNACE_DESC= Unace file archiver support
GTK2_DESC= Use gtk20 interface
QT4_DESC= Use qt4 interface

OPTIONS_DEFAULT= GTK2 7Z

.include <bsd.port.pre.mk>

.if ${PORT_OPTIONS:MGTK2}
USE_FPC+= gtk2
USE_GNOME= gtk20
LCL_PLATFORM= gtk2
BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-gtk2
.endif

.if ${PORT_OPTIONS:MQT4}
LIB_DEPENDS+= libQt4Pas.so:${PORTSDIR}/x11-toolkits/qt4pas
LCL_PLATFORM= qt
BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-qt
.endif

.if ${PORT_OPTIONS:M7Z}
RUN_DEPENDS+= 7z:${PORTSDIR}/archivers/p7zip
ARCHIVER_FILES+=7z
PLIST_SUB+= 7Z=""
.else
PLIST_SUB+= 7Z="@comment "
.endif

.if ${PORT_OPTIONS:MARC}
RUN_DEPENDS+= arc:${PORTSDIR}/archivers/arc
ARCHIVER_FILES+=arc
PLIST_SUB+= ARC=""
.else
PLIST_SUB+= ARC="@comment "
.endif

.if ${PORT_OPTIONS:MZPAQ}
RUN_DEPENDS+= zpaq:${PORTSDIR}/archivers/paq
ARCHIVER_FILES+=zpaq
PLIST_SUB+= ZPAQ=""
.else
PLIST_SUB+= ZPAQ="@comment "
.endif

.if ${PORT_OPTIONS:MUNACE}
RUN_DEPENDS+= unace:${PORTSDIR}/archivers/unace
ARCHIVER_FILES+=unace
PLIST_SUB+= UNACE=""
.else
PLIST_SUB+= UNACE="@comment "
.endif

do-build:
.for PROJECT_FILE in ${LAZARUS_PROJECT_FILES}
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
${LAZBUILD_CMD} --ws=${LCL_PLATFORM} --lazarusdir=${LAZARUS_DIR} ${PROJECT_FILE}
.endfor

pre-install:
@${ECHO_CMD} "#" > ${WRKSRC}/altconf.txt
@${ECHO_CMD} "appdata" >> ${WRKSRC}/altconf.txt

do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/res
.for ARCHIVER in ${ARCHIVER_FILES}
@${MKDIR} ${STAGEDIR}${DATADIR}/res/${ARCHIVER}
@${LN} -s ${LOCALBASE}/bin/${ARCHIVER} ${STAGEDIR}${DATADIR}/res/${ARCHIVER}/${ARCHIVER}
.endfor
@cd ${WRKSRC}/res && ${COPYTREE_SHARE} "icons lang themes" ${STAGEDIR}${DATADIR}/res
@cd ${WRKSRC} && ${INSTALL_DATA} altconf.txt ${STAGEDIR}${DATADIR}/res && \
${INSTALL_PROGRAM} pea pealauncher ${STAGEDIR}${DATADIR}/res && \
${INSTALL_PROGRAM} peazip ${STAGEDIR}${DATADIR}
@cd ${WRKSRC}/FreeDesktop_integration && \
${INSTALL_DATA} peazip.desktop ${STAGEDIR}${DESKTOPDIR} && \
${INSTALL_DATA} peazip.png ${STAGEDIR}${PREFIX}/share/pixmaps/
${INSTALL_SCRIPT} ${WRKDIR}/pea ${WRKDIR}/pealauncher ${WRKDIR}/peazip ${STAGEDIR}${PREFIX}/bin/

.include <bsd.port.post.mk>
2 changes: 2 additions & 0 deletions archivers/peazip/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
SHA256 (peazip-5.7.1.src.zip) = d32c1427f911a03974ee619096267eaf289afe4652f9abebbf18d55971b5e5f3
SIZE (peazip-5.7.1.src.zip) = 4045028
26 changes: 26 additions & 0 deletions archivers/peazip/files/patch-peach.pas
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
--- peach.pas.orig 2015-08-10 00:54:42.122935000 -0500
+++ peach.pas 2015-08-10 00:56:11.788970000 -0500
@@ -4320,6 +4320,7 @@
APPLICATION5 = '';
APPLICATION6 = '';
APPLICATION7 = '';
+ APPLICATION8 = '';
{$ENDIF}
{$IFDEF NETBSD}
EXEEXT = '';
@@ -4330,6 +4331,7 @@
APPLICATION5 = '';
APPLICATION6 = '';
APPLICATION7 = '';
+ APPLICATION8 = '';
{$ENDIF}
{$IFDEF DARWIN}
EXEEXT = '';
@@ -4340,6 +4342,7 @@
APPLICATION5 = '';
APPLICATION6 = '';
APPLICATION7 = '';
+ APPLICATION8 = '';
{$ENDIF}

var
3 changes: 3 additions & 0 deletions archivers/peazip/files/pea.in
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
#!/bin/sh

cd %%DATADIR%%/res && exec %%DATADIR%%/res/pea "$@"
3 changes: 3 additions & 0 deletions archivers/peazip/files/pealauncher.in
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
#!/bin/sh

cd %%DATADIR%%/res && exec %%DATADIR%%/res/pealauncher "$@"
3 changes: 3 additions & 0 deletions archivers/peazip/files/peazip.in
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
#!/bin/sh

cd %%DATADIR%% && exec %%DATADIR%%/peazip "$@"
9 changes: 9 additions & 0 deletions archivers/peazip/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,9 @@
PeaZip, free archiver utility, Open Source WinRar / WinZip alternative for
Windows, Linux and FreeBSD. Compress to 7Z, ARC, BZ2, GZip, PAQ, PEA,
self-extracting archives, TAR, WIM, XZ, ZIP files. Open 150+ file types,
including ACE, CAB, DMG, ISO, RAR, UDF, ZIPX format. Extract, create and
convert archives, split / join files, strong encryption, encrypted password
manager, secure delete, find duplicate files, compute hash, export job
definition as script to automate backup / restore.

WWW: http://www.peazip.org
78 changes: 78 additions & 0 deletions archivers/peazip/pkg-plist
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
bin/pea
bin/pealauncher
bin/peazip
share/applications/peazip.desktop
share/pixmaps/peazip.png
%%DATADIR%%/peazip
%%DATADIR%%/res/altconf.txt
%%DATADIR%%/res/icons/PeaZip.ico
%%DATADIR%%/res/icons/PeaZip_7z.ico
%%DATADIR%%/res/icons/PeaZip_block.ico
%%DATADIR%%/res/icons/PeaZip_cd.ico
%%DATADIR%%/res/icons/PeaZip_package.ico
%%DATADIR%%/res/icons/PeaZip_rar.ico
%%DATADIR%%/res/icons/PeaZip_zip.ico
%%DATADIR%%/res/icons/new installer/peazip-256.bmp
%%DATADIR%%/res/icons/new installer/peazip-icon-green.ico
%%DATADIR%%/res/icons/new installer/peazip-icon-yellow.ico
%%DATADIR%%/res/icons/new installer/peazip-installer-green-16.bmp
%%DATADIR%%/res/icons/new installer/peazip-installer-green-24.bmp
%%DATADIR%%/res/icons/new installer/peazip-installer-green-256.bmp
%%DATADIR%%/res/icons/new installer/peazip-installer-green-32.bmp
%%DATADIR%%/res/icons/new installer/peazip-installer-green-48.bmp
%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-16.bmp
%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-24.bmp
%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-256.bmp
%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-32.bmp
%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-48.bmp
%%DATADIR%%/res/icons/new installer/peazip-installer.png
%%DATADIR%%/res/icons/peazip_seven.icl
%%DATADIR%%/res/lang/ar.txt
%%DATADIR%%/res/lang/bg.txt
%%DATADIR%%/res/lang/by-cr.txt
%%DATADIR%%/res/lang/by-lt.txt
%%DATADIR%%/res/lang/chs.txt
%%DATADIR%%/res/lang/cht.txt
%%DATADIR%%/res/lang/cz.txt
%%DATADIR%%/res/lang/de-uml.txt
%%DATADIR%%/res/lang/default.txt
%%DATADIR%%/res/lang/en-gb.txt
%%DATADIR%%/res/lang/en.txt
%%DATADIR%%/res/lang/es-es.txt
%%DATADIR%%/res/lang/es-la.txt
%%DATADIR%%/res/lang/eu.txt
%%DATADIR%%/res/lang/fi.txt
%%DATADIR%%/res/lang/fr.txt
%%DATADIR%%/res/lang/gl.txt
%%DATADIR%%/res/lang/gr.txt
%%DATADIR%%/res/lang/hu.txt
%%DATADIR%%/res/lang/it.txt
%%DATADIR%%/res/lang/ja.txt
%%DATADIR%%/res/lang/ko.txt
%%DATADIR%%/res/lang/nl.txt
%%DATADIR%%/res/lang/no.txt
%%DATADIR%%/res/lang/pl.txt
%%DATADIR%%/res/lang/pt-br.txt
%%DATADIR%%/res/lang/pt-pt.txt
%%DATADIR%%/res/lang/ro.txt
%%DATADIR%%/res/lang/ru.txt
%%DATADIR%%/res/lang/si.txt
%%DATADIR%%/res/lang/sk.txt
%%DATADIR%%/res/lang/sv.txt
%%DATADIR%%/res/lang/tj.txt
%%DATADIR%%/res/lang/tr.txt
%%DATADIR%%/res/lang/uk.txt
%%DATADIR%%/res/lang/uz.txt
%%DATADIR%%/res/lang/vn.txt
%%DATADIR%%/res/pea
%%DATADIR%%/res/pealauncher
%%DATADIR%%/res/themes/firecrystal.theme.7z
%%DATADIR%%/res/themes/nographic-embedded/fm-theme.bmp
%%DATADIR%%/res/themes/nographic-embedded/note.readme
%%DATADIR%%/res/themes/seven-embedded/fm-theme.bmp
%%DATADIR%%/res/themes/seven-embedded/note.readme
%%DATADIR%%/res/themes/seven.theme.7z
%%7Z%%%%DATADIR%%/res/7z/7z
%%ARC%%%%DATADIR%%/res/arc/arc
%%UNACE%%%%DATADIR%%/res/unace/unace
%%ZPAQ%%%%DATADIR%%/res/zpaq/zpaq
8 changes: 1 addition & 7 deletions archivers/php5-snappy/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,16 +23,10 @@ PHP_MODNAME= snappy
WRKSRC= ${WRKDIR}/${PROJECTHOST}
OPTIONS_DEFINE= TEST

.include <bsd.port.options.mk>
test: build
post-build-TEST-on:
@(cd ${WRKSRC} && ${MAKE} ${MAKE_ENV} NO_INTERACTION=yes ${.TARGET})

.if !empty(${PORT_OPTIONS:MTEST})
post-stage: test
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/php/${PHP_EXT_DIR}/snappy.so
.else
post-stage:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/php/${PHP_EXT_DIR}/snappy.so
.endif

.include <bsd.port.mk>
9 changes: 2 additions & 7 deletions archivers/xarchiver/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -27,14 +27,9 @@ NLS_USES= gettext
NLS_CPPFLAGS+= -I${LOCALBASE}/include
NLS_LDFLAGS+= -L${LOCALBASE}/lib

.include <bsd.port.options.mk>

post-patch:
.if empty(PORT_OPTIONS:MDOCS)
post-patch-DOCS-off:
@${REINPLACE_CMD} -e 's|doc||g' ${WRKSRC}/Makefile.in
.endif
.if empty(PORT_OPTIONS:MNLS)
post-patch-NLS-off:
@${REINPLACE_CMD} -e 's| po | |g' ${WRKSRC}/Makefile.in
.endif

.include <bsd.port.mk>
9 changes: 2 additions & 7 deletions astro/boinc-astropulse/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -42,11 +42,7 @@ X11_USE= GL=gl,glu,glut \
XORG=ice,sm,x11,xau,xcb,xext,xi,xdamage,xdmcp,xfixes,xmu,xt,xxf86vm
X11_CONFIGURE_ENABLE= graphics

.include <bsd.port.options.mk>

.if ! ${PORT_OPTIONS:MX11}
BUILD_DEPENDS+= ${LOCALBASE}/include/boinc/std_fixes.h:${PORTSDIR}/net/boinc-client
.endif
X11_BUILD_DEPENDS_OFF= ${LOCALBASE}/include/boinc/std_fixes.h:${PORTSDIR}/net/boinc-client

SETI_WORK!= cd ${.CURDIR}/../boinc-setiathome-v7 && ${MAKE} -V WRKSRC
CONFIGURE_ENV+= BOINCDIR="${NONEXISTENT}" \
Expand Down Expand Up @@ -76,9 +72,8 @@ do-install:
${INSTALL} -d ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}
${INSTALL_PROGRAM} ${WRKSRC}/${AP_BINARY} \
${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
.if ${PORT_OPTIONS:MX11}
do-install-X11-on:
${INSTALL_PROGRAM} ${WRKSRC}/ap_graphics \
${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
.endif

.include <bsd.port.mk>
16 changes: 5 additions & 11 deletions astro/boinc-setiathome-v7/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -45,16 +45,10 @@ X11_USE= GL=gl,glu,glut \
XORG=ice,sm,x11,xau,xcb,xext,xi,xdamage,xdmcp,xfixes,xmu,xt,xxf86vm
X11_CONFIGURE_ENABLE= graphics

.include <bsd.port.options.mk>
X11_BUILD_DEPENDS_OFF= ${LOCALBASE}/include/boinc/std_fixes.h:${PORTSDIR}/net/boinc-client

.if ! ${PORT_OPTIONS:MX11}
BUILD_DEPENDS+= ${LOCALBASE}/include/boinc/std_fixes.h:${PORTSDIR}/net/boinc-client
.endif

.if ${ARCH} == i386 || ${ARCH} == amd64
# comment out if world is built with clang and port with gcc
CFLAGS+= -mtune=native
.endif
CFLAGS_i386= -mtune=native
CFLAGS_amd64= -mtune=native

.if !empty(MACHINE_CPU:Maltivec)
CONFIGURE_ARGS+= --enable-altivec
Expand Down Expand Up @@ -101,8 +95,8 @@ do-install:
${INSTALL} -d ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}
${INSTALL_PROGRAM} ${WRKSRC}/client/${SETI_BINARY} \
${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
.if ${PORT_OPTIONS:MX11}
do-install-X11-on:
${INSTALL_PROGRAM} ${WRKSRC}/client/seti_graphics \
${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
.endif

.include <bsd.port.mk>
Loading

0 comments on commit 2ccf9bb

Please sign in to comment.