forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
405 changed files
with
5,852 additions
and
1,746 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_langpack_ar.tar.gz) = d996fd3d2d23df769a69325c542b2450fa2f1b400b9a4543e4fe63b14c202098 | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_langpack_ar.tar.gz) = 2256147 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_langpack_ar.tar.gz) = a3b4aad49e5f7f041e7706817df65be7070c3d2ac209e932dee211c21eb48b1f | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_langpack_ar.tar.gz) = 2256170 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
--- src/analyzer.cpp.orig 2014-10-14 18:53:15 UTC | ||
+++ src/analyzer.cpp | ||
@@ -471,12 +471,12 @@ void analyzer::draw(int subindex, float | ||
//pumping up actual signal an erase surrounding | ||
// sounds | ||
fft_outL[_iter] = 0.25f * std::max(n * 0.6f * \ | ||
- fabs(fft_outL[_iter]) - var1L , 1e-20); | ||
+ fabsf(fft_outL[_iter]) - var1L , 1e-20f); | ||
if(_mode == 3 or _mode == 4) { | ||
// do the same with R channel if needed | ||
lastoutR = fft_outR[_iter]; | ||
fft_outR[_iter] = 0.25f * std::max(n * \ | ||
- 0.6f * fabs(fft_outR[_iter]) - var1R , 1e-20); | ||
+ 0.6f * fabsf(fft_outR[_iter]) - var1R , 1e-20f); | ||
} | ||
break; | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
--- src/modules_dist.cpp.orig 2015-03-13 23:00:12 UTC | ||
+++ src/modules_dist.cpp | ||
@@ -794,8 +794,8 @@ uint32_t tapesimulator_audio_module::pro | ||
lfo2.advance(1); | ||
|
||
// dot | ||
- rms = std::max((double)rms, (fabs(Lo) + fabs(Ro)) / 2); | ||
- input = std::max((double)input, (fabs(Lc) + fabs(Rc)) / 2); | ||
+ rms = std::max(rms, (fabsf(Lo) + fabsf(Ro)) / 2); | ||
+ input = std::max(input, (fabsf(Lc) + fabsf(Rc)) / 2); | ||
|
||
float values[] = {inL, inR, outs[0][i], outs[1][i]}; | ||
meters.process(values); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
--- src/modules_limit.cpp.orig 2014-10-14 18:56:24 UTC | ||
+++ src/modules_limit.cpp | ||
@@ -429,7 +429,7 @@ uint32_t multibandlimiter_audio_module:: | ||
} | ||
|
||
// write multiband coefficient to buffer | ||
- buffer[pos] = std::min(*params[param_limit] / std::max(fabs(tmpL), fabs(tmpR)), 1.0); | ||
+ buffer[pos] = std::min(*params[param_limit] / std::max(fabsf(tmpL), fabsf(tmpR)), 1.0f); | ||
|
||
// step forward in multiband buffer | ||
pos = (pos + channels) % buffer_size; | ||
@@ -811,7 +811,7 @@ uint32_t sidechainlimiter_audio_module:: | ||
} | ||
|
||
// write multiband coefficient to buffer | ||
- buffer[pos] = std::min(*params[param_limit] / std::max(fabs(tmpL), fabs(tmpR)), 1.0); | ||
+ buffer[pos] = std::min(*params[param_limit] / std::max(fabsf(tmpL), fabsf(tmpR)), 1.0f); | ||
|
||
// step forward in multiband buffer | ||
pos = (pos + channels) % buffer_size; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
# Created by: [email protected] | ||
# $FreeBSD$ | ||
|
||
PORTNAME= diamond | ||
PORTVERSION= 0.7.12 | ||
DISTVERSIONPREFIX= v | ||
CATEGORIES= biology | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= BLAST-compatible local sequence aligner | ||
|
||
LICENSE= BSD2CLAUSE | ||
|
||
BUILD_DEPENDS= ${LOCALBASE}/include/boost:devel/boost-libs | ||
RUN_DEPENDS= ${LOCALBASE}/include/boost:devel/boost-libs | ||
|
||
ONLY_FOR_ARCHS= amd64 | ||
|
||
USES= cmake:outsource | ||
|
||
CFLAGS+= -DNDEBUG | ||
|
||
USE_GITHUB= yes | ||
GH_ACCOUNT= bbuchfink | ||
|
||
PLIST_FILES= bin/diamond | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,2 @@ | ||
SHA256 (bbuchfink-diamond-v0.7.12_GH0.tar.gz) = 16f8f618e4e5e81071ef8b66dc39685a1e969434ddeff3d88fa01091971b662f | ||
SIZE (bbuchfink-diamond-v0.7.12_GH0.tar.gz) = 1826614 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
--- CMakeLists.txt.orig 2016-03-29 09:23:52 UTC | ||
+++ CMakeLists.txt | ||
@@ -9,6 +9,7 @@ if(BUILD_STATIC) | ||
set(CMAKE_EXE_LINKER_FLAGS "-static") | ||
endif() | ||
|
||
+FIND_PACKAGE(Threads REQUIRED) | ||
find_package(Boost | ||
1.53.0 REQUIRED | ||
COMPONENTS program_options timer iostreams thread | ||
@@ -16,9 +17,6 @@ find_package(Boost | ||
|
||
find_package(ZLIB REQUIRED) | ||
|
||
-set(CMAKE_BUILD_TYPE Release) | ||
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-uninitialized") | ||
- | ||
add_subdirectory("src/algo/blast/core") | ||
include_directories( | ||
"${CMAKE_SOURCE_DIR}/src" | ||
@@ -29,6 +27,11 @@ add_executable(diamond src/main.cpp | ||
src/basic/options.cpp | ||
src/util/tinythread.cpp) | ||
|
||
-target_link_libraries(diamond blast_core ${Boost_LIBRARIES} ${ZLIB_LIBRARY}) | ||
+target_link_libraries(diamond blast_core ${Boost_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${ZLIB_LIBRARY}) | ||
|
||
install(TARGETS diamond DESTINATION bin) | ||
+ | ||
+get_cmake_property(_variableNames VARIABLES) | ||
+foreach (_variableName ${_variableNames}) | ||
+ message(STATUS "${_variableName}=${${_variableName}}") | ||
+endforeach() |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
DIAMOND is a BLAST-compatible local aligner for mapping protein and translated | ||
DNA query sequences against a protein reference database (BLASTP and BLASTX | ||
alignment mode). The speedup over BLAST is up to 20,000 on short reads at a | ||
typical sensitivity of 90-99% relative to BLAST depending on the data and | ||
settings. | ||
|
||
WWW: http://ab.inf.uni-tuebingen.de/software/diamond/ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_langpack_zh-CN.tar.gz) = 5417cb66c3697857a1a8d096725cfe239e45e3be7de8c165f1e8a61dc3b39cd8 | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_langpack_zh-CN.tar.gz) = 567927 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_helppack_zh-CN.tar.gz) = 27f7cc581da2ad46ace96bee168aab585b36921f68eb2b7a26ad3ceeceaa99f0 | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_helppack_zh-CN.tar.gz) = 10640847 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_langpack_zh-CN.tar.gz) = 06697ee5a200808d36816f19060057e33c0876afd71329d820bdc2842e0ab8db | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_langpack_zh-CN.tar.gz) = 567869 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_helppack_zh-CN.tar.gz) = 0dbfd1ecf21c12cfc229a875c463862a0528f198138f66bb92d06ae815a9b538 | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_helppack_zh-CN.tar.gz) = 10640861 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_langpack_zh-TW.tar.gz) = 0ba7f350135dee30a03b60198b3e76b6f1b8144c5a86e4afec4a7b8532fe9be7 | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_langpack_zh-TW.tar.gz) = 565116 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_helppack_zh-TW.tar.gz) = 963019456a1bc963db1670a2c55bed152b5da72ed058e6cf9ab088a3d5bf2d87 | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_helppack_zh-TW.tar.gz) = 10697230 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_langpack_zh-TW.tar.gz) = 6cb04c177f0fe68f5288a0d644a192e2a01ba6c550caef11f4c8d353f9741cfc | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_langpack_zh-TW.tar.gz) = 565073 | ||
SHA256 (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_helppack_zh-TW.tar.gz) = 66624f4c8f622bbb3563997e47408257aba6cc5e814cdf714cb8977fedf095eb | ||
SIZE (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_helppack_zh-TW.tar.gz) = 10697555 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
28 changes: 0 additions & 28 deletions
28
databases/mariadb100-client/files/patch-cmake_jemalloc.cmake
This file was deleted.
Oops, something went wrong.
11 changes: 0 additions & 11 deletions
11
databases/mariadb100-client/files/patch-extra_yassl_taocrypt_src_integer.cpp
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (mariadb-10.0.23.tar.gz) = 156eed69892834be66736aebe0a17a76d5031fd1c2f481a82228ff33bb7ba274 | ||
SIZE (mariadb-10.0.23.tar.gz) = 57394548 | ||
SHA256 (mariadb-10.0.25.tar.gz) = 4540832c18112a332f61f4eeb57140890c4e2188ae12b312f4e2e8a0363553e4 | ||
SIZE (mariadb-10.0.25.tar.gz) = 57459461 |
28 changes: 0 additions & 28 deletions
28
databases/mariadb100-server/files/patch-cmake_jemalloc.cmake
This file was deleted.
Oops, something went wrong.
Oops, something went wrong.