Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed May 7, 2016
1 parent 3ea8a6f commit 3aa4cad
Show file tree
Hide file tree
Showing 405 changed files with 5,852 additions and 1,746 deletions.
4 changes: 2 additions & 2 deletions arabic/libreoffice/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_langpack_ar.tar.gz) = d996fd3d2d23df769a69325c542b2450fa2f1b400b9a4543e4fe63b14c202098
SIZE (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_langpack_ar.tar.gz) = 2256147
SHA256 (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_langpack_ar.tar.gz) = a3b4aad49e5f7f041e7706817df65be7070c3d2ac209e932dee211c21eb48b1f
SIZE (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_langpack_ar.tar.gz) = 2256170
2 changes: 1 addition & 1 deletion audio/calf/files/patch-src__calf__audio_fx.h
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
--- src/calf/audio_fx.h.orig
--- src/calf/audio_fx.h.orig 2015-03-13 23:00:12 UTC
+++ src/calf/audio_fx.h
@@ -27,6 +27,7 @@
#include "inertia.h"
Expand Down
2 changes: 1 addition & 1 deletion audio/calf/files/patch-src__calf__osctl.h
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
--- src/calf/osctl.h.orig
--- src/calf/osctl.h.orig 2014-01-26 21:24:40 UTC
+++ src/calf/osctl.h
@@ -26,7 +26,10 @@
#include <vector>
Expand Down
17 changes: 17 additions & 0 deletions audio/calf/files/patch-src_analyzer.cpp
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
--- src/analyzer.cpp.orig 2014-10-14 18:53:15 UTC
+++ src/analyzer.cpp
@@ -471,12 +471,12 @@ void analyzer::draw(int subindex, float
//pumping up actual signal an erase surrounding
// sounds
fft_outL[_iter] = 0.25f * std::max(n * 0.6f * \
- fabs(fft_outL[_iter]) - var1L , 1e-20);
+ fabsf(fft_outL[_iter]) - var1L , 1e-20f);
if(_mode == 3 or _mode == 4) {
// do the same with R channel if needed
lastoutR = fft_outR[_iter];
fft_outR[_iter] = 0.25f * std::max(n * \
- 0.6f * fabs(fft_outR[_iter]) - var1R , 1e-20);
+ 0.6f * fabsf(fft_outR[_iter]) - var1R , 1e-20f);
}
break;
}
13 changes: 13 additions & 0 deletions audio/calf/files/patch-src_modules__dist.cpp
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
--- src/modules_dist.cpp.orig 2015-03-13 23:00:12 UTC
+++ src/modules_dist.cpp
@@ -794,8 +794,8 @@ uint32_t tapesimulator_audio_module::pro
lfo2.advance(1);

// dot
- rms = std::max((double)rms, (fabs(Lo) + fabs(Ro)) / 2);
- input = std::max((double)input, (fabs(Lc) + fabs(Rc)) / 2);
+ rms = std::max(rms, (fabsf(Lo) + fabsf(Ro)) / 2);
+ input = std::max(input, (fabsf(Lc) + fabsf(Rc)) / 2);

float values[] = {inL, inR, outs[0][i], outs[1][i]};
meters.process(values);
20 changes: 20 additions & 0 deletions audio/calf/files/patch-src_modules__limit.cpp
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
--- src/modules_limit.cpp.orig 2014-10-14 18:56:24 UTC
+++ src/modules_limit.cpp
@@ -429,7 +429,7 @@ uint32_t multibandlimiter_audio_module::
}

// write multiband coefficient to buffer
- buffer[pos] = std::min(*params[param_limit] / std::max(fabs(tmpL), fabs(tmpR)), 1.0);
+ buffer[pos] = std::min(*params[param_limit] / std::max(fabsf(tmpL), fabsf(tmpR)), 1.0f);

// step forward in multiband buffer
pos = (pos + channels) % buffer_size;
@@ -811,7 +811,7 @@ uint32_t sidechainlimiter_audio_module::
}

// write multiband coefficient to buffer
- buffer[pos] = std::min(*params[param_limit] / std::max(fabs(tmpL), fabs(tmpR)), 1.0);
+ buffer[pos] = std::min(*params[param_limit] / std::max(fabsf(tmpL), fabsf(tmpR)), 1.0f);

// step forward in multiband buffer
pos = (pos + channels) % buffer_size;
1 change: 1 addition & 0 deletions biology/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -21,6 +21,7 @@
SUBDIR += clustalw
SUBDIR += consed
SUBDIR += crux
SUBDIR += diamond
SUBDIR += emboss
SUBDIR += fasta
SUBDIR += fasta3
Expand Down
28 changes: 28 additions & 0 deletions biology/diamond/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Created by: [email protected]
# $FreeBSD$

PORTNAME= diamond
PORTVERSION= 0.7.12
DISTVERSIONPREFIX= v
CATEGORIES= biology

MAINTAINER= [email protected]
COMMENT= BLAST-compatible local sequence aligner

LICENSE= BSD2CLAUSE

BUILD_DEPENDS= ${LOCALBASE}/include/boost:devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/include/boost:devel/boost-libs

ONLY_FOR_ARCHS= amd64

USES= cmake:outsource

CFLAGS+= -DNDEBUG

USE_GITHUB= yes
GH_ACCOUNT= bbuchfink

PLIST_FILES= bin/diamond

.include <bsd.port.mk>
2 changes: 2 additions & 0 deletions biology/diamond/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
SHA256 (bbuchfink-diamond-v0.7.12_GH0.tar.gz) = 16f8f618e4e5e81071ef8b66dc39685a1e969434ddeff3d88fa01091971b662f
SIZE (bbuchfink-diamond-v0.7.12_GH0.tar.gz) = 1826614
33 changes: 33 additions & 0 deletions biology/diamond/files/patch-CMakeLists.txt
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
--- CMakeLists.txt.orig 2016-03-29 09:23:52 UTC
+++ CMakeLists.txt
@@ -9,6 +9,7 @@ if(BUILD_STATIC)
set(CMAKE_EXE_LINKER_FLAGS "-static")
endif()

+FIND_PACKAGE(Threads REQUIRED)
find_package(Boost
1.53.0 REQUIRED
COMPONENTS program_options timer iostreams thread
@@ -16,9 +17,6 @@ find_package(Boost

find_package(ZLIB REQUIRED)

-set(CMAKE_BUILD_TYPE Release)
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-uninitialized")
-
add_subdirectory("src/algo/blast/core")
include_directories(
"${CMAKE_SOURCE_DIR}/src"
@@ -29,6 +27,11 @@ add_executable(diamond src/main.cpp
src/basic/options.cpp
src/util/tinythread.cpp)

-target_link_libraries(diamond blast_core ${Boost_LIBRARIES} ${ZLIB_LIBRARY})
+target_link_libraries(diamond blast_core ${Boost_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${ZLIB_LIBRARY})

install(TARGETS diamond DESTINATION bin)
+
+get_cmake_property(_variableNames VARIABLES)
+foreach (_variableName ${_variableNames})
+ message(STATUS "${_variableName}=${${_variableName}}")
+endforeach()
7 changes: 7 additions & 0 deletions biology/diamond/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
DIAMOND is a BLAST-compatible local aligner for mapping protein and translated
DNA query sequences against a protein reference database (BLASTP and BLASTX
alignment mode). The speedup over BLAST is up to 20,000 on short reads at a
typical sensitivity of 90-99% relative to BLAST depending on the data and
settings.

WWW: http://ab.inf.uni-tuebingen.de/software/diamond/
8 changes: 4 additions & 4 deletions chinese/libreoffice-zh_CN/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
SHA256 (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_langpack_zh-CN.tar.gz) = 5417cb66c3697857a1a8d096725cfe239e45e3be7de8c165f1e8a61dc3b39cd8
SIZE (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_langpack_zh-CN.tar.gz) = 567927
SHA256 (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_helppack_zh-CN.tar.gz) = 27f7cc581da2ad46ace96bee168aab585b36921f68eb2b7a26ad3ceeceaa99f0
SIZE (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_helppack_zh-CN.tar.gz) = 10640847
SHA256 (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_langpack_zh-CN.tar.gz) = 06697ee5a200808d36816f19060057e33c0876afd71329d820bdc2842e0ab8db
SIZE (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_langpack_zh-CN.tar.gz) = 567869
SHA256 (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_helppack_zh-CN.tar.gz) = 0dbfd1ecf21c12cfc229a875c463862a0528f198138f66bb92d06ae815a9b538
SIZE (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_helppack_zh-CN.tar.gz) = 10640861
8 changes: 4 additions & 4 deletions chinese/libreoffice-zh_TW/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
SHA256 (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_langpack_zh-TW.tar.gz) = 0ba7f350135dee30a03b60198b3e76b6f1b8144c5a86e4afec4a7b8532fe9be7
SIZE (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_langpack_zh-TW.tar.gz) = 565116
SHA256 (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_helppack_zh-TW.tar.gz) = 963019456a1bc963db1670a2c55bed152b5da72ed058e6cf9ab088a3d5bf2d87
SIZE (libreoffice/i18n/LibreOffice_5.0.5_Linux_x86_deb_helppack_zh-TW.tar.gz) = 10697230
SHA256 (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_langpack_zh-TW.tar.gz) = 6cb04c177f0fe68f5288a0d644a192e2a01ba6c550caef11f4c8d353f9741cfc
SIZE (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_langpack_zh-TW.tar.gz) = 565073
SHA256 (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_helppack_zh-TW.tar.gz) = 66624f4c8f622bbb3563997e47408257aba6cc5e814cdf714cb8977fedf095eb
SIZE (libreoffice/i18n/LibreOffice_5.0.6_Linux_x86_deb_helppack_zh-TW.tar.gz) = 10697555
2 changes: 2 additions & 0 deletions databases/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -937,6 +937,8 @@
SUBDIR += sqldeveloper
SUBDIR += sqlite-ext-miscfuncs
SUBDIR += sqlite-ext-pcre
SUBDIR += sqlite-ext-regexp
SUBDIR += sqlite-ext-spellfix
SUBDIR += sqlite2
SUBDIR += sqlite3
SUBDIR += sqlitebrowser
Expand Down
28 changes: 0 additions & 28 deletions databases/mariadb100-client/files/patch-cmake_jemalloc.cmake

This file was deleted.

This file was deleted.

64 changes: 38 additions & 26 deletions databases/mariadb100-server/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME?= mariadb
PORTVERSION= 10.0.23
PORTVERSION= 10.0.25
CATEGORIES= databases ipv6
MASTER_SITES= http://ftp.osuosl.org/pub/${SITESDIR}/ \
http://mirrors.supportex.net/${SITESDIR}/ \
Expand All @@ -24,23 +24,18 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message

SLAVEDIRS= databases/mariadb100-client
USES= bison:build cmake cpe execinfo gmake shebangfix
USES= bison:build cmake compiler:c++11-lib cpe execinfo gmake shebangfix
USE_LDCONFIG= ${PREFIX}/lib/mysql ${PREFIX}/lib/mysql/plugin
SHEBANG_FILES= scripts/*.sh
SITESDIR= mariadb/mariadb-${PORTVERSION}/source

OPTIONS_DEFINE= FASTMTX
OPTIONS_RADIO= SSL
OPTIONS_RADIO_SSL= BUNDLED_SSL OPENSSL WITHOUT_SSL
OPTIONS_DEFAULT+= OPENSSL
NO_OPTIONS_SORT= yes

BUNDLED_SSL_DESC= SSL/TLS support via (bundled) CyaSSL
FASTMTX_DESC= Replace mutexes with spinlocks
WITHOUT_SSL_DESC= No SSL/TLS support

CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mysql" \
-DINSTALL_DOCREADMEDIR="share/doc/mysql" \
CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mariadb" \
-DINSTALL_DOCREADMEDIR="share/doc/mariadb" \
-DINSTALL_INCLUDEDIR="include/mysql" \
-DINSTALL_INFODIR="info" \
-DINSTALL_LIBDIR="lib/mysql" \
Expand All @@ -56,6 +51,7 @@ CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mysql" \
-DINSTALL_SUPPORTFILESDIR="share/mysql" \
-DWITH_UNIT_TESTS=0 \
-DWITH_LIBEDIT=0 \
-DWITH_SSL=${OPENSSLBASE} \
-DWITH_LIBWRAP=1 \
-DEXECINFO_ROOT=${LOCALBASE} \
-DCOMPILATION_COMMENT="FreeBSD Ports"
Expand All @@ -73,47 +69,55 @@ CONFLICTS_INSTALL= mariadb5*-${PKGNAMESUFFIX:C/^[0-9]*-//}-* \

.if !defined(CLIENT_ONLY)
# MySQL-Server options
USE_MYSQL= yes
USE_LDCONFIG+= ${PREFIX}/lib/mysql/plugin
OPTIONS_DEFINE+= INNODB MAXKEY MROONGA OQGRAPH
OPTIONS_DEFINE+= MAXKEY
OPTIONS_DEFAULT+= MAXKEY
OPTIONS_SUB= yes
OPTIONS_GROUP= ENGINES
OPTIONS_GROUP_ENGINES= INNOBASE MROONGA OQGRAPH SPHINX SPIDER TOKUDB

ENGINES_DESC= Optional MariaDB storage engines
INNOBASE_DESC= Build InnoDB engine next to XtraDB
MAXKEY_DESC= Change max key length from 1000 to 4000
MROONGA_DESC= Mroonga Full Text Search engine
OQGRAPH_DESC= Open Query Graph Computation engine (Requires GCC)
SPHINX_DESC= SphinxSE engine
SPIDER_DESC= Partitioning and XA-transactions engine
TOKUDB_DESC= Fractal tree index tree data structure engine

OPTIONS_SUB= yes

TOKUDB_PORTDOCS= PATENTS README.md

INNODB_DESC= Build InnoDB engine next to XtraDB
MAXKEY_DESC= Change max key length from 1000 to 4000
MROONGA_DESC= Mroonga Full Text Search engine (gcc)
OQGRAPH_DESC= Open Query Graph Computation engine (gcc)
.endif

BUNDLED_SSL_CMAKE_ON= -DWITH_SSL=bundled
FASTMTX_CMAKE_ON= -DWITH_FAST_MUTEXES=1
OPENSSL_CMAKE_ON= -DWITH_SSL=yes
OPENSSL_USE= OPENSSL=yes
WITHOUT_SSL_CMAKE_ON= -DWITH_SSL=no
USE_OPENSSL= yes

.if defined(CLIENT_ONLY)
# MySQL-Client part
USES+= readline
.else
# MySQL-Server part
USE_MYSQL= yes
WANT_MYSQL_VER= 100m
USES+= mysql:100m
USE_RC_SUBR= mysql-server
USERS= mysql
GROUPS= mysql
CMAKE_ARGS+= -DWITH_EMBEDDED_SERVER="ON" \
-DCMAKE_SKIP_BUILD_RPATH:BOOL=YES \
-DWITHOUT_EXAMPLE_STORAGE_ENGINE=1

INNODB_CMAKE_OFF= -DWITHOUT_INNOBASE=1
.for ENGINE in ${OPTIONS_GROUP_ENGINES}
${ENGINE}_CMAKE_OFF= -DWITHOUT_${ENGINE}=1
.endfor

MAXKEY_EXTRA_PATCHES+= ${FILESDIR}/extra-patch-include_my__compare.h
MROONGA_CMAKE_OFF= -DWITHOUT_MROONGA=1
OQGRAPH_LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libJudy.so:devel/judy
# Currently OQGraph does not build using clang.
# See See https://mariadb.atlassian.net/browse/MDEV-8051.
OQGRAPH_USE= gcc
OQGRAPH_BROKEN= does not build
OQGRAPH_BROKEN= OQGraph does not build

post-install:
# Remove programs to avoid conflict with mariadb100-client
Expand All @@ -122,7 +126,9 @@ post-install:
${RM} ${STAGEDIR}${PREFIX}/bin/msql2mysql \
${STAGEDIR}${PREFIX}/bin/mysql_config \
${STAGEDIR}${PREFIX}/bin/mysql_find_rows \
${STAGEDIR}${PREFIX}/bin/mysqlaccess
${STAGEDIR}${PREFIX}/bin/mysqlaccess \
${STAGEDIR}${DOCSDIR}/COPYING.AGPLv3 \
${STAGEDIR}${DOCSDIR}/COPYING.GPLv2
.endif

.include <bsd.port.pre.mk>
Expand All @@ -133,8 +139,14 @@ CMAKE_ARGS+= -DWITH_JEMALLOC="system"
CMAKE_ARGS+= -DWITH_JEMALLOC="no"
.endif

# Server segfaults on i386 when built with clang >= 3.4
.if ${PORT_OPTIONS:MTOKUDB}
NOT_FOR_ARCHS= i386
NOT_FOR_ARCHS_REASON= TokuDB not supported on 32-bit platforms, see \
https://github.com/percona/PerconaFT/blob/master/README.md
.endif

.if ${ARCH} == 'i386' && ${OSVERSION} >= 1001000
# Server segfaults on i386 when built with clang >= 3.4
USE_GCC= yes
.endif

Expand Down
4 changes: 2 additions & 2 deletions databases/mariadb100-server/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (mariadb-10.0.23.tar.gz) = 156eed69892834be66736aebe0a17a76d5031fd1c2f481a82228ff33bb7ba274
SIZE (mariadb-10.0.23.tar.gz) = 57394548
SHA256 (mariadb-10.0.25.tar.gz) = 4540832c18112a332f61f4eeb57140890c4e2188ae12b312f4e2e8a0363553e4
SIZE (mariadb-10.0.25.tar.gz) = 57459461
28 changes: 0 additions & 28 deletions databases/mariadb100-server/files/patch-cmake_jemalloc.cmake

This file was deleted.

Loading

0 comments on commit 3aa4cad

Please sign in to comment.