Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Feb 7, 2016
1 parent 31879e0 commit 40cd0eb
Show file tree
Hide file tree
Showing 552 changed files with 18,258 additions and 3,969 deletions.
3 changes: 2 additions & 1 deletion audio/cd-console/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,8 @@ MASTER_SITES= http://www.oskusoft.com/osku/cd-console/
MAINTAINER= [email protected]
COMMENT= Curses-based console CD player

MAKE_ARGS= BINPATH=${STAGEDIR}${PREFIX}/bin
USES= ncurses
MAKE_ARGS= BINPATH=${STAGEDIR}${PREFIX}/bin LIBS="${LDFLAGS} -lncurses"

PLIST_FILES= bin/cd-console

Expand Down
17 changes: 13 additions & 4 deletions audio/cmp3/files/patch-Makefile.in
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- Makefile.in.orig 2001-07-29 07:43:49.000000000 +0200
+++ Makefile.in 2014-05-08 00:46:44.189113048 +0200
--- Makefile.in.orig 2001-07-29 05:43:49 UTC
+++ Makefile.in
@@ -5,19 +5,19 @@
# initial_directory is now set in the config file
mpg123_location := "mpg123"
Expand All @@ -23,7 +23,7 @@

## Define this for bufferring or add other parameters to mpg123 and ogg123
mpg123_params := -b 320
@@ -35,14 +35,14 @@
@@ -35,14 +35,14 @@ ogg123_params := -d oss

VERSION="2.0pre6"
WKGDIR=cmp3-kenrevs
Expand All @@ -41,7 +41,16 @@
CC= @CC@
OBJS= cmp3common.o cmp3fileio.o cmp3manager.o cmp3curses.o \
cmp3llist.o cmp3main.o cmp3listfiles.o cmp3playlist.o cmp3volume.o \
@@ -103,7 +103,7 @@
@@ -83,7 +83,7 @@ shmdump: cmp3shmdump.c
$(CC) $(CFLAGS) cmp3shmdump.c -o cmp3shmdump

cmp3: lib $(OBJS)
- $(CC) $(CFLAGS) $(OBJS) nevlib/libnev.a $(LIBS) -o cmp3
+ $(CC) $(CFLAGS) $(OBJS) nevlib/libnev.a $(LDFLAGS) $(LIBS) -o cmp3

lib:
@$(MAKE) -C nevlib lib
@@ -103,7 +103,7 @@ tar: distclean
install: rnmp3 cmp3
install -c -s cmp3 $(install_directory)/cmp3
install -c -s rnmp3 $(install_directory)/rnmp3
Expand Down
11 changes: 11 additions & 0 deletions audio/cmp3/files/patch-cmp3.h
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- cmp3.h.orig 2001-07-01 06:38:08.000000000 +0200
+++ cmp3.h
@@ -1,7 +1,7 @@
#ifndef _CMP3_H
#define _CMP3_H

-#if defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__DragonFly__)
#include <ncurses.h>
#include <termios.h>
#else
8 changes: 3 additions & 5 deletions audio/csound6/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,7 +12,8 @@ DIST_SUBDIR= csound
MAINTAINER= [email protected]
COMMENT= Sound synthesizer

LICENSE= LGPL21
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING

BUILD_DEPENDS= boost-libs>0:${PORTSDIR}/devel/boost-libs \
swig>2:${PORTSDIR}/devel/swig20 \
Expand All @@ -21,7 +22,7 @@ BUILD_DEPENDS= boost-libs>0:${PORTSDIR}/devel/boost-libs \
LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
libsndfile.so:${PORTSDIR}/audio/libsndfile

USES= bison cmake python:2
USES= bison cmake localbase python:2
CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
-DBUILD_JAVA_INTERFACE:BOOL=OFF \
-DBUILD_P5GLOVE_OPCODES:BOOL=OFF \
Expand All @@ -33,9 +34,6 @@ CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
USE_LDCONFIG= yes
SSP_UNSAFE= yes

CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib

SUB_FILES= pkg-message

CONFLICTS= csound-5.*
Expand Down
12 changes: 12 additions & 0 deletions audio/csound6/files/patch-Opcodes_chua_ChuaOscillator.cpp
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
--- Opcodes/chua/ChuaOscillator.cpp.orig 2015-09-29 11:13:27 UTC
+++ Opcodes/chua/ChuaOscillator.cpp
@@ -117,8 +117,8 @@
// d = sys_variables(12);
// gnor = a*(x.^3) + b*(x.^2) + c*x + d;

-#include <OpcodeBase.hpp>
#include <boost/numeric/ublas/vector.hpp>
+#include <OpcodeBase.hpp>
using namespace boost::numeric;
#include <cmath>

2 changes: 1 addition & 1 deletion audio/funktrackergold/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ OPTIONS_DEFINE= DOCS

LICENSE= GPLv2

USES= compiler:nestedfct tar:tgz
USES= compiler:nestedfct ncurses tar:tgz

WRKSRC= ${WRKDIR}/funkgold
MAKE_ARGS= EXTRA_LDFLAGS="-lpthread"
Expand Down
1 change: 1 addition & 0 deletions audio/juke/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -10,6 +10,7 @@ MASTER_SITES= http://www.moll.no/oyvind/distfiles/ \
MAINTAINER= [email protected]
COMMENT= Simple (n)curses based juke box program

USES= ncurses
GNU_CONFIGURE= yes

SUB_FILES= pkg-message
Expand Down
5 changes: 4 additions & 1 deletion audio/ksmp3play/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libsmpeg.so:${PORTSDIR}/multimedia/smpeg

GNU_CONFIGURE= yes
USES= pathfix
USES= ncurses pathfix
USE_SDL= sdl
NO_WRKSUBDIR= yes
EXTRACT_AFTER_ARGS= --exclude CVS
Expand All @@ -26,6 +26,9 @@ LDFLAGS+= -L${LOCALBASE}/lib

OPTIONS_DEFINE= DOCS

post-patch:
${REINPLACE_CMD} -e 's|-lcurses|-lncurses|' ${WRKSRC}/configure

post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
Expand Down
4 changes: 3 additions & 1 deletion audio/libnjb/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@ COMMENT= C library, API for communicating with Creative and Dell audio players
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE

USES= pathfix libtool
USES= pathfix ncurses libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
Expand All @@ -33,5 +33,7 @@ post-patch:
'/^SHOW_DIRECTORIES/d' ${WRKSRC}/doc/Doxyfile.in
@${REINPLACE_CMD} -e \
'/pkgdocdir/s|-$$(VERSION)||g' ${WRKSRC}/doc/Makefile.in
@${REINPLACE_CMD} -e 's|-lcurses|-lncurses|' ${WRKSRC}/configure \
${WRKSRC}/sample/Makefile.am ${WRKSRC}/sample/Makefile.in

.include <bsd.port.mk>
2 changes: 1 addition & 1 deletion audio/mikmod/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ LICENSE= GPLv2

LIB_DEPENDS= libmikmod.so:${PORTSDIR}/audio/libmikmod

USES= gmake
USES= gmake ncurses
GNU_CONFIGURE= yes

PLIST_FILES= bin/mikmod \
Expand Down
2 changes: 1 addition & 1 deletion audio/moc/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING

LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl

USES= gmake libtool pkgconfig tar:bzip2
USES= gmake libtool ncurses pkgconfig tar:bzip2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_BDB= yes
Expand Down
1 change: 1 addition & 0 deletions audio/mp-player/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -14,6 +14,7 @@ LICENSE= GPLv2

LIB_DEPENDS= libmikmod.so:${PORTSDIR}/audio/libmikmod

USES= ncurses
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lmikmod -lpthread -lncurses -lpanel
DEFINES= -D_REENTRANT
Expand Down
2 changes: 1 addition & 1 deletion audio/mp3blaster/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= [email protected]
COMMENT= MP3 console ncurses-based player

USES= gmake
USES= gmake ncurses
GNU_CONFIGURE= yes
WANT_GNOME= yes
CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS}"
Expand Down
1 change: 1 addition & 0 deletions audio/mp3c/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -16,6 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= mp3info:${PORTSDIR}/audio/mp3info \
cdrecord:${PORTSDIR}/sysutils/cdrtools

USES= ncurses
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=${PREFIX}"

Expand Down
1 change: 1 addition & 0 deletions audio/napster/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,6 +11,7 @@ COMMENT?= MP3 sharing, search, and chat client for the OpenNAP network

CONFLICTS?= ru-nap-*

USES= ncurses
GNU_CONFIGURE= yes

OPTIONS_DEFINE= DOCS
Expand Down
27 changes: 14 additions & 13 deletions audio/pd/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,6 +2,7 @@
# $FreeBSD$

PORTNAME= pd
PORTREVISION= 1
DISTVERSION= 0.46-7
DISTVERSIONSUFFIX= .src
CATEGORIES= audio
Expand Down Expand Up @@ -41,49 +42,49 @@ JACK_CONFIGURE_ENABLE= jack
JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack

post-patch:
@${FIND} ${PATCH_WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
${FIND} ${PATCH_WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
's|__FreeBSD_kernel__|__FreeBSD__|g ; \
s|__x86_64__|__amd64__|g ; \
s|<alloca\.h>|<stdlib.h>|g'
@${REINPLACE_CMD} -e \
${REINPLACE_CMD} -e \
's|\*kfreebsd\*gnu\*)|*freebsd*)| ; \
s|portaudio=yes|portaudio=no| ; \
s|-O3||' ${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e \
${REINPLACE_CMD} -e \
'/^pkgconfigdir/s|=.*|= $$(prefix)/libdata/pkgconfig| ; \
/^libpddir/s|=.*|= $$(pkglibdir)| ; \
s|make -C|$$(MAKE) -C|' ${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e \
${REINPLACE_CMD} -e \
'/^pd_LDADD/s| =.*| = $$(LIBM)|' ${WRKSRC}/src/Makefile.am
@${REINPLACE_CMD} -e \
${REINPLACE_CMD} -e \
's|PD_BASEDIR/LICENSE|${DOCSDIR}/LICENSE|g ; \
s|PD_BASEDIR/doc/1|${DOCSDIR}/1|g' \
${WRKSRC}/doc/1.manual/1.introduction.txt
@${REINPLACE_CMD} -e \
${REINPLACE_CMD} -e \
's|-O2 | | ; \
s|-lc ||g' ${WRKSRC}/extra/makefile.subdir
@${REINPLACE_CMD} -e \
${REINPLACE_CMD} -e \
's|-O2 |$$(CFLAGS) | ; \
s|-g ||g ; \
s|-lc ||g' ${WRKSRC}/extra/expr~/makefile
@${REINPLACE_CMD} -e \
${REINPLACE_CMD} -e \
'/libpthread/s|_ERROR|_WARN|' ${WRKSRC}/portaudio/configure.in

do-install:
.for i in src man tcl po extra
@(cd ${WRKSRC}/${i} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
(cd ${WRKSRC}/${i} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
.endfor
(cd ${WRKSRC} && ${INSTALL_DATA} pd.pc \
${STAGEDIR}${PREFIX}/libdata/pkgconfig)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(${TAR} -C ${WRKSRC}/doc --exclude "*.bak" --exclude "*.orig" \
${MKDIR} ${STAGEDIR}${DOCSDIR}
(${TAR} -C ${WRKSRC}/doc --exclude "*.bak" --exclude "*.orig" \
-cf - . | ${TAR} -C ${STAGEDIR}${DOCSDIR} --unlink -xf -)
.for i in LICENSE.txt README.txt
(cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
.endfor
@${LN} -sf ${DOCSDIR} ${STAGEDIR}${PREFIX}/lib/pd/doc
@${FIND} ${STAGEDIR}${PREFIX}/lib/pd -name "*.pd_linux" | ${XARGS} \
${LN} -sf ${DOCSDIR} ${STAGEDIR}${PREFIX}/lib/pd/doc
${FIND} ${STAGEDIR}${PREFIX}/lib/pd -name "*.pd_linux" | ${XARGS} \
${STRIP_CMD}

.include <bsd.port.mk>
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/s_audio_alsa.c.orig 2011-11-07 13:06:38.000000000 +0900
+++ src/s_audio_alsa.c 2012-02-26 03:12:50.000000000 +0900
--- src/s_audio_alsa.c.orig 2014-09-18 00:09:56 UTC
+++ src/s_audio_alsa.c
@@ -25,7 +25,14 @@
#include <sched.h>
#include <sys/mman.h>
Expand Down
34 changes: 34 additions & 0 deletions audio/pd/files/patch-src_s__loader.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
--- src/s_loader.c.orig 2014-08-18 00:35:53 UTC
+++ src/s_loader.c
@@ -2,7 +2,7 @@
* For information on usage and redistribution, and for a DISCLAIMER OF ALL
* WARRANTIES, see the file, "LICENSE.txt," in this distribution. */

-#ifdef HAVE_LIBDL
+#if defined(HAVE_LIBDL) || defined(__FreeBSD__)
#include <dlfcn.h>
#endif
#ifdef HAVE_UNISTD_H
@@ -37,11 +37,9 @@ objects. The specific name is the lette
darwin, or microsoft, followed by a more specific string, either "fat" for
a fat binary or an indication of the instruction set. */

-#ifdef __FreeBSD__
-static char sys_dllextent[] = ".b_i386", sys_dllextent2[] = ".pd_freebsd";
-#elif defined(__linux__) || defined(__FreeBSD_kernel__) || defined(__GNU__)
+#if defined(__linux__) || defined(__FreeBSD__) || defined(__GNU__) || defined(__FreeBSD__)
static char sys_dllextent2[] = ".pd_linux";
-# ifdef __x86_64__
+# ifdef __amd64__
static char sys_dllextent[] = ".l_ia64"; // this should be .l_x86_64 or .l_amd64
# elif defined(__i386__) || defined(_M_IX86)
static char sys_dllextent[] = ".l_i386";
@@ -216,7 +214,7 @@ gotone:
makeout = (t_xxx)GetProcAddress(ntdll, "setup");
SetDllDirectory(NULL); /* reset DLL dir to nothing */
}
-#elif defined HAVE_LIBDL
+#elif defined(HAVE_LIBDL) || defined(__FreeBSD__)
dlobj = dlopen(filename, RTLD_NOW | RTLD_GLOBAL);
if (!dlobj)
{
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- src/s_main.c.orig 2011-03-07 10:11:02.000000000 +0900
+++ src/s_main.c 2011-04-06 19:30:04.000000000 +0900
@@ -936,7 +940,11 @@
--- src/s_main.c.orig 2015-09-09 23:08:21 UTC
+++ src/s_main.c
@@ -1137,7 +1137,11 @@ static void sys_afterargparse(void)
/* add "doc/5.reference" library to helppath */
strncpy(sbuf, sys_libdir->s_name, MAXPDSTRING-30);
sbuf[MAXPDSTRING-30] = 0;
Expand Down
1 change: 1 addition & 0 deletions audio/playmidi/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,6 +12,7 @@ COMMENT= MIDI player

LICENSE= GPLv2

USES= ncurses
WRKSRC= ${WRKDIR}/${PORTNAME}-2.4

ONLY_FOR_ARCHS= i386 amd64
Expand Down
27 changes: 15 additions & 12 deletions audio/siren/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,13 +12,13 @@ COMMENT= Text-based audio player
LICENSE= ISCL

LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac \
libid3tag.so:${PORTSDIR}/audio/libid3tag \
libmad.so:${PORTSDIR}/audio/libmad \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libwavpack.so:${PORTSDIR}/audio/wavpack \
libopusfile.so:${PORTSDIR}/audio/opusfile
libid3tag.so:${PORTSDIR}/audio/libid3tag \
libmad.so:${PORTSDIR}/audio/libmad \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libwavpack.so:${PORTSDIR}/audio/wavpack \
libopusfile.so:${PORTSDIR}/audio/opusfile

USES= ncurses pkgconfig
USES= ncurses pkgconfig
HAS_CONFIGURE= yes
USE_CSTD= c99

Expand All @@ -31,12 +31,15 @@ PULSEAUDIO_CONFIGURE_ON= oss=no pulse=yes
OPTIONS_SUB= yes

CONFIGURE_ARGS= sndfile=no \
alsa=no \
ao=no \
sndio=no \
sun=no \
portaudio=no \
aac=no
alsa=no \
ao=no \
sndio=no \
sun=no \
portaudio=no \
aac=no

post-patch:
@${REINPLACE_CMD} -e 's|-lcurses|-lncurses|' ${WRKSRC}/configure

post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/siren
Expand Down
Loading

0 comments on commit 40cd0eb

Please sign in to comment.