forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
148 changed files
with
1,822 additions
and
2,162 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,25 +1,23 @@ | ||
# Created by: gahr | ||
# Created by: Pietro Cerutti <gahr@FreeBSD.org> | ||
# $FreeBSD$ | ||
|
||
PORTNAME= libebur128 | ||
PORTVERSION= 1.0.1 | ||
PORTVERSION= 1.0.2 | ||
DISTVERSIONPREFIX= v | ||
PORTREVISION= 1 | ||
CATEGORIES= audio | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Implementation of the EBU R128 loudness standard | ||
|
||
LICENSE= MIT | ||
LICENSE_FILE= ${WRKSRC}/COPYING | ||
|
||
LIB_DEPENDS= libspeexdsp.so:${PORTSDIR}/audio/speexdsp | ||
|
||
USES= cmake:outsource pkgconfig | ||
|
||
USE_GITHUB= yes | ||
GH_ACCOUNT= jiixyj | ||
|
||
PLIST_SUB+= VER1=${PORTVERSION:R:R} \ | ||
VER3=${PORTVERSION} | ||
USES= cmake:outsource pkgconfig | ||
USE_LDCONFIG= yes | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (jiixyj-libebur128-v1.0.1_GH0.tar.gz) = 01aa7aed90c593944eeb3087a6f965557dc708de360bf1a589b3babb021e7336 | ||
SIZE (jiixyj-libebur128-v1.0.1_GH0.tar.gz) = 29760 | ||
SHA256 (jiixyj-libebur128-v1.0.2_GH0.tar.gz) = 9b334d31a26b47ba6740bb7bbee7a24461d535f426b1ed42368c187e27c08323 | ||
SIZE (jiixyj-libebur128-v1.0.2_GH0.tar.gz) = 29794 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
libebur128 is a library that implements the EBU R 128 standard for loudness | ||
normalisation. | ||
normalization. | ||
|
||
WWW: https://github.com/jiixyj/libebur128 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,5 @@ | ||
include/ebur128.h | ||
lib/libebur128.a | ||
lib/libebur128.so | ||
lib/libebur128.so.%%VER1%% | ||
lib/libebur128.so.%%VER3%% | ||
lib/libebur128.so.1 | ||
lib/libebur128.so.1.0.1 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,28 +2,28 @@ | |
# $FreeBSD$ | ||
|
||
PORTNAME= libgroove | ||
PORTVERSION= 4.1.1 | ||
PORTREVISION= 2 | ||
PORTVERSION= 4.2.1 | ||
CATEGORIES= audio | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Audio dispatching library | ||
|
||
LICENSE= MIT | ||
LICENSE_FILE= ${WRKSRC}/LICENSE | ||
|
||
LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \ | ||
libchromaprint.so:${PORTSDIR}/audio/chromaprint \ | ||
libchromaprint.so:${PORTSDIR}/audio/chromaprint \ | ||
libebur128.so:${PORTSDIR}/audio/libebur128 \ | ||
libspeexdsp.so:${PORTSDIR}/audio/speexdsp \ | ||
libSDL2.so:${PORTSDIR}/devel/sdl20 | ||
|
||
USES= cmake:outsource | ||
USE_LDCONFIG= yes | ||
libspeexdsp.so:${PORTSDIR}/audio/speexdsp | ||
|
||
USE_GITHUB= yes | ||
GH_ACCOUNT= andrewrk | ||
|
||
USES= cmake:outsource | ||
USE_SDL= sdl2 | ||
USE_LDCONFIG= yes | ||
|
||
PLIST_SUB+= VER1=${PORTVERSION:R:R} \ | ||
VER3=${PORTVERSION} | ||
VER3=${PORTVERSION} | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (andrewrk-libgroove-4.1.1_GH0.tar.gz) = a852936e5da65e1729bc85b20e2a6ace71c3813abd77dac44759b3db8659bea6 | ||
SIZE (andrewrk-libgroove-4.1.1_GH0.tar.gz) = 8591724 | ||
SHA256 (andrewrk-libgroove-4.2.1_GH0.tar.gz) = 82ba73ff44a3359f10899a11522521bdc9256b8bfad082a3fac49915e9f4d70f | ||
SIZE (andrewrk-libgroove-4.2.1_GH0.tar.gz) = 46363 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,7 @@ | ||
Audio dispatching library. Generic sink-based interface. Provides decoding, | ||
encoding, resampling, and gain adjustment. Perfect for the backend of a | ||
music player. | ||
This library provides decoding and encoding of audio on a playlist. It is | ||
intended to be used as a backend for music player applications. That said, | ||
it is also generic enough to be used as a backend for any streaming audio | ||
processing utility. It provides decoding, encoding, resampling, and gain | ||
adjustment. | ||
|
||
WWW: https://github.com/andrewrk/libgroove |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (elixir-lang-ecto-v0.14.1_GH0.tar.gz) = ea41db38d3fbae7ea6e3634d8424796cd1f1a3f953088320f8586d71f4407c7e | ||
SIZE (elixir-lang-ecto-v0.14.1_GH0.tar.gz) = 189607 | ||
SHA256 (elixir-lang-ecto-v0.14.2_GH0.tar.gz) = 7c1cdbbcbe716b26d12e12b10a8e2037ae56bb38d7301ed89382adf29c8aaea8 | ||
SIZE (elixir-lang-ecto-v0.14.2_GH0.tar.gz) = 190249 |
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (DBD-mysql-4.031.tar.gz) = ae2ee4339fb13429922d76d37e25ce838f98baa011f691a6bbec8513ddb4cfd2 | ||
SIZE (DBD-mysql-4.031.tar.gz) = 145217 | ||
SHA256 (DBD-mysql-4.032.tar.gz) = b8e681e719d8f2d1cecb9e8603e13483b09b56508629b079022778e7dfd7bfb6 | ||
SIZE (DBD-mysql-4.032.tar.gz) = 146476 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,7 +2,7 @@ | |
# $FreeBSD$ | ||
|
||
DISTVERSION?= 9.0.22 | ||
PORTREVISION?= 0 | ||
PORTREVISION?= 1 | ||
PKGNAMESUFFIX?= ${DISTVERSION:R:S/.//}${COMPONENT} | ||
|
||
MAINTAINER?= [email protected] | ||
|
Oops, something went wrong.